Microsoft Flow에 로그인할 수 없으며 "인증 실패" 오류가 발생합니다.

이 문서에서는 Microsoft Flow에 로그인하려고 할 때 인증 실패 오류가 발생하는 문제에 대한 해결 방법을 제공합니다.

적용 대상: Power Automate
원래 KB 번호: 4316891

증상

Microsoft Flow에 로그인하려고 하면 다음과 유사한 인증 실패 오류 메시지가 표시됩니다.

Flow에 로그인할 때 발생하는 오류 페이지의 스크린샷

메시지의 URL은 다음과 유사할 수 있습니다.

https://flow.microsoft.com/AuthenticationFailed/?message=AADSTS50001%3a+Resource+%27https%3a%2f%2fservice.flow.microsoft.com%2f%27+is+disabled

이 URL은 테넌트가 이 문제의 영향을 받는다는 것을 나타냅니다.

원인

이 문제는 테넌트에서 마지막 흐름 라이선스(또는 Flow를 포함하는 Office 라이선스)가 만료될 때 발생합니다. 이 경우 흐름 서비스는 Microsoft Entra ID 비활성화됩니다.

이 동작은 대부분의 애플리케이션에 적합하지만 Flow를 라이선스 없이 무료로 사용할 수 있더라도 관련 라이선스가 테넌트에서 있는 경우 Flow에 대한 액세스를 차단합니다.

이제 만료된 라이선스로 인해 액세스가 자동으로 비활성화되는 애플리케이션 목록에서 흐름이 제외됩니다. 그러나 이미 사용하지 않도록 설정된 테넌트는 비활성 상태로 되돌아가지 않습니다. 이러한 경우 Flow에 대한 액세스는 차단된 상태로 유지됩니다.

해결 방법

이 문제를 resolve 다음 단계를 수행합니다.

참고

이러한 단계는 테넌트 관리자만 수행할 수 있습니다.

  1. Azure Portal)을 열고 로그인합니다.

  2. 탐색 모음에서 Microsoft Entra 설정을 엽니다.

    탐색 모음의 Microsoft Entra 설정 아이콘 스크린샷

  3. 엔터프라이즈 애플리케이션모든 애플리케이션>으로 이동합니다.

    엔터프라이즈 애플리케이션 항목을 선택한 후 모든 애플리케이션 항목을 선택하는 스크린샷

  4. 7df0a125-d3be-4c96-aa54-591f83ff541c를 필터 입력에 붙여넣습니다.

    참고

    Flow 서비스의 애플리케이션 ID입니다. 표시 목록에서 모든 애플리케이션을 선택해야 할 수 있습니다.

    필터 입력에 7df0a125-d3be-4c96-aa54-591f83ff541c를 붙여넣는 스크린샷

  5. Microsoft Flow Service를 선택한 다음 속성을 선택합니다.

  6. 사용자가 로그인할 수 있도록 설정? 옵션이 예로 설정되어 있는지 확인합니다.

    사용자가 로그인할 수 있도록 설정 필드가 예로 설정되어 검사 스크린샷

  7. 저장을 선택합니다.

이제 모든 사용자가 Flow 포털에 다시 로그인할 수 있습니다.

추가 정보

자세한 내용은 Flow 팀에 이러한 단계와 관련된 문제에 대해 문의하려면 알려진 문제: 로그인 문제를 참조하세요.