AX2009에서 회사를 복사 하는 동안 최대 파일 크기가 초과 되었습니다.

증상

회사를 복제 하려고 할 때 최대 파일 크기를 초과 했다는 오류 메시지가 표시 됩니다. NTFS 형식의 하드 디스크에는 아직 여유 공간이 충분히 있으며, 컴퓨터에는 RAM (>= 20GB) 및 가상 메모리를 충분 하 게 장착 되어 있습니다.   대용량을 복제 또는 가져오기를 시도 하는 경우 DAT 파일 (9GB) 다음과 같은 오류 메시지가 발생 함: "SIN\AppData\Local\Temp\ $tmp 0030005에 쓰는 동안 record = FFFFEB40 Windows 오류: = 오류 코드: 50110 = 최대 파일 크기를 초과 하는 작업이 실패 함"

원인

32 비트 파일 크기 제한 (< 4GB)입니다. 회사 복사 프로세스는 일부 임시 테이블을 사용 하 고 임시 테이블은 특정 크기에 도달 하면 더 이상 캐시에 저장 되지 않으며 하드 디스크의 ISAM 파일 종류에 기록 됩니다. 이 파일에는 4GB 보다 큰 제한이 있습니다.  

해결 방법

를 통해을 최적화 합니다. DAT 파일 내보내기/가져오기 방법: 1을 수행할 수 있는 작업은 여러 가지가 있습니다. 클래스 SysDataImport\classDeclaration TmpRecIdMap 및 TmpTransactionIdMap 테이블을 변경 하 여 임시 테이블 대신 실제 테이블을 사용 합니다.  그렇지 않으면 컴퓨터에서 사용할 수 있는 모든 임시 공간이 소모 될 수 있습니다. 이전 코드-TmpRecIdMap old2NewRecId TmpRecIdMap New받는 Id TmpTableIdMap tmpTableIdMap;//트랜잭션 idTmpTransactionIdMap old2NewCreatedTransactionId; TmpTransactionIdMap old2NewModifiedTransactionId; 새 코드의 예 (4 개의 새 표 사용)-//->ChangeBegin//TmpRecIdMap old2NewRecId:/TmpRecIdMap newRecId    DD_RecIdMapOldRecId old2NewRecId    DD_RecIdMapNewRecId NewTmpTableIdMap Id:/<-ChangeEnd tmpTableIdMap;    거래 id//->ChangeBegin//TmpTransactionIdMap old2NewCreatedTransactionId;//TmpTransactionIdMap old2NewModifiedTransactionId;    DD_TransactionIdMapCreated old2NewCreatedTransactionId    DD_TransactionIdMapModified old2NewModifiedTransactionId//<-ChangeEndDownload 첨부 샘플 xpo는 변경의 예로 사용할 수 있습니다. 2. SQL server에서는 로깅 수준을 간단 하 게 설정 합니다 (과도 한 로깅 방지를 위해 가져오는 동안에만). 3. AX 내에서 여러 정의 그룹을 구성 하 여 여러 개의 개별 테이블 그룹에 데이터를 내보냅니다. 4. 다른 테이블의 의사 Id를 참조 하는 테이블을 관련 테이블과 동일 하 게 유지 하 고, 그렇지 않으면 받는 사람 Id 관계는 유지 되지 않는 경우이를 확인 합니다. 5. 가져오기가 실행 되는 동안 증가 하지 않도록 데이터베이스 파일 크기가 충분히 높게 설정 되어 있는지 확인 합니다. 26. 다음과 같은 "AOS에 실행: 예", "기존 레코드를 검색 하지 않음: 예", "인덱싱: 가져온 후 다시 인덱싱", "레코드 ID 압축 사용: 예" 옵션을 설정 합니다. 7. 별도의 클라이언트에서 각 정의 그룹의 가져오기/내보내기를 실행 하거나 별도의 AOSs를 병렬로 실행할 수도 있습니다. 이러한 옵션을 사용 하면 성능이 최대화 되며, 별도의 가져오기를 병렬로 실행할 때 중단 될 수 있는 단일 오류의 위험을 최소화 하 게 됩니다. "

추가 도움이 필요하신가요?

기술 향상
교육 살펴보기
새로운 기능 우선 가져오기
Microsoft Insider 참가

이 정보가 유용한가요?

소중한 의견에 감사드립니다.

피드백을 주셔서 감사합니다. Office 지원 에이전트와 연락하는 것이 도움이 될 것 같습니다.

×