중요 이 문서에서는 레지스트리 수정 방법을 설명합니다. 레지스트리를 수정하기 전에 해당 레지스트리를 백업하는 것이 좋습니다. 또한 문제가 발생할 경우 레지스트리를 복원하는 방법을 알고 있어야 합니다. 레지스트리 백업, 복원 및 수정 방법에 대한 자세한 내용은 다음 문서 번호를 클릭하여 Microsoft 기술 자료 문서를 참조하십시오.

322756 Windows에서 레지스트리를 백업 및 복원하는 방법

다음과 같은 경우를 생각해 볼 수 있습니다.

  • 클라이언트 컴퓨터가 두 명 이상의 사용자에 의해 사용되거나 터미널 서버 또는 Citrix 환경에서 사용되고 있습니다.

  • 사용자가 오프라인으로 전환합니다. 그런 후 또 다른 사용자가 오프라인으로 전환을 클릭합니다.


이 시나리오에서 두 번째 사용자는 오프라인으로 전환할 수 없습니다. 실제로 다른 어떤 사용자도 오프라인으로 전환할 수 없습니다. 또한 다음과 유사한 내용의 오류 메시지가 나타납니다.

데이터베이스를 삭제하는 동안 오류가 발생했습니다. Microsoft Dynamics CRM 관리자에게 도움을 요청하고 오프라인으로 다시 전환하십시오.

현상

Microsoft Office Outlook용 Microsoft Dynamics CRM에서는 한 명의 사용자만 오프라인으로 전환하도록 구성할 수 있습니다.

원인

이것은 의도적으로 설계된 동작입니다. Microsoft Dynamics CRM 2011에서는 Outlook용 Microsoft Dynamics CRM을 설치한 후 구성할 수 있습니다. 그런 후 오프라인으로 전환 단추를 클릭하여 오프라인 구성 요소를 설치할 수 있습니다.

사용자가 오프라인으로 전환 단추를 클릭할 수 없게 하려면 다음 옵션 중 하나를 사용합니다.

옵션 1



오프라인으로 전환 단추를 볼 수 없게 하려는 사용자에 대해 오프라인으로 전환 권한을 제거합니다. 이렇게 하려면 다음과 같이 하십시오.

  1. CRM 보안 역할을 변경할 권한이 있는 사용자의 경우 설정, 관리 및 보안 역할을 차례로 클릭합니다.

  2. 변경해야 하는 보안 역할을 클릭하여 엽니다. (예를 들어 영업 관리자 클릭)

  3. 비즈니스 관리 탭을 클릭한 후 기타 권한 섹션에서 오프라인으로 전환 확인란을 클릭하여 선택 취소합니다.

  4. 저장을 클릭한 후 닫기를 클릭합니다.

    참고 클라이언트가 이미 구성된 경우 클라이언트 도구 모음에서 이 단추가 사라질 때까지 5분 이상이 걸릴 수 있습니다.

옵션 2



각 컴퓨터에서 모든 사용자에 대해 오프라인으로 전환 단추를 사용 불가능하게 설정한 후 disableofflinecapability 스위치를 사용하여 Outlook용 Microsoft Dynamics CRM을 설치합니다. 이렇게 하려면 다음과 같이 하십시오.

  1. 시작, 실행을 차례로 클릭하고 Setupclient.exe 파일 경로를 입력합니다.

  2. /disableofflinecapability 스위치를 설정하여 Outlook용 Microsoft Dynamics CRM을 설치합니다. (예를 들어 C:\Client\i386\SetupClient.exe /disableofflinecapability 명령 사용)

  3. 지금 설치를 클릭하거나 /q 스위치를 사용하여 사용자 프롬프트 없는 자동 설치를 수행합니다.

옵션 3



경고 레지스트리 편집기나 다른 방법을 사용하여 레지스트리를 잘못 수정하면 심각한 문제가 발생할 수 있습니다. 이러한 문제를 해결하기 위해 운영 체제를 다시 설치해야 할 수도 있습니다. Microsoft는 이러한 문제의 해결을 보증하지 않습니다. 레지스트리 수정에 따른 모든 책임은 사용자에게 있습니다.

Outlook용 Microsoft Dynamics CRM Client를 이미 설치한 경우 해당 구성을 실행하는 새 사용자에게 오프라인으로 전환 단추가 보이지 않도록 LightClient 레지스트리 키를 변경할 수 있습니다. 이렇게 하려면 다음과 같이 하십시오.

  1. 시작, 실행을 차례로 클릭하고 Regedit를 입력한 후 확인을 클릭합니다.

  2. 다음 레지스트리 하위 키를 찾습니다.

    HKEY_CURRENT_USER\Software\Microsoft\MSCRMClient

  3. LightClient 레지스트리 키를 마우스 오른쪽 단추로 클릭한 다음 수정을 클릭합니다.

  4. 을 1로 변경하고 10진수를 선택한 후 확인을 클릭합니다.

  5. Outlook용 Microsoft Dynamics CRM을 시작합니다.

    참고 클라이언트가 이미 구성된 경우 클라이언트 도구 모음에서 이 단추가 사라질 때까지 5분 이상이 걸릴 수 있습니다.

  6. 다음 레지스트리 하위 키를 찾습니다.

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRMClient
    참고 64비트 클라이언트 컴퓨터를 사용하고나 3비트 버전의 Microsoft Office가 설치되어 있는 경우 해당 레지스트리 하위 키는 다음과 같습니다.

    HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\MSCRMClient

  7. LightClient 레지스트리 키를 마우스 오른쪽 단추로 클릭한 후 수정을 클릭합니다.

  8. 을 1로 변경하고 10진수를 선택한 후 확인을 클릭합니다. 새 구성이 실행되면 오프라인으로 전환 단추가 제거됩니다.


참고 HKEY_CURRENT_USER에서 레지스트리 항목을 변경하면 현재 로그인한 사용자에게 변경 내용이 적용됩니다. 변경 내용을 여러 사용자에게 적용하려면 HKEY_Users\ 아래에서 해당 레코드를 찾습니다. 또는 그룹 정책을 사용하여 여러/다른 사용자에게 키를 적용합니다.

해결 방법

사용자가 이미 오프라인 상태이고 다른 사용자가 같은 컴퓨터에서 오프라인으로 전환할 수 있게 하려면 이전 사용자에서 데이터베이스를 삭제해야 합니다. SQL Express 데이터베이스 삭제 방법에 대한 자세한 내용은 다음 MSDN(Microsoft Developer Network) 웹 사이트를 참조하십시오.

http://msdn.microsoft.com/ko-kr/library/ms178613.aspx

추가 정보

추가 도움이 필요하신가요?

기술 향상
교육 살펴보기
새로운 기능 우선 가져오기
Microsoft Insider 참가

이 정보가 유용한가요?

번역 품질에 얼마나 만족하시나요?
사용 경험에 어떠한 영향을 주었나요?

소중한 의견에 감사드립니다.

×