동기화 문제는 Outlook 및 Outlook Web App에서 발생합니다.

증상

Microsoft Outlook 또는 Microsoft Outlook Web App(이전의 Outlook Web Access)에서 동기화 문제가 발생하면 다음과 같은 증상이 나타날 수 있습니다.

  • 증상 1

    Microsoft Outlook Web App과 비교하여 Microsoft Outlook에서 받는 메시지 간에 차이나 불일치가 나타납니다.

  • 증상 2

    Outlook에 문제가 있지만 캐시 모드가 비활성화되어 있으면 문제가 발생하지 않습니다.

  • 증상 3

    Outlook의 오프라인 폴더 파일(.ost)을 Microsoft Exchange Server를 실행하는 서버의 사서함과 동기화할 때 오류 메시지가 표시되는 경우가 있습니다. 오류 메시지가 다음과 같을 수 있습니다.

    Microsoft Outlook을 시작할 수 없습니다. Outlook 창을 열 수 없습니다. 폴더 집합을 열 수 없습니다. c:\Users\<username>\AppData\Local\Microsoft\Outlook<username@domain.com.ost> 파일은 Outlook 데이터 파일(ost)이 아닙니다.

  • 증상 4

    .ost 파일과 사서함을 동기화한 후 이메일 메시지, 약속, 연락처, 작업, 업무 일지, 메모, 게시된 항목 및 문서와 같은 일부 항목이 .ost 파일이나 사서함에서 누락되었음을 알 수 있습니다.

원인

이러한 증상이 발생하거나 동기화하는 데 다른 문제가 있는 경우 손상된 .ost 파일이 원인일 수 있습니다.

해결 방법

Outlook 2003 및 Outlook 2007:

OST 무결성 검사 도구(Scanost.exe)를 사용하여 .ost 파일의 불일치를 확인합니다.

Outlook 2010 이상 버전:

OST 무결성 검사 도구(scanost.exe)는 Outlook 2010 이상 버전에 포함되어 있지 않습니다. 이 도구는 Outlook 데이터 파일(.ost)의 오류를 수정하기 위해 이전 버전에서 권장되었습니다. 특정 폴더에 문제가 있는 경우 Outlook에서 폴더를 다시 동기화할 수 있습니다. 이렇게 하려면 다음과 같이 하십시오.

  1. 폴더를 마우스 오른쪽 단추로 클릭한 후 속성을 선택합니다.
  2. 오프라인 항목 지우기를 선택한 다음 확인을 선택합니다.
  3. Outlook 2010 리본에서 보내기/받기 탭을 선택합니다.
  4. 폴더 업데이트를 선택합니다.

이러한 방법으로 문제가 해결되지 않으면 .ost 파일을 다시 빌드하는 것이 좋습니다. 이렇게 하려면 .ost 파일을 삭제한 다음 Outlook이 Exchange Server에서 정보를 다시 다운로드하도록 합니다. 자세한 내용은 이 문서의 추가 정보 섹션을 참조하세요.

그러나 서버에 없는 로컬 데이터가 있는 경우는 예외입니다. 이 경우 다음 단계를 수행하는 것이 좋습니다.

  1. 데이터를 Outlook 데이터 파일(.pst)로 내보낸 다음 .ost 파일을 삭제합니다.
  2. 서버 데이터를 다시 다운로드한 다음 중복 가져오기 안 함 옵션을 사용하여 .pst 파일 데이터를 가져옵니다. 이 옵션에 액세스하려면 파일 탭을 선택한 다음 열기 옵션을 선택합니다.

추가 정보

OST 무결성 검사 도구는 .ost 파일에서만 실행되며 동기화 문제를 진단하고 복구하는 데 사용할 수 있습니다. .ost 파일의 로컬 복사본과 Exchange Server 사서함을 검사합니다. 이 도구는 파일과 사서함의 항목과 폴더를 비교하고 파일과 사서함 간의 동기화 차이를 조정하려고 합니다. OST 무결성 검사 도구는 Exchange Server 사서함을 변경하지 않습니다. 이 도구는 검색 로그의 차이점을 기록하므로 도구가 검색하고 해결한 차이점을 확인할 수 있습니다. 또한 검사 로그는 도구가 해결할 수 없고 수동으로 수정해야 하는 상황을 식별합니다. 검사 로그는 지운 편지함 폴더에 있습니다.

OST 무결성 검사 도구(Scanost.exe)는 실행 중인 Outlook 버전에 맞게 다음 위치에 Outlook을 설치하면 설치됩니다.

Outlook 2003의 경우: drive:\Program Files\Common Files\System\MSMAPI\LocaleID 폴더. 이 예제에서 LocaleID는 Microsoft Office 설치를 위한 LCID(로케일 식별자)입니다. 영어 - 미국의 LCID는 1033입니다.

Outlook 2007: 드라이브:\Program Files\Microsoft Office\OFFICE12

Scanost.exe를 사용하여 오류를 복구하는 방법

  1. Outlook 2003 또는 Outlook 2007이 실행 중인 경우 종료합니다.

  2. Scanost.exe를 두 번 클릭합니다.

  3. 프로필을 묻는 메시지가 표시되도록 Outlook을 설정한 경우 도구는 프로필도 묻는 메시지를 표시합니다. 프로필 이름 목록에서 확인할 .ost 파일이 포함된 프로필을 선택합니다. 연결 또는 오프라인으로 작업 메시지가 표시되면 연결을 선택합니다.

  4. 원하는 옵션을 선택합니다. 도구가 검색 중에 발견한 차이점을 자동으로 해결하도록 하려면 오류 복구 확인란을 선택합니다. 이 확인란의 선택을 취소하면 도구에서 문제를 기록합니다. 그러나 도구는 필요한 수정 작업을 하지 않습니다.

  5. 검사 시작을 선택합니다.

참고

검사 로그를 보려면 Outlook을 시작한 다음 지운 편지함 폴더를 엽니다. 도구는 지운 편지함 폴더를 검사하지 않습니다. 모든 문제는 제목이 "OST 무결성 검사"인 메시지에 표시됩니다.

.ost 파일을 열려고 할 때 문제가 발생하면 받은 편지함 오류 수정 도구(Scanpst.exe)를 사용하여 .ost 파일의 오류를 진단하고 복구할 수 있습니다. 받은 편지함 복구 도구는 .ost 파일과 개인 폴더(.pst) 파일 모두에서 사용할 수 있습니다. 받은 편지함 복구 도구는 .ost 또는 .pst 파일을 검사하고 파일 구조가 그대로인지 확인합니다. 또한 도구는 필요한 경우 내부 데이터 구조를 복구하려고 합니다. 도구는 Exchange Server 사서함과 상호 작용하지 않습니다.

.ost 파일을 다시 빌드하는 방법

  1. 실행 중인 운영 체제에 맞게 다음 폴더를 찾습니다.

    Windows XP: C:\Documents and Settings\<alias>\Local Settings\Application Data\Microsoft\Outlook
    Windows Vista 이상 버전: C:\Users\<alias>\AppData\Local\Microsoft\Outlook

  2. 폴더가 표시되지 않으면 폴더 숨기기를 취소합니다. 이렇게 하려면 다음과 같이 하십시오.

    Windows 8 및 Windows 10:

    보기 탭에서 숨겨진 항목 확인란과 파일 확장명 확인란을 선택합니다.

    Windows 7:

    • 구성 메뉴에서 폴더 및 검색 옵션을 선택합니다.
    • 보기 탭을 선택한 다음 숨겨진 파일, 폴더 및 드라이브 표시 옵션을 선택한 다음 알려진 파일 형식의 파일 확장명 숨기기 확인란의 선택을 취소합니다.

    Windows XP:

    • 도구 메뉴에서 폴더 옵션을 선택합니다.
    • 보기 탭을 선택한 다음 숨겨진 파일 및 폴더 표시 확인란을 선택한 다음 알려진 파일 형식의 파일 확장명 숨기기 확인란의 선택을 취소합니다.
  3. 기본적으로 Outlook은 사용자의 로컬 캐시를 위해 Outlook.ost를 만듭니다. Outlook.ost 파일이 이미 있는 경우 Outlook은 파일 이름 끝에 숫자를 삽입합니다(예: Outlook0.ost 또는 Outlook1.ost). .ost 파일의 이름을 바꿉니다. 이렇게 하려면 .ost 파일 이름 확장명의 이름을 .old(으)로 바꿉니다. .ost 파일 이름 확장명이 표시되지 않으면 2A 및 2B단계에 설명된 대로 알려진 파일 형식의 확장명 숨기기 확인란을 선택 취소해야 합니다.

  4. "파일이 사용 중입니다" 오류 메시지가 나타나면 CTRL+ALT+DELETE를 누른 다음 작업 관리자를 선택합니다. 프로세스 탭을 선택하고 Outlook.exe 및 Winword.exe가 프로세스 목록에 표시되지 않는지 확인합니다. 이러한 프로세스가 목록에 표시되면 각 파일을 선택한 다음 프로세스 종료를 선택합니다.

  5. .ost 파일의 이름을 바꾼 후 Outlook을 다시 시작합니다. "처음 사용할 준비 중입니다." 메시지가 나타납니다. 사서함이 동기화될 때까지 기다립니다. 이 프로세스는 사용자의 사서함 크기에 따라 달라집니다.

  6. 사서함이 동기화된 후에도 문제가 계속 발생하는지 테스트합니다. 그래도 문제가 발생하면 .ost 파일이 문제의 원인이 아닙니다.

다른 문제로 인해 유사한 오류가 발생하는 경우 legacyExchangeDN의 마지막 문자가 공백인 경우 Outlook의 상태 표시줄에 연결 끊김이 표시됨을 참조하세요.