Jūs negalite įdiegti vieningosios ryšių valdomos API perskirstymo ir neaiškios klaidos pranešimą


Požymiai


Turite kompiuterį, kuriame yra Microsoft Visual C ++ 2008 pakeitimų paketo 1 perskirstomąjį paketą versija įdiegta 9.0.30729. Jei bandote įdiegti "Microsoft" vieningosios ryšių valdomos API perskirstymo programa (UCMARedist.msi), įdiegti nepavyksta. Be to, Jūs gaunate tokį klaidos pranešimą:
"Microsoft" vieningosios ryšių valdomos API 2.0 Core Redist įdiegti arba pašalinti reikalauja, kad VC ++ 2008 perskirstomojo paketo jau yra įdiegtas.
Šis klaidos pranešimas neaišku, nes dar nereiškia, kad būtinas konkrečios versijos Visual C ++ 2008 perskirstomąjį paketą.

Sprendimas


Norėdami išspręsti šią problemą, nepavyksta įdiegti į "Microsoft" vieningosios ryšių valdomos API perskirstymo programa, atsisiųskite ir įdiekite Microsoft Visual C ++ 2008 Redistributable paketą versija 9.0.21022--klaida iš šioje Microsoft svetainėje:

Būsena


„Microsoft“ patvirtino, kad tai yra „Microsoft“ produktų, išvardytų skyriuje „Taikoma“, problema.

Daugiau informacijos


Jei norite gauti daugiau informacijos apie į "Microsoft" vieningosios ryšių valdomos API perskirstymo (UCMARedist.msi), apsilankykite šioje "Microsoft" žinių bazės straipsnį:
976657 Office Communications Server 2007 R2, vieningosios ryšių valdomos API 2.0 Core Redist 64 bitų kaupiamojo naujinimo aprašas: 2010 m. balandžio