Bendradarbiavimo duomenų objektai (CDO) 1.2.1 nepalaikomi naudojant "Outlook" 2010 ir vėlesnes versijas

Suvestinė

Nors bendradarbiavimo duomenų objektų (CDO) 1.2.1 objektų biblioteką galima naudoti su "Microsoft Outlook 2010" ir vėlesne verisons, mes jokiu būdu nerekomenduojame ir nepalaikome.

Svarbu: Šis straipsnis taikomas naudojant "CDO 1.2.1" klientą kartu su "Outlook" 2010 ir naujesnėmis versijomis. Ji netaikoma CDO 1.2.1, kuri įdiegia MAPI posistemę ir kuri yra skirta naudoti kompiuteryje be programos "Outlook", naudojimui.

Daugiau informacijos

Bendradarbiavimo duomenų objektai (CDO) 1.2.1 yra kliento biblioteka, kuri suteikia ploną pakuotę su išplėstomis MAPI funkcijomis. Ši biblioteka paprastai naudojama el. laiškų siuntimo funkcijoms įtraukti į pasirinktųjų programų. Ši biblioteka leidžia šioms programoms atlikti funkcijas, pvz., siųsti laiškus per MAPI, dirbti su kalendoriais ir pasiekti įvairius duomenis programoje "Microsoft Outlook" arba "Microsoft Exchange".

"Microsoft Outlook 2010" ir naujesnėse versijose yra daug architektūros pasikeitimų kliento MAPI posistemyje. Ypatingą susirūpinimą kelia scenarijai, kai "Outlook" sukonfigūruota naudoti kelias "Exchange" paskyras. Be to, CDO 1.2.1 yra 32 bitų klientų biblioteka ir neveiks su 64 bitų "Outlook" versijomis. Atsižvelgiant į visus šiuos faktorius, CDO 1.2.1 nepalaikomas naudoti su "Outlook 2010" arba naujesnėmis versijomis, todėl nerekomenduojame jo naudoti su "Outlook 2010" ir naujesnėmis versijomis.

Programos, kurios naudoja CDO, turi būti iš naujo sukurtos naudoti kitas taikomųjų programų programavimo sąsajas (API), o ne CDO. Pradedant nuo "Outlook 2007", "Outlook" objekto modelis buvo labai išplėstas, kad būtų galima atlikti anksčiau tik naudojant CDO 1.2.1. "Outlook 2010" ir naujesnėse versijose objekto modelyje yra kelios naujos funkcijos, kurias galima toliau plėsti. Pvz., "Outlook" objekto modelyje yra naujų funkcijų, kurios veikia tinkamai su keliomis "Exchange" paskyromis. "Outlook" objekto modelis taip pat veikia ir 32 bitų, ir 64 bitų "Outlook" versijose. Kūrėjai turėtų naudoti "Outlook 2010" ir vėlesnį objekto modelį vietoj CDO 1.2.1. Be to, kūrėjai vis tiek gali naudoti išplėstinę MAPI (kuri reikalauja nevaldomo C++) kai kuriuose scenarijuose, kuriuose buvo būtinas CDO. Tačiau jei įmanoma, paprastai rekomenduojame naudoti "Outlook" objekto modelį vietoj išplėstinės MAPI.

"Microsoft" produktų palaikymas gali padėti programuotojams klientams perkelti "CDO 1.2.1" naudoti "CDO 1.2.1" naudojant kitas API. Tačiau "Microsoft" neteikia palaikymo jokiems scenarijams, kai CDO 1.2.1 naudojama su "Outlook 2010" arba "Outlook 2013".

Reikia daugiau pagalbos?

Tobulinkite savo įgūdžius
Ieškoti mokymo
Pirmiausia gaukite naujų funkcijų
Prisijungti prie "Microsoft Insider"

Ar ši informacija buvo naudinga?

Dėkojame už jūsų atsiliepimus!

Dėkojame už jūsų atsiliepimą! Panašu, kad gali būti naudinga jus sujungti su vienu iš mūsų „Office“ palaikymo agentų.

×