Custom Entity Does Not Appear After Importing A Solution

Symptoms

After importing a solution into another organization the custom entity does not show up.

Cause

This happens when the solution does not have SiteMap as a component.

This also can happen if you do not publish your customizations after importing the solution.

Resolution

Resolution 1:
Include SiteMap as part of the solution and re-export the solution. Then import the solution into another organization.
  1. Click Settings, click Solutions and open the solution you want to modify.
  2. Click Client Extensions, click Add Existing and choose Site Map.
  3. Click Save.
  4. Click Export Solution and follow the export wizard to export your solution.

Resolution 2:
Customize the imported custom entity on the organization where the solution has been imported, to show the entity in the area you want like Workplace.
  1. Click Settings, click Customizations and click Customize the System.
  2. Under Components, expand Entities and select the entity you want to modify.
  3. Under the Areas that display this entity, select the areas to display the custom entity.
Resolution 3:

Publish All Customizations:
  1. Click Settings, click Customizations and click Customize the System.
  2. Click Publish All Customizations.
Publish just the custom entity:
  1. Click Settings, click Customizations and click Customize the System.
  2. Under Components, expand Entities and select the entity you want to publish.
  3. Click Publish on the ribbon.

Rekvizīti

Raksta ID: 2500942. Pēdējo reizi pārskatīts: 2011. gada 25. janv.. Pārskatījums: 1

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