Intermittent search and indexing failures

Symptom

While using FAST ESP, one may experience search or indexing outages with the following messages found in the Application Event Logs and the FAST-specific log files:

This application has requested the Runtime to terminate it in an unusual way.

Cause

This is often the result of paged pool exhaustion in Windows 2003, resulting in memory operations that do not work as expected.

Resolution

The FAST ESP release notes recommend the following keys be set to tune Windows memory management:

Path: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

Value: SystemCacheDirtyPageThreshold
Type: REG_DWORD
Data (decimal): 2048
Data (hexadecimal): 800

Value: PoolUsageMaximum
Type: REG_DWORD
Data (decimal): 60
Data (hexadecimal): 3C

Value: PagedPoolSize
Type: REG_DWORD
Data (decimal): 4294967295
Data (hexadecimal): FFFFFFFF

Path: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager

Value: HeapDecommitFreeBlockThreshold
Type: REG_DWORD
Data (decimal): 262144
Data (hexadecimal): 40000

More Information

The boot flag /3GB can result in similar behavior, and is unsupported. It should be removed from boot.ini if present. Any modification to the registry or boot settings should be followed by a server reboot.
Rekvizīti

Raksta ID: 2514995. Pēdējo reizi pārskatīts: 2011. gada 31. aug.. Pārskatījums: 1

Atsauksmes