TFS test manager - run test error: 403: Forbidden

Symptom

Error running any test case within Test Manager: “The request failed with HTTP status 403: Forbidden”  

Cause

When we looked at the IIS log for the request that is passed from the test manager client to the TFS server, we found that the request was initiated against the server through port 8143. Port 8143 was a binding for HTTPS. But later the request switches to port number 8080 and that’s when a 403 exception was thrown.



IIS log snippet:

2011-04-26 21:13:24 <Server name> POST /tfs/Main/TestManagement/v1.0/TestResults.asmx - 8143 - 10.1.21.30 Team+Foundation+(mtm.exe,+10.0.30319.1) 401 2 5 15  
2011-04-26 21:13:24 <Server name> POST /tfs/Main/TestManagement/v1.0/TestResults.asmx - 8143 <Domain>\<User login> 10.1.21.30 Team+Foundation+(mtm.exe,+10.0.30319.1) 200 0 0 62  
2011-04-26 21:13:24 <Server name> POST /tfs/Main/TestManagement/v1.0/TestResults.asmx - 8143 - 10.1.21.30 Team+Foundation+(mtm.exe,+10.0.30319.1) 401 2 5 31  
2011-04-26 21:13:24 <Server name> POST /tfs/Main/TestManagement/v1.0/TestResults.asmx - 8143 <Domain>\<User login> 10.1.21.30 Team+Foundation+(mtm.exe,+10.0.30319.1) 200 0 0 46  
2011-04-26 21:13:24 <Server name> POST /tfs/Main/TestManagement/v1.0/TestResults.asmx - 8143 - 10.1.21.30 Team+Foundation+(mtm.exe,+10.0.30319.1) 401 2 5 46  
2011-04-26 21:13:24 ::1 POST /tfs/Main/Services/v1.0/Registration.asmx - 8080 - ::1 Team+Foundation+(w3wp.exe,+10.0.30319.1) 403 4 5 15
2011-04-26 21:13:24 <Server name> POST /tfs/Main/TestManagement/v1.0/TestResults.asmx - 8143 <Domain>\<User login> 10.1.21.30 Team+Foundation+(mtm.exe,+10.0.30319.1) 500 0 0 46  
2011-04-26 21:13:24 <Server name> POST /tfs/Main/TestManagement/v1.0/TestResults.asmx - 8143 - 10.1.21.30 Team+Foundation+(mtm.exe,+10.0.30319.1) 401 2 5 15  
2011-04-26 21:13:24 <Server name> POST /tfs/Main/TestManagement/v1.0/TestResults.asmx - 8143 <Domain>\<User login>10.1.21.30 Team+Foundation+(mtm.exe,+10.0.30319.1) 200 0 0 234  

The Registration.asmx request is an internal server to server call.  

This was evident that server is configured to use port 8080.

Resolution

While we checked the configuration of the server on the TFS admin console, we found that the Notification and the Server URLs were set to the netbios name of the server and Port 8080.  
We changed the notification and server urls to the FQDN name of the server and port 8143. This fixed the issue.  
Rekvizīti

Raksta ID: 2546867. Pēdējo reizi pārskatīts: 2011. gada 5. maijs. Pārskatījums: 1

Atsauksmes