Šobrīd esat bezsaistē, tiek gaidīts atkārtots savienojums ar internetu

Sadarbības datu objekti (CDO) 1.2.1 netiek atbalstīts ar Outlook 2010 un jaunākas versijas

SVARĪGI! Šis raksts ir tulkots, izmantojot Microsoft mašīntulkošanas programmatūru, un šo rakstu nav tulkojis cilvēks. Microsoft piedāvā gan rakstus, ko tulkojuši cilvēki, gan mašīntulkotus rakstus, tāpēc jebkuram zināšanu bāzes rakstam varat piekļūt savā dzimtajā valodā. Tomēr mašīntulkotu rakstu kvalitāte ne vienmēr ir teicama. Šādos rakstos var būt leksikas, sintakses vai gramatikas kļūdas, kas līdzinās kļūdām, kādas pieļauj ārzemnieks, runājot jūsu valodā. Microsoft neuzņemas atbildību par jebkādām neprecizitātēm, kļūdām vai bojājumiem, ko izraisījis kļūdains satura tulkojums vai kas radušās tulkojuma lietojuma gaitā. Turklāt Microsoft regulāri atjaunina mašīntulkošanas programmatūru.

Noklikšķiniet šeit, lai skatītu šī raksta versiju angļu valodā: 2028411
KOPSAVILKUMS

Lai gan sadarbības datu objekti (CDO) 1.2.1 objektu bibliotēka varētu izmantot ar Microsoft Outlook 2010, un Microsoft Outlook 2013, mums nav ieteikt vai jebkādā veidā atbalstīt šo.

Svarīgi: Šis pants attiecas uz, izmantojot CDO 1.2.1 klienta pusē kopā ar Outlook 2010 un jaunākām versijām. Tas neattiecas uz izmantojot CDO 1.2.1 kas instalē MAPI apakšsistēmas un kas ir paredzēta lietošanai bez Outlook datoros.

PAPILDINDORMĀCIJA

Sadarbības datu objekti (CDO) 1.2.1 ir klienta bibliotēka, kas nodrošina plānas ievietošanas (wrapper) pār Extended MAPI funkcionalitāti. Šīs bibliotēkas parasti lieto, lai pievienotu e-pasta ziņapmaiņas funkcionalitāte, lai pielāgotu programmu. Šī bibliotēka ļauj programmām, ļauj veikt tādas funkcijas kā, piemēram, nosūtot e-pastu, izmantojot MAPI, strādājot ar kalendāru un piekļūt dažādiem datiem programmā Microsoft Outlook vai Microsoft Exchange.

Sākot ar programmu Outlook 2007, CDO 1.2.1 nav bijis iekļauts programmā Microsoft Outlook. Taču CDO 1.2.1 ir pieejama tikai kā lejupielādi programmā Outlook 2007:

http://www.Microsoft.com/downloads/details.aspx?familyid=2714320d-c997-4de1-986f-24f081725d36&DisplayLang=EN

Šo lejupielādes failu var instalēt tikai datorā, kurā instalēta programma Outlook 2007. Ja Outlook nav instalēts, tiek parādīts šāds kļūdas ziņojums, palaižot ExchangeCdo.msi failu:

Collaboration Data Objects 1.2.1 nevar instalēt, ja ir instalēts Microsoft Office Outlook 2007.

Lai gan CDO lejupielādējama versija nav instalēta, instalējot Outlook 2010 vai Outlook 2013, jūs varētu instalēt CDO vispirms ar Outlook 2007 pirms jaunināšanas uz programmu Outlook. Šādā gadījumā programmas joprojām var izmantot CDO bibliotēkas integrēt ar Outlook 2010 un MAPI Outlook 2013 versiju.

Tomēr mēs iesakām, ka CDO vispirms atinstalēt pirms Outlook jaunināt no programmas Outlook 2007 Outlook 2010 un jaunākām versijām.

Microsoft Outlook 2010 un jaunākas versijas ietver daudzas arhitektūras izmaiņas klienta pusē MAPI apakšsistēmā. Īpašas bažas ir scenāriji, kuros Outlook ir konfigurēts, lai lietotu vairākus Exchange e-pasta kontiem. Arī CDO 1.2.1 ir 32-bitu klienta bibliotēka un nedarbosies ar 64-bitu programmas Outlook versijām. Ņemot vērā visus šos faktorus, CDO 1.2.1 netiek atbalstītas izmantošanai ar 2013 programmu Outlook vai Outlook 2010, un nav ieteicams tās izmantot ar Outlook 2010 un jaunākas versijas.

Programmas, kas izmanto CDO būtu uzticamāk CDO vietā izmantot citu lietojumprogrammu programmēšanas interfeisi (API). Sākot ar programmu Outlook 2007, Outlook objektu modelis ievērojami paplašināja nodrošina funkcionalitāti, kas tika iepriekš bija pieejamas tikai izmantojot CDO 1.2.1. Outlook 2010 un 2013 Outlook objekta modelis ietver dažas jaunas iespējas paplašināt par to vairāk. Piemēram, Outlook objektu modelis ir jaunu funkcionalitāti, lai pareizi strādātu ar vairākiem Exchange e-pasta kontiem. Outlook objekta modelis darbojas arī Outlook gan 32 bitu un 64 bitu versijām. Izstrādātājiem vajadzētu izmantot Outlook 2010 un vēlāk objekta modeli tā vietā, lai CDO 1.2.1. Arī attīstītāji joprojām varat izmantot Extended MAPI (kas prasa nepārvaldītu C++) Dažos scenārijos kur CDO bija vajadzīgs. Tomēr, ja tas ir iespējams, parasti iesakām izmantot Outlook objekta modelis, nevis jālieto Extended MAPI.

Microsoft produktu atbalsta darbiniekiem var palīdzēt attīstītājs klienti migrē no izmantojot CDO 1.2.1, izmantojot citu API pielāgotām programmām. Tomēr, Microsoft nav sniegs atbalstu visiem scenārijiem CDO 1.2.1 lieto ar Outlook 2010 vai Outlook 2013.

Brīdinājums: šis raksts ir tulkots automātiski

Rekvizīti

Raksta ID: 2028411. Pēdējo reizi pārskatīts: 04/02/2013 22:00:00. Pārskatījums: 1.0

  • kbmt KB2028411 KbMtlv
Atsauksmes
or="var m=document.createElement('meta');m.name='ms.dqp0';m.content='true';document.getElementsByTagName('head')[0].appendChild(m);" onload="var m=document.createElement('meta');m.name='ms.dqp0';m.content='false';document.getElementsByTagName('head')[0].appendChild(m);" src="http://c1.microsoft.com/c.gif?">