You receive a "There was a problem that caused parts of the Microsoft Online Services Sign-in Assistant to be disabled" error

Problem

You experience sign-in issues in a Microsoft cloud service such as Microsoft 365, Microsoft Azure, or Microsoft Intune. Specifically, you see a pop-up dialog box that contains the following error message:

There was a problem that caused parts of the Microsoft Online Services Sign-in Assistant to be disabled. The problem may have been caused by a program that was recently installed.

Cause

This problem occurs when the Microsoft Online Services Sign-in Assistant detects that an issue occurred in the Microsoft Online Services Sign-in Assistant service. In this situation, the connection to the service is ended.

Solution

To restart the Microsoft Online Services Sign-in Assistant service, follow these steps:

  1. Click Start, and then click Run.

  2. In the Open box, type services.msc, and then press Enter.

    Screenshot of the Run window with services.msc typed.

  3. In the list of services, locate and then double-click the Microsoft Online Services Sign-in Assistant service.

    Screenshot to select the Microsoft Online Services Sign-in Assistant in the Services window.

  4. Stop the service. To do this, click Stop, and then wait until the service stops. The Service status should be displayed as Stopped.

    Screenshot of the Online Services Sign-in Assistant properties window, showing the Service status is stopped.

  5. Start the service. To do this, click Start, and then wait until the service starts. The Service status should be displayed as Started.

    Screenshot of the Online Services Sign-in Assistant properties window, showing the Service status is started.

  6. Verify that the issue is resolved and the pop-up dialog box is no longer displayed.

  7. If you continue to see the pop-dialog box, restart the computer, and then verify that the issue is resolved.

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More Information

For more information about related technical issues, see the following Microsoft Knowledge Base article:

2637629 How to troubleshoot non-browser apps that can't sign in to Microsoft 365, Azure, or Intune

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