Du er frakoblet, venter på at Internett skal koble til igjen

"Kan ikke laste inn type 'System.Security.Authentication.ExtendedProtection.ExtendedProtectionPolicy'" feil når du har installert oppdateringen 982167 eller 982168-oppdateringen

Kundestøtte for Windows XP er avsluttet

Microsoft avsluttet kundestøtte for Windows XP den 8. april 2014. Denne endringen har påvirket programvareoppdateringene og sikkerhetsalternativene dine. Finn ut hvordan dette påvirker deg og hvordan du forblir beskyttet.

Kundestøtte for Windows Server 2003 opphørte 14. juli 2015

Microsoft avsluttet kundestøtte for Windows Server 2003 den 14. juli 2015. Denne endringen har påvirket programvareoppdateringene og sikkerhetsalternativene dine. Finn ut hvordan dette påvirker deg og hvordan du forblir beskyttet.

VIKTIG: Denne artikkelen ble oversatt med maskinoversettelsesprogramvare fra Microsoft og muligens redigert av Microsoft Community via CTF-teknologi i stedet for av en oversetter. Microsoft tilbyr både menneskelig oversatte og maskinoversatte/Community-redigerte artikler, slik at du får tilgang til alle artiklene i vår Knowledge Base på ditt eget språk. En maskinoversatt eller Community-redigert artikkel er imidlertid ikke alltid perfekt. Den kan inneholde feil i vokabular, syntaks eller grammatikk, mye likt en fremmedspråklig som forsøker å snakke språket ditt. Microsoft har ikke ansvar for unøyaktige opplysninger, feil eller skade forårsaket av feilaktig oversettelse av innholdet eller kundenes bruk av informasjonen. Microsoft oppdaterer jevnlig maskinoversettelsesprogramvaren og -verktøyene for å forbedre redigering av maskinoversatte tekster.

Den engelske versjonen av denne artikkelen er den følgende: 2262911
Symptom
Når du har installert oppdateringen 982167 eller 982168-oppdateringen, kan du få en unntak-feilmelding som ligner på følgende når du kjører Windows Communication Foundation-baserte programmer:
Kan ikke laste typen ' System.Security.Authentication.ExtendedProtection.ExtendedProtectionPolicy
Årsak
Oppdater 982167 og Oppdater 982168 laget av oppdateringen for .NET Framework 2.0-funksjonen i .NET Framework 3.5 SP1 til å introdusere den nye typen 'System.Security.Authentication.ExtendedProtection.ExtendedProtectionPolicy'. Denne nye typen brukes av den tilsvarende nye funksjonen i Windows Communication Foundation.

Feilen forekommer fordi den underliggende klientbibliotek for .NET Framework 2.0 SP2 nettverk funksjonen Lag ikke er oppdatert når funksjonen laget Windows Communication Foundation er oppdatert til å bruke den nye typen. Den underliggende klientbibliotek for .NET Framework 2.0 SP2 nettverk funksjonen Lag støtter ikke denne nye typen, og så denne feilen har oppstått.

Denne situasjonen kan oppstå av flere grunner, inkludert visse feil problemer som er relatert til dual branch servicing. Hvis du vil ha mer informasjon, kan du klikke følgende artikkelnummer for å vise artikkelen i Microsoft Knowledge Base:
960043 Dual Branch Servicing for .NET Framework 2.0 Service Pack 2, .NET Framework 3.0 Service Pack 2 og .NET Framework 3.5 Service Pack 1
Workaround
Hvis du vil omgå dette problemet, gjør du følgende:
  1. Installere hurtigreparasjon 975954. Hvis du vil laste ned MSI-oppdateringer, kan du gå til følgende MSDN-websiden:
  2. Kjør en reparasjon av produktet. Vi kan reparere produktet for deg automatisk, eller du kan reparere produktet selv.

    Løs problemet for meg

    Hvis du vil kjøre en reparasjon av produktet automatisk, klikker du Løs dette problemet. Deretter klikker du Kjør i dialogboksen Filnedlasting, og følg trinnene i veiviseren.

    Obs!Denne veiviseren er foreløpig bare tilgjengelig på engelsk. Den automatiske reparasjonen fungerer imidlertid også for andre språkversjoner av Windows.

    Obs!Hvis du ikke bruker datamaskinen som har problemet, kan du lagre den automatiske reparasjonen på en flash-stasjon eller en CD slik at du kan kjøre den på datamaskinen som har problemet.

    La meg løse det selv

    Hvis du vil reparere produktet selv, skriver du inn følgende kommando fra en hevet ledetekst:
    msiexec/f {C09FB3CD-3D0C-3F2D-899A-6A1D67F2073F}

    Dette fører til at alle funksjonene i .NET Framework 2.0 SP2 produktet til reevaluate sin installasjonsstatusen.
    Dette løser problemet, og gjør det mulig for oppdateringen 982167 eller 982168 til å bruke sine respektive payloaden.
Obs! Hvis trinn 1 og 2 ikke fungerer, kan du prøve å avinstallere oppdateringen installert før du fikk feilen, og deretter installere oppdateringen på nytt.
Status
Microsoft har bekreftet at dette er et problem i Microsoft-produktene som er oppført i delen "Gjelder for".
Mer informasjon
Hvis du vil ha mer informasjon om hvordan du kjører en kommando med utvidede rettigheter, kan du gå til følgende Microsoft-webside: Hvis du vil ha mer informasjon om de forskjellige kommandolinjebryterne som støttes av Windows Installer, kan du gå til følgende MSDN-websiden: Hvis du vil ha mer informasjon om Windows Installer, kan du gå til følgende MSDN-websiden:
sikkerhetsoppdatering oppdatering 982167 982168 belastningstypen System.Security.Authentication.ExtendedProtection.ExtendedProtectionPolicy WCF løsning løs det

Advarsel: Denne artikkelen er autooversatt

Egenskaper

Artikkel-ID: 2262911 – Forrige gjennomgang: 11/27/2013 00:05:00 – Revisjon: 5.0

Microsoft .NET Framework 3.5 Service Pack 1, Microsoft .NET Framework 2.0 Service Pack 2, Microsoft Windows Server 2003 Service Pack 2, Microsoft Windows XP Service Pack 2

  • kbbug kbexpertiseinter kbinfo kbsecurity kbmsifixme kbfixme kbmt KB2262911 KbMtno
Tilbakemelding
mov.clickstreamTracker.init();