Du kan ikke tilordne et forbundsdomene til en bruker i Microsoft 365 administrasjon Center

Problem

Du oppretter en ny bruker i Microsoft 365 administrasjon-senteret. Når du imidlertid prøver å tilordne et organisasjonsdomene til den nye brukeren, er ikke det organisasjonsdomenet oppført i brukerens liste over domener.

Følgende er et eksempel på hva som skjer når du opplever dette problemet:

  • Enkel pålogging (SSO) og Active Directory-synkronisering er aktivert i Microsoft 365-portalen.
  • Når du viser egenskapene for domenet på siden for domeneegenskaper, er domenetypen oppført som samlet eller enkel pålogging. Adatum.com er for eksempel domenet i forbund.
  • Når du oppretter en ny bruker, ser du at standarddomenet som leveres av Microsoft 365, er oppført som det første alternativet i rullegardinlisten. Standarddomenet er for eksempel contoso.onmicrosoft.com.
  • Når du klikker rullegardinlisten for å vise listen over domener, er ikke det organisasjonsbaserte domenet oppført. Adatum.com er for eksempel ikke oppført.

Årsak

Denne virkemåten er etter utforming i Microsoft 365. Du kan ikke opprette brukere i forbund gjennom portalen. Alle brukere i forbund må opprettes lokalt og må synkroniseres ved hjelp av Synkroniseringsverktøy for Microsoft Azure Active Directory.

Obs!

Du kan heller ikke angi et organisasjonsbasert domene som standarddomenet i Microsoft 365.

Løsning

Hvis du vil omgå dette problemet, kan du opprette en samsvarende brukerkonto i lokal Active Directory Domain Services (AD DS)-miljøet, konfigurere brukerhovednavnet (UPN) på riktig måte, og deretter synkronisere kontoen og Microsoft Entra ID ved hjelp av katalogsynkronisering. Det gjør du ved å følge disse trinnene:

  1. Få den primære SMTP-adressen til Microsoft 365-brukerkontoen ved å følge disse trinnene:

    1. Logg på Microsoft 365-portalen som global administrator.
    2. Velg Admin>Exchange for å åpne Exchange Admin Center.
    3. Finn brukerkontoen, og dobbeltklikk den.
    4. Velg E-postadresse i venstre navigasjonsrute, og noter deretter den primære SMTP-adressen til brukerkontoen.
  2. Start Active Directory-brukere og -datamaskiner, og opprett deretter en brukerkonto i det lokale domenet som samsvarer med Microsoft 365-brukerkontoen. Hvis du vil ha mer informasjon, kan du se Opprette en brukerkonto i Active Directory-brukere og -datamaskiner.

  3. Kontroller at UPN for brukerkontoen er oppdatert til domenenavnet i organisasjonsforbundet. Hvis du vil ha mer informasjon, kan du se Feilsøke Active Directory-brukerkontoer som er styrt som SSO-aktiverte bruker-ID-er for Microsoft 365.

  4. Bruk Active Directory Service Interfaces (ADSI) Edit til å redigere proxyAddresses-attributtet til brukerobjektet, slik at det samsvarer med den primære SMTP-adressen som du nevnte i trinn 1D. Det gjør du ved å følge disse trinnene:

    Obs!

    Hvis du vil ha mer informasjon om hvordan du installerer ADSI Edit, kan du se Installere ADSI Edit.

    1. Velg Start>kjøring, skriv inn ADSIEdit.msc, og velg deretter OK.

    2. Høyreklikk ADSI Rediger, velg Koble til, og velg deretter OK for å laste inn domenepartisjonen.

    3. Finn brukerobjektet du vil endre, i navigasjonsruten, høyreklikk på det, og velg deretter Egenskaper.

    4. Velg proxyAddresses-attributtet i attributtlisten, og velg deretter Rediger.

    5. Skriv inn riktig SMTP-adresse i feltet Verdi som skal legges til , og velg deretter Legg til.

      Obs!

      Den primære SMTP-adresseverdien for brukerobjektet bør forberedes av en SMTP med store bokstaver: utforming for adresseverdien som skal formateres riktig for proxyAddressesattribute. SMTP:username@contoso.comer for eksempel en akseptabel verdi, og «username@contoso.com» er ikke en akseptabel verdi.

    6. Velg OK to ganger, og avslutt deretter ADSI Edit.

    Hvis du vil ha mer informasjon om hvordan du bruker ADSI Edit til å redigere Active Directory-attributter, kan du se Bruke ADSI Edit

  5. Fremtving katalogsynkronisering.

Mer informasjon

Hvis du vil ha mer informasjon, kan du se Feilsøke brukernavnproblemer som oppstår for brukere i forbund når de logger på Microsoft 365, Azure eller Intune.

Trenger du fremdeles hjelp? Gå til Microsoft Community.