Du er frakoblet, venter på at Internett skal koble til igjen

ImageX.exe kan ikke ta opp en avbildning i Windows PE 3.0 på en datamaskin som kjører Windows 7 eller Windows Server 2008 R2

VIKTIG: Denne artikkelen ble oversatt med maskinoversettelsesprogramvare fra Microsoft og muligens redigert av Microsoft Community via CTF-teknologi i stedet for av en oversetter. Microsoft tilbyr både menneskelig oversatte og maskinoversatte/Community-redigerte artikler, slik at du får tilgang til alle artiklene i vår Knowledge Base på ditt eget språk. En maskinoversatt eller Community-redigert artikkel er imidlertid ikke alltid perfekt. Den kan inneholde feil i vokabular, syntaks eller grammatikk, mye likt en fremmedspråklig som forsøker å snakke språket ditt. Microsoft har ikke ansvar for unøyaktige opplysninger, feil eller skade forårsaket av feilaktig oversettelse av innholdet eller kundenes bruk av informasjonen. Microsoft oppdaterer jevnlig maskinoversettelsesprogramvaren og -verktøyene for å forbedre redigering av maskinoversatte tekster.

Den engelske versjonen av denne artikkelen er den følgende: 2525084
Symptom
Tenk deg følgende:
  • Du har en datamaskin som kjører Windows 7 eller Windows Server 2008 R2 og som har flere prosessorer.
  • Du kjører Imagex.exe-verktøyet for å ta opp en avbildning i Windows Preinstallation Environment (Windows PE) 3,0 på datamaskinen.
I dette scenariet mislykkes Imagex.exe tilfeldig. I tillegg kan du få en av følgende feilmeldinger:
Prosessen kan ikke tilgang til filen fordi den brukes av en annen prosess.


Instruksjonen i minneadresse det refereres til minne på minneadresse. Minnet kunne ikke skrive. Klikk OK for å avslutte programmet.

Årsak
Dette problemet oppstår på grunn av et tidsberegningsproblem i Imagex.exe-verktøyet.

Når tidsberegningen problemet oppstår, prøver to tråder å åpne en fil på samme tid. Du får derfor feilmeldingen som er nevnt i delen "Symptomer".
Løsning
Hvis du vil løse dette problemet, installerer den nyeste versjonen av Windows-vurdering og Deployment Kit (Windows ADK), eller installere hurtigreparasjonspakken som er beskrevet i delen "Informasjon om hurtigreparasjon".

Metode 1: Installere Windows ADK

  1. Last ned den nyeste versjonen av Windows-ADK.
  2. Monter problemfilen Winpe.wim ved å bruke Imagex.exe-verktøyet sammen med syntaksen for/mountrw . Hvis du vil gjøre dette, kjører du følgende kommando i en ledetekst:
    IMAGEX. EXE/mountrw banen til klargjøringsområdet Winpe.wim 1
  3. Kopier den oppdaterte imagex-filen (som standard, den er plassert på C:\Program Files (x 86) \Windows Kits\8.1\Assessment og distribusjon av Kit\Deployment Tools\amd64\DISM\Imagex.exe) i Verktøy -mappen i den monterte filen Winpe.wim.
  4. Demonter Winpe.wim-filen ved å bruke Imagex.exe-verktøyet sammen med/commit -syntaks. Hvis du vil gjøre dette, kjører du følgende kommando i en ledetekst:
    IMAGEX. EXE/Commit

Metode 2: Informasjon om hurtigreparasjon

En støttet hurtigreparasjon er tilgjengelig fra Microsoft. Denne hurtigreparasjonen er imidlertid ment å løse problemet som er beskrevet i denne artikkelen. Bruk denne hurtigreparasjonen bare på systemer som har dette bestemte problemet.

Hvis hurtigreparasjonen er tilgjengelig for nedlasting, finnes delen "Nedlasting av hurtigreparasjoner tilgjengelig" øverst i denne Knowledge Base-artikkelen. Hvis denne delen ikke vises, kan du sende en forespørsel til Microsofts kundeservice og kundestøtte for å få hurtigreparasjonen.

Obs! Hvis det oppstår andre problemer, eller hvis feilsøkingstips, må du kanskje opprette en separat forespørsel om. Vanlige kundestøttekostnader gjelder for ytterligere kundestøttespørsmål og problemer som ikke dekkes av denne oppdateringen. For en fullstendig liste over telefonnumre for Microsofts kundeservice og kundestøtte eller opprette en separat forespørsel om, kan du gå til følgende Microsoft-webområde: Obs! "Nedlasting av hurtigreparasjoner tilgjengelig"-skjemaet viser språk hurtigreparasjonen er tilgjengelig. Hvis du ikke ser språket ditt, er det fordi en hurtigreparasjon ikke er tilgjengelig for dette språket.

Forutsetninger

Hvis du vil bruke denne hurtigreparasjonen, må du kjøre ett av følgende operativsystemer:
  • Windows 7
  • Windows 7 Service Pack 1 (SP1)
  • Windows Server 2008 R2
  • Windows Server 2008 R2 Service Pack 1 (SP1)
Hvis du vil ha mer informasjon om hvordan du skaffer Windows 7 eller en oppdateringspakke for Windows Server 2008 R2, kan du klikke følgende artikkelnummer for å vise artikkelen i Microsoft Knowledge Base:
976932 Informasjon om Service Pack 1 for Windows 7 og Windows Server 2008 R2

Instruksjoner for installasjon

For brukere som allerede har installert Win7 RTM OPK eller WAIK verktøyet Kit:

Denne nedlastingen inneholder en oppdatert versjon av imagex.exe-filen som erstatter imagex.exe-filen på systemet. ImageX er som standard installert i følgende mappe:

WAIK brukere:
C:\Program Files\Windows AIK\Tools\<architecture>

OPK-brukere:
C:\Program Files\Windows OPK\Tools\<architecture>
Merk: <architecture>er x 86, amd64 eller IA64.

Hvis du vil oppdatere imagex.exe, gjør du følgende:
1. Last ned ImageX release CAB-fil for alle arkitekturer til en mappe på datamaskinen.
2. i Windows Utforsker, Finn x 86 CAB-filen på datamaskinen.
3. i Windows Utforsker dobbeltklikker du CAB-filen for å vise innholdet i filen.
4. Trykk CTRL + A for å velge imagex.exe.
5. Høyreklikk det merkede området, og deretter trekke ut.
6. i Velg målvinduet, velger du mappen som inneholder CAB-filen.
7. Klikk Opprett ny mappe, og skriv deretter inn x 86 navn på mappen.
8. Klikk på Extract for å pakke ut filene.
9. i Windows Utforsker, Finn mappen der du pakket ut filene i de foregående trinnene.
10. Trykk CTRL + A for å velge ImageX i mappen.
11. Høyreklikk det merkede området, og klikk deretter Kopier.
12. Finn mappen der x 86 imagex.exe-filen er installert på datamaskinen. X 86 imagex.exe-filen kan for eksempel installeres i mappen C:\Program Files\Windows AIK\Tools\x86 eller C:\Program Files\Windows OPK\Tools\x86 i henhold til WAIK eller OPK brukere.
13. Høyreklikk hvor som helst i mappen, og klikk deretter Lim inn.
14. Når du blir bedt om det, klikker du Kopier og Erstatt for å erstatte imagex.exe-filen med den nye versjonen som inneholder denne utgivelsen.
15. Hvis et vindu ber om administratortilgang, klikker du Fortsett. Hvis andre filoperasjonen windows ber deg, klikker du Ja i disse vinduene.
16. Gjenta trinn 2-15 ved hjelp av amd64 ImageX CAB-filen ved å skrive amd64 mappenavn og ved å velge denne mappen som mål for den utpakkede amd64 ImageX-filen. Amd64 imagex.exe-filen kan for eksempel installeres i mappen C:\Program Files\Windows AIK\Tools\amd64 OR C:\Program Files\Windows OPK\Tools\amd64 i henhold til WAIK eller OPK brukere.
17. Gjenta trinn 2-15 ved hjelp av ImageX for IA64 CAB-filen ved å skrive inn IA64 for navnet på mappen, og ved å velge denne mappen som mål for den utpakkede filen IA64 ImageX. Amd64 imagex.exe-filen kan for eksempel installeres i mappen C:\Program Files\Windows AIK\Tools\IA64 OR C:\Program Files\Windows OPK\Tools\IA64 i henhold til WAIK eller OPK brukere.

For brukere som bruker imagex.exe som frittstående kjørbart program, følger du denne fremgangsmåten:
</architecture></architecture></architecture>
  1. Pakke ut denne hurtigreparasjonspakken til en midlertidig plassering manuelt.
  2. Monter problemfilen Winpe.wim ved å bruke Imagex.exe-verktøyet sammen med syntaksen for/mountrw . Hvis du vil gjøre dette, kjører du følgende kommando i en ledetekst:
    IMAGEX. EXE/mountrw banen til klargjøringsområdet Winpe.wim 1
  3. Kopier den oppdaterte imagex-filen til mappen Verktøy i den monterte filen Winpe.wim.
  4. Demonter Winpe.wim-filen ved å bruke Imagex.exe-verktøyet sammen med/commit -syntaks. Hvis du vil gjøre dette, kjører du følgende kommando i en ledetekst:
    IMAGEX. EXE/Commit

Registerinformasjon

Hvis du vil bruke denne hurtigreparasjonen i denne pakken, trenger du ikke foreta endringer i registret.

Krav om omstart

Du har ikke starte datamaskinen på nytt etter at du har installert denne hurtigreparasjonen.

Informasjon om erstatning av hurtigreparasjoner

Denne hurtigreparasjonen erstatter ikke tidligere utgitte hurtigreparasjoner.

Filinformasjon

Den globale versjonen av denne hurtigreparasjonen installerer filer med attributtene som er oppført i tabellene nedenfor. Datoene og klokkeslettene for disse filene er oppført i Coordinated Universal Time (UTC). Datoene og klokkeslettene for disse filene på den lokale datamaskinen din, vises i lokal tid sammen med den gjeldende tidsforskjellen for sommertid (DST). I tillegg kan datoene og klokkeslettene endres når du utfører bestemte operasjoner på filene.
Filinformasjonsmerknader for Windows 7 og Windows Server 2008 R2
Viktig Hurtigreparasjoner for Windows 7 og Windows Server 2008 R2 hurtigreparasjoner er inkludert i de samme pakkene. Hurtigreparasjoner på siden Be om hurtigreparasjonen er imidlertid oppført under begge operativsystemene. Hvis du vil be om hurtigreparasjonspakken som gjelder ett eller begge operativsystemene, velg hurtigreparasjonen som er oppført under "Windows 7/Windows Server 2008 R2" på siden. Se delen "Gjelder" i artiklene for å fastslå det faktiske operativsystemet som gjelder hver hurtigreparasjon for alltid.
  • Filene som gjelder for et bestemt produkt, SR_Level (RTM, SPn), og gren (LDR, GDR), kan identifiseres ved å kontrollere filversjonsnumrene, som vist i følgende tabell.
    VersjonProduktSR_LevelAvdeling
    6.1.760 1. 21xxxWindows 7 og Windows Server 2008 R2SP1LDR
For alle støttede x86-baserte versjoner av Windows 7
FilnavnFilversjonFilstørrelseDatoTidPlattform
ImageX.exe6.1.7601.21716475,64828-Apr-201102:34x 86
For alle støttede x64-baserte versjoner av Windows 7 og Windows Server 2008 R2
FilnavnFilversjonFilstørrelseDatoTidPlattform
ImageX.exe6.1.7601.21716574,97628-Apr-201102:51x 64
For alle støttede IA-64-baserte versjoner av Windows Server 2008 R2
FilnavnFilversjonFilstørrelseDatoTidPlattform
ImageX.exe6.1.7601.217161,188,35228-Apr-201102:12IA-64
Status
Microsoft har bekreftet at dette er et problem i Microsoft-produktene som er oppført i delen "Gjelder for".
Mer informasjon
Hvis du vil ha mer informasjon om terminologi for programvareoppdatering, klikker du følgende artikkelnummer for å vise artikkelen i Microsoft Knowledge Base:
824684 Beskrivelse av standardterminologien som brukes til å beskrive oppdateringer av Microsoft-programvare
Hvis du vil ha mer informasjon om verktøyet ImageX, kan du gå til følgende TechNet-webområde:
ImageX racing problemet WinPE

Advarsel: Denne artikkelen er autooversatt

Egenskaper

Artikkel-ID: 2525084 – Forrige gjennomgang: 07/09/2015 07:42:00 – Revisjon: 4.0

Windows 7 Starter, Windows 7 Home Premium, Windows 7 Professional, Windows 7 Home Basic, Windows 7 Enterprise, Windows 7 Ultimate, Windows Server 2008 R2 Standard, Windows Server 2008 R2 Enterprise, Windows Server 2008 R2 Datacenter, Windows Server 2008 R2 Foundation, Windows Server 2008 R2 for Itanium-Based Systems

  • kbqfe kbfix kbhotfixserver kbautohotfix kbsurveynew kbexpertiseinter atdownload kbmt KB2525084 KbMtno
Tilbakemelding