Du kan referere til innholdet i celler i en annen arbeidsbok ved å opprette en ekstern referanseformel. En ekstern referanse (også kalt en kobling) er en referanse til en celle eller et område i et regneark i en annen Excel arbeidsbok, eller en referanse til et definert navn i en annen arbeidsbok.

  1. Åpne arbeidsboken som skal inneholde den eksterne referansen (målarbeidsboken) og arbeidsboken som inneholder dataene du vil koble til (kildearbeidsboken).

  2. Merk cellen eller cellene der du vil opprette den eksterne referansen.

  3. Type = (likhetstegn).

    Hvis du vil bruke en funksjon, for eksempel SUMMER, skriver du inn funksjonsnavnet etterfulgt av en venstreparentes. Eksempel: =SUMMER(.

  4. Bytt til kildearbeidsboken, og klikk deretter regnearket som inneholder cellene du vil koble.

  5. Merk cellen eller cellene du vil koble til, og trykk ENTER.

    Obs!: Hvis du merker flere celler, for eksempel =[SourceWorkbook.xlsx]Ark1!$A$1:$A$10 og har en gjeldende versjon av Microsoft 365, kan du ganske enkelt trykke ENTER for å bekrefte formelen som en dynamisk matriseformel. Ellers må formelen angis som en eldre matriseformel ved å trykke CTRL+SKIFT+ENTER. Hvis du vil ha mer informasjon om matriseformler, kan du se retningslinjer og eksempler på matriseformler.

  6. Excel returnerer deg til målarbeidsboken og viser verdiene fra kildearbeidsboken.

  7. Vær oppmerksom Excel returnerer koblingen med absolutte referanser,så hvis du vil kopiere formelen til andre celler, må du fjerne dollartegnene ($):

    =[SourceWorkbook.xlsx]Ark1! $ A$1

    Hvis du lukker kildearbeidsboken, Excel automatisk til filbanen i formelen:

    ='C:\Reports\[SourceWorkbook.xlsx]Ark1'!$A$1

  1. Åpne arbeidsboken som skal inneholde den eksterne referansen (målarbeidsboken) og arbeidsboken som inneholder dataene du vil koble til (kildearbeidsboken).

  2. Merk cellen eller cellene der du vil opprette den eksterne referansen.

  3. Type = (likhetstegn).

  4. Bytt til kildearbeidsboken, og klikk deretter regnearket som inneholder cellene du vil koble.

  5. Trykk F3, velg navnet du vil koble til, og trykk ENTER.

    Obs!: Hvis det navngitte området refererer til flere celler, og du har en gjeldende versjon av Microsoft 365 ,kan du ganske enkelt trykke ENTER for å bekrefte formelen som en dynamisk matriseformel. Ellers må formelen angis som en eldre matriseformel ved å trykke CTRL+SKIFT+ENTER. Hvis du vil ha mer informasjon om matriseformler, kan du se retningslinjer og eksempler på matriseformler.

  6. Excel returnerer deg til målarbeidsboken og viser verdiene fra det navngitte området i kildearbeidsboken.

  1. Åpne målarbeidsboken og kildearbeidsboken.

  2. Gå til Formler i målarbeidsboken > Definerte navn > Definer navn.

    Definerte navn-gruppen på båndet

  3. Skriv inn et navn på området i Navn-boksen i dialogboksen Nytt navn.

  4. Slett innholdet i Refererer til-boksen, og hold deretter markøren i boksen.

    Hvis du vil at navnet skal bruke en funksjon, skriver du inn funksjonsnavnet og plasserer markøren der du vil ha den eksterne referansen. Skriv for eksempel =SUMMER(), og plasser deretter markøren mellom parentesene.

  5. Bytt til kildearbeidsboken, og klikk deretter regnearket som inneholder cellene du vil koble.

  6. Merk cellen eller celleområdet du vil koble, og klikk OK.

    Legge til et definert navn i en ekstern arbeidsbok fra Formler > Definerte navn > Definer navn > Nytt navn.

Eksterne referanser er spesielt nyttige når det ikke er praktisk å holde store regnearkmodeller samlet i samme arbeidsbok.

  • Slå sammen data fra flere arbeidsbøker    Du kan koble arbeidsbøker fra flere brukere eller avdelinger og deretter integrere de relevante dataene i en sammendragsarbeidsbok. Da trenger du ikke å endre sammendragsarbeidsboken manuelt når kildearbeidsbøkene endres.

  • Opprette ulike visninger av dataene    Du kan skrive inn alle dataene i én eller flere kildearbeidsbøker, og deretter opprette en rapportarbeidsbok som inneholder eksterne referanser til bare de relevante dataene.

  • Strømlinjeforme store, komplekse modeller    Ved å dele opp en komplisert modell i en serie med arbeidsbøker som er avhengige av hverandre, kan du arbeide med modellen uten å åpne alle de relaterte arkene. Mindre arbeidsbøker er enklere å endre, krever ikke så mye minne og er raskere å åpne, lagre og beregne.

Formler med eksterne referanser til andre arbeidsbøker vises på to måter, avhengig av om kildearbeidsboken , den som leverer data til en formel, er åpen eller lukket.

Når kilden er åpen, inneholder den eksterne referansen arbeidsboknavnet i hakeparenteser ([ ]), etterfulgt av regnearknavnet, et utropstegn (!) og cellene som formelen avhenger av. Formelen nedenfor legger for eksempel sammen cellene C10:C25 fra arbeidsboken som heter Budget.xls.

Ekstern referanse

=SUMMER([Budget.xlsx]Årlig! C10:C25)

Når kilden ikke er åpen, inkluderer den eksterne referansen hele banen.

Ekstern referanse

=SUMMER('C:\Rapporter\[Budget.xlsx]Årlig'! C10:C25)

Obs!: Hvis navnet på det andre regnearket eller arbeidsboken inneholder mellomrom eller ikke-alfabetiske tegn, må du omslutte navnet (eller banen) i enkle anførselstegn som i eksemplet ovenfor. Excel legger automatisk til disse for deg når du velger kildeområdet.

Formler som kobler til et definert navn i en annen arbeidsbok, bruker arbeidsboknavnet etterfulgt av et utropstegn (!) og navnet. Formelen nedenfor legger for eksempel sammen cellene i området Salg fra arbeidsboken som Budget.xlsx.

Ekstern referanse

=SUMMER(Budget.xlsx! Salg)

  1. Merk cellen eller cellene der du vil opprette den eksterne referansen.

  2. Type = (likhetstegn).

    Hvis du vil bruke en funksjon, for eksempel SUMMER, skriver du inn funksjonsnavnet etterfulgt av en venstreparentes. Eksempel: =SUMMER(.

  3. Bytt til regnearket som inneholder cellene du vil koble til.

  4. Merk cellen eller cellene du vil koble til, og trykk ENTER.

    Obs!: Hvis du merker flere celler (=Ark1! A1:A10), og har en gjeldende versjon avMicrosoft 365 , kan du ganske enkelt trykke ENTER for å bekrefte formelen som en dynamisk matriseformel. Ellers må formelen angis som en eldre matriseformel ved å trykke CTRL+SKIFT+ENTER. Hvis du vil ha mer informasjon om matriseformler, kan du se retningslinjer og eksempler på matriseformler.

  5. Excel vil gå tilbake til det opprinnelige regnearket og vise verdiene fra kilderegnearket.

Opprette en ekstern referanse mellom celler i forskjellige arbeidsbøker

  1. Åpne arbeidsboken som skal inneholde den eksterne referansen (målarbeidsboken, også kalt formelarbeidsboken) og arbeidsboken som inneholder dataene du vil koble til (kildearbeidsboken, også kalt dataarbeidsboken).

  2. Merk cellen eller cellene du vil koble, i kildearbeidsboken.

  3. Trykk CTRL+C, eller gå til Hjem-> utklippstavle> Kopier.

  4. Bytt til målarbeidsboken, og klikk deretter regnearket der du vil at de koblede dataene skal plasseres.

  5. Merk cellen der du vil plassere de koblede dataene, og gå deretter til Hjem-> Utklippstavle > Lim inn> Lim inn kobling.

  6. Excel returnerer dataene du kopierte fra kildearbeidsboken. Hvis du endrer den, endres den automatisk i målarbeidsboken når du oppdaterer nettleservinduet.

  7. Hvis du vil bruke koblingen i en formel, skriver du inn = foran koblingen, velger en funksjon, skriver inn (, og skriver deretter inn ) etter koblingen.

Opprette en kobling til et regneark i samme arbeidsbok

  1. Merk cellen eller cellene der du vil opprette den eksterne referansen.

  2. Type = (likhetstegn).

    Hvis du vil bruke en funksjon, for eksempel SUMMER, skriver du inn funksjonsnavnet etterfulgt av en venstreparentes. Eksempel: =SUMMER(.

  3. Bytt til regnearket som inneholder cellene du vil koble til.

  4. Merk cellen eller cellene du vil koble til, og trykk ENTER.

  5. Excel vil gå tilbake til det opprinnelige regnearket og vise verdiene fra kilderegnearket.

Trenger du mer hjelp?

Du kan alltid spørre en ekspert i Excels tekniske fellesskap eller få hjelp i Svar-fellesskapet.

Se også

Definere og bruke navn i formler

Finne koblinger (eksterne referanser) i en arbeidsbok

Trenger du mer hjelp?

Utvid ferdighetene dine
Utforsk opplæring
Vær først ute med de nye funksjonene
Bli med i Microsoft Office Insider-deltakere

Var denne informasjonen nyttig?

Hvor fornøyd er du med språkkvaliteten?
Hva påvirket opplevelsen din?

Takk for tilbakemeldingen!

×