Slik retter du en #REF! #BUSY!-feil

Slik retter du en #REF! #BUSY!-feil

#REF!-feilen viser når en formel refererer til en celle som ikke er gyldig. Dette skjer oftest når celler som ble referert til i formler blir slettet eller limt over.

Eksempel – #REF! -feilen forårsaket av sletting av en kolonne

Følgende eksempel bruker formelen =SUM(B2,C2,D2) for kolonne E.

En formel som bruker eksplisitte cellereferanser som =SUMMER(B2,C2,D2), kan føre til et #REF! -feilen hvis en kolonne slettes.

Hvis du slettet kolonne B, C eller D, ville det ført til #REF! feil. I dette tilfellet sletter vi kolonne C (2007-salg), og formelen leser nå =SUMMER(B2,#REF!,C2). Når du bruker eksplisitte cellereferanser som dette (der du refererer til hver celle enkeltvis, atskilt med komma) og sletter en referert rad eller kolonne, kan ikke Excel løse det, så den returnerer #REF! feil. Dette er den primære årsaken til at det ikke anbefales å bruke eksplisitte cellereferanser i funksjoner.

Eksempel på #REF! -feilen forårsaket av sletting av en kolonne.

Løsning

  • Hvis du ved et uhell slettet rader eller kolonner, kan du umiddelbart klikke Angre-knappen på verktøylinjen for hurtigtilgang (eller trykke CTRL+Z) for å gjenopprette dem.

  • Juster formelen slik at den bruker en områdereferanse i stedet for enkeltceller, som for eksempel =SUM(B2:D2). Nå kan du slette en kolonne innenfor området for summen, og Excel vil automatisk justere formelen. Du kan også bruke =SUM(B2:B5) for en sum av rader.

Eksempel – FINN.RAD med feil områdereferanser

I eksemplet nedenfor returnerer =FINN.REKKE(A8,A2:D5,5,USANN) en #REF! fordi den leter etter en verdi som skal returneres fra kolonne 5, men referanseområdet er A:D, som bare er 4 kolonner.

Eksempel på en FINN.OKUP-formel med feil område.  Formelen er =FINN.FIL(A8,A2:D5,5,USANN).  Det er ingen femte kolonne i området FINN.RAD, så 5 fører til en #REF! feil.

Løsning

Juster området til å være større, eller reduser kolonnen for oppslagsverdien til å samsvare med referanseområdet. =FINN.RAD(A8,A2:E5,5,USANN) vil være et gyldig referanseområde, og det vil også =FINN.RAD(A8,A2:D5,4,USANN).

Eksempel – INDEKS med feil referanserad eller -kolonne

I dette eksemplet returnerer formelen =INDEKS(B2:E5,5,5) en #REF! fordi INDEKS-området er 4 rader ganger 4 kolonner, men formelen ber om å returnere det som er i 5. rad og 5. kolonne.

Eksempel på en INDEKS-formel med en ugyldig områdereferanse.  Formelen er =INDEKS(B2:E5,5,5), men området er bare 4 rader ganger 4 kolonner.

Løsning

Juster referanseraden eller -kolonnen slik at de er i INDEKS-oppslagsområdet. =INDEKS(B2:E5,4,4) vil returnere et gyldig resultat.

Eksempel – refererer til en lukket arbeidsbok med INDIREKTE

I eksemplet nedenfor forsøker en INDIREKTE-funksjon å referere til en arbeidsbok som er lukket, noe som forårsaker en #REF! feil.

Eksempel på en #REF! -feilen forårsaket av INDIREKTE-referanse til en lukket arbeidsbok.

Løsning

Åpne den refererte arbeidsboken. Du vil støte på den samme feilen hvis du refererer til en lukket arbeidsbok med en dynamisk matrisefunksjon.

OLE-problemer

Hvis du har brukt en OLE-kobling (Object Linking and Embedding) som returnerer en #REF! -feilen, og deretter starter du programmet som koblingen ringer til.

Merknad: OLE er en teknologi som du kan bruke til å dele informasjon mellom programmer.

DDE-problemer

Hvis du har brukt et dynamisk datautveksling-emne (DDE) som returnerer en #REF! -feilen, må du først kontrollere at du refererer til det riktige emnet. Hvis du fortsatt mottar et #REF! -feilen, kontrollerer du innstillingene i klareringssenteret for eksternt innhold som beskrevet i Blokkere eller oppheve blokkering av eksternt innhold i Office-dokumenter.

Obs! Dynamisk datautveksling (DDE)er en etablert protokoll for utveksling av data mellom Microsoft Windows-baserte programmer.

Makro-problemer

Hvis en makro angir en funksjon på regnearket som refererer til en celle over funksjonen, og cellen som inneholder funksjonen er i rad 1, returnerer funksjonen #REF! fordi det ikke finnes noen celler over rad 1. Kontroller funksjonen for å se om et argument refererer til en celle eller et celleområde som ikke er gyldig. Dette kan kreve at du redigerer makroen i Visual Basic Editor (VBE), for å ta hensyn til situasjonen.

Trenger du mer hjelp?

Du kan alltid spørre en ekspert i Excel tekniske fellesskap, få støtte i Svar-fellesskapet eller foreslå en ny funksjon eller forbedring på Excel User Voice.

Se også

Oversikt over formler i Excel

Unngå formler med feil

Oppdage feil i formler

Funksjoner i Excel

Excel-funksjoner (etter kategori)

Trenger du mer hjelp?

Bli bedre på Office
Utforsk opplæring
Vær først ute med de nye funksjonene
Bli med i Office Insiders

Var denne informasjonen nyttig?

Takk for tilbakemeldingen!

Takk for tilbakemeldingen! Det høres ut som det kan være lurt å sette deg i kontakt med én av våre Office-kundestøtteagenter.

×