Administrer avtaler, planer, budsjetter – det er enkelt med Microsoft 365.

Slik retter du en #VERDI! feil i GJENNOMSNITT eller en SUMMER-funksjonene

Hvis gjennomsnitt eller Summer refererer til celler som inneholder #VALUE! feil, vil formlene resultere i en #VALUE! -feil.

#VERDI! feil i gjennomsnitt

Hvis du vil overse feilverdiene, utformer du en formel som ignorerer feilene i referanseområdet, samtidig som du beregner gjennomsnittet med de gjenværende «normale» verdiene.

Hvis du vil omgå dette scenariet, bruker du en kombinasjon av GJENNOMSNITT sammen med HVIS og ERFEIL for å avgjøre om det finnes en feil i det angitte området. Dette bestemt scenariet krever en matriseformel:

= GJENNOMSNITT(HVIS(ERFEIL(B2:D2);"";B2:D2))

Dette er en matriseformel. Du må enten trykke Enter (bare hvis du bruker Microsoft 365 ) eller CTRL + SKIFT + ENTER i formelen.

Obs!: Hvis du har en gjeldende versjon av Microsoft 365, kan du ganske enkelt skrive inn formelen i utdata-cellen, og deretter trykke Enter for å bekrefte formelen som en dynamisk matriseformel. Ellers må formelen angis som en eldre matriseformel ved først å merke utdatatabellen, skrive inn formelen i utdata-cellen, og deretter trykke CTRL + SKIFT + ENTER for å bekrefte den. Excel setter inn klammeparenteser i begynnelsen og slutten av formelen for deg. Hvis du vil ha mer informasjon om matriseformler, kan du se retningslinjer og eksempler på matriseformler.

Array-funksjonen i gjennomsnitt for å løse #VALUE! feil

Obs!: Funksjonen ovenfor vil ikke bare fungere for #VERDI!, men også for #I/T, #NULL, #DIV/0! og andre.

Du kan også bruke SUMMER på samme måte:

=SUMMER(HVIS(ERFEIL(B2:D2);"";B2:D2))

Har du spørsmål om en bestemt funksjon?

Legg inn et spørsmål i Excel-fellesskapsforumet

Trenger du mer hjelp?

Du kan alltid spørre en ekspert i Excel tekniske fellesskap, få støtte i Svar-fellesskapet, eller foreslå en ny funksjon eller forbedring på Excel User Voice.

Se også

Rette en #VALUE! feil

GJENNOMSNITT (funksjon)

SUMMER (funksjon)

Oversikt over formler i Excel

Oppdage feil i formler

Alle Excel-funksjoner (alfabetisk)

Alle Excel-funksjoner (etter kategori)

Obs!:  Denne siden er oversatt gjennom automatisering og kan inneholde grammatiske feil eller unøyaktigheter. Formålet vårt er at innholdet skal være nyttig for deg. Kan du fortelle oss om informasjonen var nyttig? Her er den engelske artikkelen for referanse.

Trenger du mer hjelp?

Bli bedre på Office
Utforsk opplæring
Vær først ute med de nye funksjonene
Bli med i Office Insiders

Var denne informasjonen nyttig?

Takk for tilbakemeldingen!

Takk for tilbakemeldingen! Det høres ut som det kan være lurt å sette deg i kontakt med én av våre Office-kundestøtteagenter.

×