Slik retter du en #VERDI! feil i indeks/sammenligne-funksjoner

Dette emnet forklarer de vanligste scenariene der du opplever #VALUE! feil når du bruker indeks-og sammenligne-funksjoner sammen i en formel. En av de vanligste grunnene til å bruke indeks og sammenligne-kombinasjonen er når du vil slå opp en verdi i et scenario der Finn. rad ikke fungerer for deg, for eksempel hvis oppslags verdien er over 255 tegn.

Problem: Formelen er ikke angitt som en matrise

Hvis du bruker indeks som en matriseformel sammen med sammenligne for å kunne hente en verdi, må du konvertere formelen til en matriseformel, ellers vil du se en #VALUE! -feil.

Løsning: INDEKS og SAMMENLIGNE må brukes som en matriseformel, noe som betyr at du må trykke på CTRL+SKIFT+ENTER. Dette bryter automatisk teksten i formelen med {}. Hvis du prøver å angi dem selv, viser Excel formelen som tekst.

Hvis du bruker INDEKS/SAMMENLIGNE når du har en oppslagsverdi som er større enn 255 tegn, må den legges inn som en matriseformel.  Formelen i celle F3 er =INDEKS(B2:B4;SAMMENLIGNE(SANN;A2:A4=F2;0);0), og den angis ved å trykke på CTRL+SKIFT+ENTER

Obs!: Hvis du har en gjeldende versjon av Microsoft 365, kan du ganske enkelt skrive inn formelen i utdata-cellen, og deretter trykke Enter for å bekrefte formelen som en dynamisk matriseformel. Ellers må formelen angis som en eldre matriseformel ved først å merke utdatatabellen, skrive inn formelen i utdata-cellen, og deretter trykke CTRL + SKIFT + ENTER for å bekrefte den. Excel setter inn klammeparenteser i begynnelsen og slutten av formelen for deg. Hvis du vil ha mer informasjon om matriseformler, kan du se retningslinjer og eksempler på matriseformler.

Trenger du mer hjelp?

Du kan alltid spørre en ekspert i Excel tekniske fellesskap, få støtte i Svar-fellesskapet, eller foreslå en ny funksjon eller forbedring på Excel User Voice.

Se også

Rette en #VALUE! feil

INDEKS (funksjon)

SAMMENLIGNE (funksjon)

Slå opp verdier med Finn. rad, indeks eller sammenligne

Oversikt over formler i Excel

Unngå formler med feil

Oppdage feil i formler

Alle Excel-funksjoner (alfabetisk)

Alle Excel-funksjoner (etter kategori)

Obs!:  Denne siden er oversatt gjennom automatisering og kan inneholde grammatiske feil eller unøyaktigheter. Formålet vårt er at innholdet skal være nyttig for deg. Kan du fortelle oss om informasjonen var nyttig? Her er den engelske artikkelen for referanse.

Trenger du mer hjelp?

Bli bedre på Office
Utforsk opplæring
Vær først ute med de nye funksjonene
Bli med i Office Insiders

Var denne informasjonen nyttig?

Takk for tilbakemeldingen!

Takk for tilbakemeldingen! Det høres ut som det kan være lurt å sette deg i kontakt med én av våre Office-kundestøtteagenter.

×