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This article applies to Microsoft Dynamics NAV for the English (UK) (en-gb) region.

Symptoms

In the UK version of Microsoft Dynamics NAV 2009 R2 or in the UK version of the Microsoft Dynamics NAV 2009 Service Pack 1 (SP1), assume that you make an application to apply a journal to an invoice after you post the journals for a vendor or for a customer. Then, when you run the Day Book Vendor (Customer) Ledger Entry report (Report 10535/Report 10525), the report does not print all the related G/L entries as expected.

Cause

The report retrieves G/L Entries by Transaction No., but when the application is performed later, the obtained gain/loss entries are posted on a different transaction.

Resolution

Hotfix information

A supported hotfix is now available from Microsoft. However, it is only intended to correct the problem that is described in this article. Apply it only to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Dynamics NAV 2009 service pack or the next Microsoft Dynamics NAV version that contains this hotfix.

Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Technical Support Professional for Microsoft Dynamics and related products determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.



Installation information

Microsoft provides programming examples for illustration only, without warranty either expressed or implied. This includes, but is not limited to, the implied warranties of merchantability or fitness for a particular purpose. This article assumes that you are familiar with the programming language that is being demonstrated and with the tools that are used to create and to debug procedures. Microsoft support engineers can help explain the functionality of a particular procedure, but they will not modify these examples to provide added functionality or construct procedures to meet your specific requirements.

Note Before you install this hotfix, verify that all Microsoft Navision client users are logged off the system. This includes Microsoft Navision Application Services (NAS) client users. You should be the only client user who is logged on when you implement this hotfix.

To implement this hotfix, you must have a developer license.

We recommend that the user account in the Windows Logins window or in the Database Logins window be assigned the "SUPER" role ID. If the user account cannot be assigned the "SUPER" role ID, you must verify that the user account has the following permissions:

  • The Modify permission for the object that you will be changing.

  • The Execute permission for the System Object ID 5210 object and for the System Object ID 9015 object.



Note You do not have to have rights to the data stores unless you have to perform data repair.

Code changes

Note Always test code fixes in a controlled environment before you apply the fixes to your production computers.
To resolve this problem, follow these steps:

  1. Change the code in the G/L Entry - OnPreDataItem trigger in the Day Book Vendor Customer Ledger Entry report (10525) as follows:
    On the View menu, add the following variables in the Variables tab in C/AL Locals:

    • Name: DtldCustLedgEntry; DataType: Record; Subtype: Detailed Cust. Ledg. Entry

    • Name: TransactionNoFilter; DataType: Text ; Length: 250


    Existing code

    ...
    IF NOT PrintGLDetails THEN
    // Delete the following line.
    CurrReport.BREAK;
    ...

    Replacement code

    ...
    IF NOT PrintGLDetails THEN
    // Add the following lines.
    CurrReport.BREAK
    ELSE BEGIN
    // End of the added lines.
    ...


    Select G/L Entry <G/L Entry> DataItem, On the View menu, click Proprieties, select DataItemLink and the delete the following link: Transaction No.=FIELD(Transaction No.)

  2. Change the code in the G/L Entry - OnPreDataItem trigger in the Day Book Vendor Customer Ledger Entry report (10535) as follows:
    On the View menu, add the following variables in the Variables tab in C/AL Locals:

    • Name: DtldVendLedgEntry; DataType: Record; Subtype: Detailed Vendor Ledg. Entry

    • Name: TransactionNoFilter; DataType: Text ; Length: 250


    Existing code

    ...
    IF NOT PrintGLDetails THEN
    // Delete the following line.
    CurrReport.BREAK;
    ...

    Replacement code

    ...
    IF NOT PrintGLDetails THEN

    // Add the following lines.
    CurrReport.BREAK
    ELSE BEGIN
    DtldVendLedgEntry.RESET;
    DtldVendLedgEntry.SETRANGE("Vendor Ledger Entry No.","Vendor Ledger Entry"."Entry No.");
    DtldVendLedgEntry.SETFILTER("Entry Type",'<>%1',DtldVendLedgEntry."Entry Type"::Application);
    IF DtldVendLedgEntry.FINDSET THEN BEGIN
    TransactionNoFilter := FORMAT(DtldVendLedgEntry."Transaction No.");
    WHILE DtldVendLedgEntry.NEXT <>0 DO
    TransactionNoFilter := TransactionNoFilter + '|' + FORMAT(DtldVendLedgEntry."Transaction No.");
    END;
    SETFILTER("Transaction No.",TransactionNoFilter);
    END;
    DtldCustLedgEntry.RESET;
    DtldCustLedgEntry.SETRANGE("Cust. Ledger Entry No.","Cust. Ledger Entry"."Entry No.");
    DtldCustLedgEntry.SETFILTER("Entry Type",'<>%1',DtldCustLedgEntry."Entry Type"::Application);
    IF DtldCustLedgEntry.FINDSET THEN BEGIN
    TransactionNoFilter := FORMAT(DtldCustLedgEntry."Transaction No.");
    WHILE DtldCustLedgEntry.NEXT <>0 DO
    TransactionNoFilter := TransactionNoFilter + '|' + FORMAT(DtldCustLedgEntry."Transaction No.");
    END;
    SETFILTER("Transaction No.",TransactionNoFilter);
    END;
    // End of the added lines.
    ...


    Select G/L Entry <G/L Entry> DataItem, On the View menu, click Proprieties, select DataItemLink and the delete the following link: Transaction No.=FIELD(Transaction No.)


Prerequisites

You must have one of the following products installed to apply this hotfix:

  • The UK version of Microsoft Dynamics NAV 2009 Service Pack 1 (SP1)

  • The UK version of Microsoft Dynamics NAV 2009 R2



Removal information

You cannot remove this hotfix.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

References

VSTF DynamicsNAV SE: 238005

Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.

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