Fout bij het upgraden van de MARS-agent: de update van de Microsoft Azure Recovery Services-agent is mislukt

In dit artikel worden de symptomen en oplossingen beschreven voor een probleem dat optreedt wanneer u probeert te upgraden van een oudere versie naar een nieuwere versie of release van de Mars-agent (Microsoft Azure Recovery Services).

Oorspronkelijke productversie: Azure Site Recovery
Origineel KB-nummer: 4020490

Symptomen

Wanneer u de MARS-agent probeert bij te werken met behulp van de wizard Upgrade van microsoft Azure Recovery Services-agent, mislukt de upgrade en ontvangt u het volgende foutbericht:

De update van de Microsoft Azure Recovery Service Agent is mislukt.
Fout: Kan RecoveryServicesManagementAgent-service niet starten. De patch verwijderen
Probleem: de installatie van de update is mislukt met fout 1612

Oorzaak

Dit probleem treedt op omdat de upgrade het broninstallatieprogramma voor de MARS-agent niet kan vinden in de Windows Installer-cache. Het broninstallatieprogramma is vereist om de upgrade te voltooien.

Oplossing

U kunt dit probleem oplossen door ervoor te zorgen dat het broninstallatieprogramma aanwezig is in de Windows Installer-cache. Ga hiervoor als volgt te werk:

  1. Sluit de wizard Microsoft Azure Recovery Services-agentupgrade af.

  2. Open het OBPatch.log bestand dat zich in de C:\Windows\Temp map bevindt.

  3. Zoek de foutbeschrijvingsregel in het OBPatch.log-bestand naar 'Waarschuwing: lokaal cachepakket'.

  4. Zoek een regel die er ongeveer als volgt uitziet: Waarschuwing:

    Lokaal C:\Windows\Installer\Unique_ID.msi pakket in de cache ontbreekt.

  5. Noteer theUnique_IDvalue voor toekomstig gebruik.

  6. Dubbelklik op het bestand mars agent update installer (.exe). Hiermee kopieert u alle binaire installatiebestanden en installatiebestanden naar een tijdelijke locatie op uw computer en wordt de wizard Microsoft Azure Recovery Services Agent Upgrade geopend.

    Opmerking Laat de wizard geopend tot stap 12.

  7. Open het bestand OBInstaller0Curr.errlog dat zich in de map C:\Windows\Temp bevindt.

  8. Search in de tekst voor Mappad voor SetupLaunchScreen en zoek vervolgens de regel met de meest recente tijdstempel die er ongeveer als volgt uitziet: Mappad voor SetupLaunchScreen: C:\Temp_ID.

  9. Ga naar de C:\Temp_ID\Installers map.

  10. Zoek in deze map het OBSAGENT.msi-bestand naar de map C:\Windows\Installer. Wijzig de naam van het doelbestand inUnique_ID.msi.

  11. Sluit de wizard MARS-agentupgrade.

  12. Voer het upgrade-installatieprogramma uit om de upgrade te installeren. Als het probleem zich blijft voordoen, neemt u contact op met Microsoft Ondersteuning.

Contacteer ons voor hulp

Als u vragen hebt of hulp nodig hebt, maak een ondersteuningsaanvraag of vraag de Azure-communityondersteuning. U kunt ook productfeedback verzenden naar de Feedback-community van Azure.