Het oplossen van een gedeeltelijk vrijgegeven batch in leveranciers in Microsoft Dynamics SL

Van toepassing: Dynamics SL 2011Accounts Payable

Symptomen


Wanneer u een batch in de rekeningen te betalen in Microsoft Dynamics SL vrij te geven, geeft de batch vrij. Wanneer u onderzoeken, ziet u dat de partij in het dialoogvenster Release AP Batches (03.400.00) de status gedeeltelijk vrijgegeven heeft. Mogelijk ziet u een van de volgende foutberichten weergegeven in een gebeurtenislogboek:
Systeembericht 8888 - een onverwachte fout is opgetreden tijdens het loslaten van batch %s. Neem contact op met Solomon voor hulp bij deze batch.
Systeembericht 6019 - Batch onbalans en niet vrijgegeven.
Systeembericht 6909 - een ander proces het item %s al toegevoegd. Het programma moet worden afgesloten.

Oorzaak


Er zijn verschillende mogelijke oorzaken voor de foutberichten worden weergegeven.



Opmerking: Als geen van de volgende oorzaken van toepassing, een debug-script uitvoeren. Zie oplossing 2 voor meer informatie over het uitvoeren van een script voor foutopsporing.

  • Tijdens de release is de verbinding tussen het exemplaar van SQL Server en de Microsoft Dynamics SL verloren gegaan. Zie oplossing 1.
  • Tijdens de release klikt u Annuleren in het dialoogvenster AP Batches vrijgeven (03.400.00) . Zie oplossing 1.

  • Het foutbericht ""-systeembericht 6909 treedt op wanneer u vrijgeven batches afstemming controleren in het dialoogvenster Controleren afstemming (03.060.00 wilt) nadat u hebt geprobeerd te wijzigen in de periode boeken.

    Voor meer informatie over het oplossen van dit probleem, klikt u op het volgende artikel in de Microsoft Knowledge Base:

    Batch- 848595 systeembericht 6909 'Een ander proces al toegevoegd het Item' wanneer u een AP controleren afstemming loslaat in Solomon

  • In Microsoft Business Solutions - Solomon 6.0, bug 7318 ertoe leiden dat het foutbericht ""-systeembericht 6909 worden weergegeven.

    Voor meer informatie over deze fout, klikt u op het volgende artikel in de Microsoft Knowledge Base:

    895221 in Solomon wordt een ""-systeembericht 6909 foutbericht weergegeven wanneer u een batch met leveranciers controle loslaat of een foutbericht 'is een fout opgetreden tijdens de validatie van bedragen' wanneer u AP cheques afdrukken

Oplossing


Opmerking: Als u Microsoft Dynamics SL 2011 of hoger gebruikt, kunt u de batch verwijderen uit de gegevensinvoerscherm en opnieuw invoeren.

Oplossing 1

Probeer opnieuw de batch vrij te geven. Ga hiervoor als volgt te werk:
  1. Open het dialoogvenster Release AP Batches (03.400.00) .
  2. Klik op het geselecteerde selectievakje in naast het batchnummer waarnaar wordt verwezen in het gebeurtenislogboek.
  3. Klik op Begin verwerken.

Oplossing 2

Als u Microsoft SQL Server 2000 uitvoert, wordt het script AP_6019_DEBUG uitvoeren in SQL Query Analyzer en vervolgens de resultaten van het script en het gebeurtenislogboek verzenden naar Microsoft Customer Support Services. Ga hiervoor als volgt te werk. Is ook een video beschikbaar die begeleidt door het proces van het AP-Foutopsporing script uitvoeren:



  1. Download het bestand AP_6019_DEBUG.sql.

    Het volgende bestand is gedownload van de Microsoft Dynamics File Exchange Server:


    Releasedatum: 8 oktober 2009




    Microsoft heeft dit bestand op virussen gecontroleerd. Microsoft gebruikt de meest actuele software voor virusdetectie die beschikbaar was op de datum waarop het bestand werd gepost. Het bestand is opgeslagen op beveiligde servers die onbevoegde wijzigingen aan het bestand verhinderen.

  2. Klik op Starten wijs Alle programma's Query Analyzernaar Microsoft SQL Server.
  3. Typ de naam van het exemplaar van SQL Server-naam in het vak SQL Server in het dialoogvenster verbinden met SQL Server en klik vervolgens op SQL Server-verificatie.
  4. Sa typt in het vak aanmeldingsnaam , typt u het wachtwoord in het vak wachtwoord en klik vervolgens op OK.
  5. Selecteer op de werkbalk met Query Analyzer, de database van de toepassing.
  6. Klik op Optiesin het menu Extra en klik vervolgens op het tabblad resultaten .
  7. Klik op resultaten op tekstin het vak resultaten doel standaard .
  8. Klik op de Tab als scheidingstekenin het vak uitvoerindeling resultaten en klik op OK.

  9. XXXXXX vervangen door het batchnummer van zes cijfers.

  10. Het script wordt uitgevoerd, drukt u op F5.

  11. Nadat het script is voltooid, eenmaal op het onderste venster.

  12. Klik in het menu bestand op Opslaan Als.
  13. Typ in het vak bestandsnaam IncidentAP. Incident vervangen door het nummer van uw werkelijke incident.
  14. Klik op Rapportbestanden (*.rpt)in het vak Opslaan als type en klik op Opslaan.

  15. Dit bestand samen met het gebeurtenislogboek ZIP en vervolgens de bestanden verzenden naar Microsoft Customer Support Services.
Als u werkt met Microsoft SQL Server 2005 of Microsoft SQL Server 2008, wordt het script AP_6019_DEBUG uitvoeren in SQL Server Management Studio en vervolgens de resultaten van het script en het gebeurtenislogboek verzenden naar Microsoft Customer Support Services. Ga hiervoor als volgt te werk:
  1. Download het bestand AP_6019_DEBUG.sql voor foutopsporing.

    Het volgende bestand is gedownload van de Microsoft Dynamics File Exchange Server:


    Releasedatum: 8 oktober 2009




    Microsoft heeft dit bestand op virussen gecontroleerd. Microsoft gebruikt de meest actuele software voor virusdetectie die beschikbaar was op de datum waarop het bestand werd gepost. Het bestand is opgeslagen op beveiligde servers die onbevoegde wijzigingen aan het bestand verhinderen.

  2. Start SQL Server Management Studio, bij de server aanmelden en wijzig vervolgens de opmaak van uitvoer. Ga hiervoor als volgt te werk:
    1. Klik op Opties in het menu Extra .
    2. Klik op queryresultaten.
    3. Klik op resultaten op tekstin het vak Standaard bestemming voor de resultaten .
    4. Queryresultatenvouwen en vouw het exemplaar van SQL Server.
    5. Klik op resultaten op tekst.
    6. Klik op Tab als scheidingstekenin het vak uitvoerindeling .
    7. Klik op het selectievakje kolomkoppen opnemen in het resultaat instellen .
    8. Klik op OK om het dialoogvenster Opties te sluiten.
  3. Klik op openenin het menu bestand , zoekt u het bestand AP_6019_DEBUG.sql en dubbelklik op het bestand AP_6019_DEBUG.sql .
  4. De XXXXXX tijdelijke aanduiding vervangen door het batchnummer van zes cijfers van de geschorste partij.
  5. Druk op F5.
  6. Zodra het script is voltooid, met de linkermuisknop op het onderste deelvenster van het venster.
  7. Klik in het menu bestand op Opslaan Als.
  8. Typ in het vak bestandsnaam IncidentAP.

    Opmerking Het Incident tijdelijke aanduiding vervangen door het nummer van de partij van de geschorste partij.
  9. Klik op Rapportbestanden (*.rpt)in het vak Opslaan als type .
  10. Klik op Opslaan.
  11. Het bestand comprimeren.
  12. Indienen van het gecomprimeerde bestand samen met het gebeurtenislogboek van Microsoft Customer Support Services.

Klanten

Klanten van Microsoft Business Solutions die het Enhancement-plan zijn of die op een serviceplan kunnen naar CustomerSource gaan om een nieuw ondersteuningsverzoek indienen. Hiertoe gaat u naar de volgende Microsoft Business Solutions-website:Typ uw beveiligingssleutel toegang krijgen tot de site. Klik op de koppeling Support om naar de pagina ondersteuning. Ondersteuning, klikt u op Nieuwe aanvragen voor ondersteuning.

Business Solutions-Partners

Microsoft Business Solutions Certified partners kunnen naar PartnerSource gaan om een nieuw ondersteuningsverzoek indienen. Hiertoe gaat u naar de volgende Microsoft Business Solutions-website:Typ uw beveiligingssleutel toegang krijgen tot de site. Klik op de koppeling Support onder Resourcesop de startpagina van PartnerSource en klik vervolgens op Nieuw ondersteuningsverzoek.

Algemene informatie

Microsoft Business Solutions-klanten die niet in de plannen en andere Microsoft-partners kunnen ondersteuningsverzoeken indienen en hun opties voor ondersteuning op de website Microsoft Support kunnen bekijken. Hiertoe gaat u naar de volgende Microsoft-website: