U ontvangt een foutbericht 'Time-out van verbinding' in Microsoft Business Portal wanneer u de pagina Project opent


Symptomen


In Microsoft Business Solutions - Business Portal, wanneer u klikt op Project openen de projectpagina, wordt het volgende foutbericht weergegeven in het webonderdeel Project Communicator:

Fout:

Connector: verbinding time-out.
HRESULT = 0x800A1527 - Client: Er is een onverwachte fout opgetreden tijdens de verwerking van deze aanvraag.
HRESULT = 0x800A1527 - Client: het Soap-bericht verzenden mislukt of geen duidelijke reactie is ontvangen.
HRESULT = 0x800A1527 - Client: niet nader omschreven Clientfout.
HRESULT=0x800A1527


faultcode=Client


FaultString = Connector: verbinding time-out.


faultactor=


Details = Connector: verbinding time-out.
HRESULT = 0x800A1527 - Client: Er is een onverwachte fout opgetreden tijdens de verwerking van deze aanvraag.
HRESULT = 0x800A1527 - Client: het Soap-bericht verzenden mislukt of geen duidelijke reactie is ontvangen.
HRESULT = 0x800A1527 - Client: niet nader omschreven Clientfout.
HRESULT=0x800A1527

Oorzaak


Dit probleem treedt op omdat het Transmission Control Protocol (TCP)-poort die u hebt opgegeven voor de website op het hoogste niveau in beheer van Internet Information Services (IIS) bevat een waarde die anders is dan de waarde die u hebt opgegeven in het bestand ProjectService.wsdl.

Oplossing


U kunt dit probleem oplossen door de volgende stappen uit te voeren:
  1. Zoek in Internet Information Services (IIS) Manager, websites op het hoogste niveau waarop Microsoft Business Portal is geïnstalleerd. Ga hiervoor als volgt te werk:
    1. Klik op Start, wijs Systeembeheeraan en klik op beheer van Internet Information Services (IIS).
    2. Vouw de servernaamin het dialoogvenster Internet Information Services (IIS) Manager .

      Opmerking In dit artikel staat servernaam voor de naam van de server waarop u Microsoft Business Portal hebt geïnstalleerd.
    3. Vouw websitesuit.
  2. Klik met de rechtermuisknop op de website op het hoogste niveau en klik vervolgens op Eigenschappen.
  3. Klik op het tabblad website de waarde in het vak TCP-poort en klikt u op Annuleren.
  4. Open het bestand ProjectService.wsdl in Kladblok.

    Opmerking De standaardlocatie voor het bestand ProjectService.wsdl is Microsoft Business Solutions\Business Portal\Applications\PMA.
  5. Zoek de volgende regel aan het einde van het bestand:
     <soap:address location="HTTP://Server_name:80/BusinessPortal/Applications/PMA/PCService.asmx" /> 
    Opmerking In deze regel staat "Servernaam" de naam van de server waarop u Microsoft Business Portal hebt geïnstalleerd.
  6. Het poortnummer dat wordt vervangen door de waarde die u in stap 3 hebt genoteerd. De regel in stap 5 wordt poort 80.
  7. Klik in het menu Bestand op Opslaan.


Het probleem dat wordt beschreven in de sectie Symptomen niet van toepassing op Microsoft Dynamics SL 7.0.