Office Communicator does not display phone numbers for contacts

Symptoms

You are running Microsoft Office Communicator on a Windows client-based computer. When you right-click a contact, and then you click Call, telephone numbers for the contact are not populated as expected.

Note The telephone numbers that you expect to see are listed for the user in the Active Directory directory service.

Cause

This problem may occur if one of the following conditions are true:
  • Your company's normalization file is not set up correctly.
  • Telephone numbers for users in Active Directory are not in the correct format.

Resolution

To resolve this problem, follow these steps:
  1. Log off Office Communicator on the client computer.
  2. Make sure that the telephone numbers for the users are set up correctly on the server that is running Active Directory. To do this, follow these steps:
    1. Open Active Directory Users and Computers. To do this, click Start, point to All Programs, point to Administrative Tools, and then click Active Directory Users and Computers.
    2. Right-click the domain, and then click Find.
    3. On the Users, Contacts, and Groups tab, type the user name in the Name box, and then click Find Now.
    4. Right-click the user name, and then click Properties.
    5. On the Telephones tab, make sure that the telephone numbers for the user are present and that the numbers are in the correct format. The following is an example of a telephone number in the correct E.164 format: 
      +91 1234567891
    By default, the ABS Configuration Tool is installed to the following folder:
    C:\Program Files\Microsoft Office Communications Server 2007\Reskit
  3. Run the ABS Configuration Tool (AbsConfig.exe). The ABS Configuration Tool is included in the Microsoft Office Communications Server  Resource Kit Tools. To obtain the Office Communications Server Resource Kit Tools, visit the following Microsoft Web site:

    Office Communications Server 2007 Resource Kit Tools
    http://www.microsoft.com/downloads/en/details.aspx?FamilyID=b9bf4f71-fb0b-4de9-962f-c56b70a8aecd&displaylang=en

    Office Communications Server 2007 R2 Resource Kit Tools
    http://www.microsoft.com/downloads/en/details.aspx?familyid=9E79A236-C0DF-4A72-ABA6-9A9602A93ED0&displaylang=en

    On the Configure WMI tab, select the Apply only company-specific normalization rules option under Normalization rules to use your company's normalization file.

    Note To make sure that your company's normalization file is not causing the problem, set Normalization rules to use Apply only generic built-in normalization rules.

    Warning Using ABS Configuration Tool’s Restore defaults button will automatically set Normalization rules to Apply No Rules. This setting will cause the removal of the phone number information from the next download of the Office Communicator address book file. For phone numbers to be added to the Office Communicator address book file they must be first normalized by the Address Book Service.
  4. On the Configure WMI tab, select the Apply only company-specific normalization rules option under Normalization rules to use your company's normalization file.

    Note To make sure that your company's normalization file is not causing the problem, set Normalization rules to use Apply only generic built-in normalization rules.

    Warning Using ABS Configuration Tool’s Restore defaults button will automatically set Normalization rules to Apply No Rules. This setting will cause the removal of the phone number information from the next download of the Office Communicator address book file. For phone numbers to be added to the Office Communicator address book file they must be first normalized by the Address Book Service.
  5. Regenerate the Address Book. This is needed for the changes to be updated and also to make sure that Communicator 2007 has the latest address book information. To do this, follow these steps:
    1. Click Start, click Run, type cmd in the Open box, and then click OK.
    2. Change to the directory that contains the abServer.exe file. By default, the abServer.exe file is located in the following directory:
      C:\Program Files\ Microsoft Office Communications Server 2007\Server\Core
    3. At the command prompt, type the following command, and then press ENTER:
      abServer.exe –regenur
      Note You may have to wait up to five minutes for the command to actually finish.
    4. To verify that the Address Book regeneration has finished, locate events that resemble the following under Office Communications Server in Event Viewer:

  6. Run the Address Book server synchronization. To do this, follow these steps:
    1. Click Start, click Run, type cmd in the Open box, and then click OK.
    2. Change to the directory that contains the abServer.exe file. By default, the abServer.exe file is located in the following directory:
      C:\Program Files\ Microsoft Office Communications Server 2007\Server\Core
    3. At the command prompt, type the following command and then press ENTER:
      abServer.exe –syncnow
      Note You may have to wait up to five minutes for the command to finish.
    4. To verify that the Address Book synchronization has finished, locate events that resemble the following under Office Communications Server in Event Viewer:



      If a telephone number does not normalize, you will see events that resemble the following under Office Communications Server in Event Viewer:
  7. Log on to Communicator 2007 from the client computer. Telephone numbers now populate as expected when you right-click a contact, and then you click Call.
Note For information about how to use a company normalization file to troubleshoot issues, see the Sample_Company_Phone_Number_Normalization_rules.txt file. By default, the file is located in the following directory:
C:\Program Files\Microsoft Office Communications Server 2007\Web Components\Address Book Files\Files
Eigenschappen

Artikel-id: 961947 - Laatst bijgewerkt: 17 feb. 2011 - Revisie: 1

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