FRx-8900: Unable to Connect to the DSN Provide for User: xxxx

Symptoms

"FRx-8900: Unable to Connect to the DSN Provide for User: xxxx"

This error occurs after entering the database user ID and Password in FRx Report Designer.

Cause

This error may occur for any one or a combination of several of the following:
  1. Incorrect SQL User Password.
  2. The Data Source name has a dash or space in it.
  3. The SQL user does not have appropriate rights to the general ledger Database.
  4. The SQL User is not listed in the SLGU Table.
  5. Incorrect Data Source Configuration.

Resolution

To resolve this error verify the following:
  1. Verify the SQL User ID and Password are valid.
  2. A dash or space is not a supported character for a Data Source name. An underscore is a supported character.
  3. Verify the SQL user has appropriate rights to the General Ledger Database. Microsoft FRx recommends db_datareader rights to the database.
  4. The SQL User is not listed in the Flexi - PFM SLGU table (required by the General Ledger).
  5. Microsoft FRx recommends using a System DSN for Data Source configuration not a User DSN.

References

Eigenschappen

Artikel-id: 964894 - Laatst bijgewerkt: 26 jan. 2009 - Revisie: 1

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