Prestatieproblemen met Outlook wanneer er te veel items of mappen zijn in een cachemodus .ost of .pst bestandsmap

Van toepassing: Outlook 2019Outlook 2016Outlook 2013

Symptomen


Als u veel items in elke map, treden symptomen zoals in Microsoft Outlook het volgende:
  • Wanneer u Exchange-modus met cache of een Outlook-gegevensbestand (.pst) gebruikt, ziet u prestatieproblemen wanneer u bepaalde acties uitvoeren.
  • Verminderde prestaties in Outlook treedt op als de mappen Postvak in, agenda, taken, verzonden Items en Verwijderde Items bevat een groot aantal items.
  • Prestaties van de agenda is niet consistent. Bijvoorbeeld kan updates van vergadering niet worden weergegeven in de agenda van de primaire, gedeeld of overgedragen.
Als u veel e-mailmappen hebt, treden de volgende problemen met de prestaties:
  • Mappen worden niet correct weergegeven of ze lang duren, met name in cache-modus wordt weergegeven.
  • Als uw Outlook-profiel heeft postbussen gedeeld en heeft caching ingeschakeld (Downloaden van gedeelde mappen is ingeschakeld), map problemen met synchronisatie, prestatieproblemen en andere problemen optreden als het aantal gedeelde mappen per postbus groter is dan 500, als KB 3115602beschreven. Ook fouten worden geregistreerd in de map problemen met synchronisatie en '9646'-gebeurtenissen worden geregistreerd in het toepassingslogboek.
  • In uitzonderlijke gevallen, als er meer dan 10.000 mappen, is Outlook erg langzaam te openen. Dit probleem treedt op omdat het lang duurt om op te sommen van de mappen.

Oorzaak


Dit probleem kan optreden als u mappen die groter zijn dan de limiet voor het aantal items per map of als u te veel mappen totale. De artikel- en limieten voor 2019 in Outlook, Outlook 2016 2013 voor Outlook en Outlook 2010 zijn als volgt:
  • 100.000 items per map
  • 5000 items per map Agenda
  • 500 totaal mappen

Om te voorkomen dat problemen met de prestaties van Outlook voor Android en iOS apps, is het raadzaam dat u het aantal mappen en 500 voor deze programma's, te beperken.

Oplossing


Als u het maximale aantal van 500 totaal mappen hebt overschreden, verminderen het aantal e-mailmappen die u hebt.Als u mappen die groter zijn dan de limiet voor het aantal items in een Outlook-gegevensbestand (.pst) of een Outlook-bestand voor off line gegevens (.ost), artikelen verplaatsen van grotere mappen mappen afzonderlijk of kleiner in hetzelfde bestand postvak of gegevens. Hebt u een online archief van Microsoft Exchange, kunt u items desgewenst naar dat archief verplaatsen.

Als u de aanbevolen limiet van 5000 totale agenda-items hebt overschreden, gebruikt u een van de volgende manieren verminderen het aantal items dat u hebt:

Methode 1: Als u hebt ingeschakeld on line archief postvak, items naar het Online archief postbus archiveren.

Methode 2: Een bewaarbeleid van toepassing op de map Agenda items uit deze map verwijderen. (Bijvoorbeeld: items die niet binnen één jaar is gewijzigd naar de map Verwijderde Items verplaatst.)

Methode 3:In synchronisatie venster-instellingen, aanpassen het aantal maanden die zijn gesynchroniseerd voor de primaire, gedeelde kalenders. U doet dit door de volgende registersleutels toevoegen. 

Opmerking: Deze methode is van toepassing op versie 1810 of een latere versie van Office 365 ProPlus (Klik-en-klaar).

Beschrijving Instelling voor het venster van de agenda synchroniseren
Register-pad HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\Cached-modus
Naam CalendarSyncWindowSetting
Type REG_DWORD
Waarde Waarde = 0 is niet actief Waarde = 1 primaire agenda-map Waarde = 2 alle agendamappen De standaardwaarde is 0 als instellen geen
 
Beschrijving Als u op het aantal maanden in het venster Agenda synchroniseren
Register-pad HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\Cached-modus
Naam CalendarSyncWindowSettingMonths
Type REG_DWORD
Waarde Waarde = decimale waarde kiezen hoeveel maanden selecteren in het venster Agenda synchroniseren zoals 1, 3, 6 of 12 6 als standaard niet ingesteld
 
Beschrijving De instelling bepaalt of alle terugkerende items weergeven in plaats van ze te filteren
Register-pad HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\Cached-modus
Naam CalendarSyncWindowAllRecurring
Type REG_DWORD
Waarde 0
 

Deze registersleutels bijwerken de beperking synchroniseren zodat de client-modus met cache minder agenda-items, zelfs voor een agenda die jaren van de geschiedenis op de server is gedownload. Deze sleutels niet reinigen up oudere agenda-inhoud die al is gedownload. Deze methode is effectief als u bereid bent te 'offline items wissen' en synchroniseren van uw agenda (in plaats van bulk verwijderen van oude items). Als u de agenda al in het profiel hebt, hebt u de off line Items wissen nadat u de registersleutels en start Outlook opnieuw.

Off line agenda-items, schakelt u als volgt te werk:

  1. Open het deelvenster agenda in Outlook, klik met de rechtermuisknop op de map agenda .
  2. Selecteer Eigenschappen.
  3. Klik op het tabblad Algemeen op Off line Items wissen.
  4. Klik op OK.

Bovendien kunt u de ondersteuning en herstel-assistent (SaRA) voor Office 365 voor het vaststellen van problemen met Outlook. (Het programma werkt voor beide programma's.)

Download en installeer het programma, gaat u naar de volgende Microsoft-website:

Downloaden van Microsoft Support en herstel Assistant voor Office 365

In het hulpprogramma voor de diagnostische Outlook uitvoeren onder de sectie "Geavanceerde diagnostische gegevens van het" om de oorzaak van het probleem met de prestaties.

Meer informatie


Als u wilt weergeven op het aantal agenda-items, gebruiken in het dialoogvenster Agenda-eigenschappen om te controleren hoeveel artikelen er in een agendamap in Outlook-modus met cache.

Ga hiervoor als volgt te werk:

  1. Open het deelvenster Agenda in Outlook, klik met de rechtermuisknop op de map agenda .
  2. Selecteer Eigenschappen.
  3. Selecteer Totaal aantal items weergevenop het tabblad Algemeen .
  4. Selecteer op het tabblad synchronisatie .
  5. Bekijk het aantal onder Statistieken voor deze map weergeven.

Outlook maakt gebruik van een OST-bestand alleen als u de Exchange-e-mailaccount is geconfigureerd voor gebruik van de Exchange-modus met cache. Als Outlook is geconfigureerd voor verbinding met de Exchange-postbus in de online modus, wordt een OST-bestand wordt niet gebruikt. Als uw Outlook-client is verbonden met Exchange in on line-modus en u geen mappen hoog aantal van items in een PST-bestand hebt, kan het probleem met de prestaties op de server kunnen voordoen.

Raadpleeg het volgende Knowledge Base-artikel voor meer informatie over prestatieproblemen van Outlook:

2759052 treden toepassing wordt onderbroken als er een grote Outlook-gegevensbestand.