Name constraint validation fails when a URN is specified in a subject alternative name in Windows 7, Windows 8, Windows Server 2008 R2 and Windows Server 2012

Symptoms

Consider the following scenario:
  • You create a cross-certification environment to enable certificates to be used and trusted between two organizations.
  • You configure a name constraint in the certificate chain.
  • You issue a certificate that contains a subject alternative name that is set to a Uniform Resource Name (URN) in one of the following operating systems:
    • Windows 7
    • Windows Server 2008 R2
    • Windows 8
    • Windows Server 2012
    For example, you set the subject alternative name to URL=urn:uuid:be127ea0-d180-124d-e044-000f202b235a.
  • The URN is not restricted in any certificate path.
In this scenario, validation of the name constraint in the certificate fails. Additionally, when you open the issued certificate, you receive an error message that resembles the following:
The certificate has an invalid name. The name is not included in the permitted list or is explicitly excluded.

Cause

This issue occurs because Crypt32.dll treats a certificate that has a URN defined for the subject alternative name as an invalid format.

Resolution

Hotfix information


A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running one of the following operating systems:
  • Windows 7 Service Pack 1 (SP1)
  • Windows Server 2008 R2 Service Pack 1 (SP1)
  • Windows 8
  • Windows Server 2012
For more information about how to obtain a Windows 7 or a Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.
File information

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
Additional file information
Eigenschappen

Artikel-id: 2797120 - Laatst bijgewerkt: 15 mrt. 2013 - Revisie: 1

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