Systeembestandscontrole (SFC) markeert Windows Defender PowerShell-modulebestanden ten onrechte als beschadigd

In dit artikel wordt een probleem beschreven waarbij systeembestandscontrole Windows Defender PowerShell-modulebestanden onjuist markeert als beschadigd.

Van toepassing op: Windows-client
Origineel KB-nummer: 4513240

Symptomen

Het hulpprogramma Systeembestandscontrole (SFC) markeert bestanden die zich in de map %windir%\System32\WindowsPowerShell\v1.0\Modules\Defender bevinden als beschadigd of beschadigd. Wanneer dit probleem optreedt, ziet u foutvermeldingen die er ongeveer als volgt uitzien:

Hashes voor bestandslid komen niet overeen.

Oorzaak

Dit is een bekend probleem in Windows 10, versie 1607 en latere versies en Windows Defender versie 4.18.1906.3 en latere versies tot en met versie 4.8.1908.

De bestanden voor de Windows Defender PowerShell-module die zich in %windir%\System32\WindowsPowerShell\v1.0\Modules\Defender bevinden, worden verzonden als onderdeel van de Windows-installatiekopieën. Deze bestanden zijn door de catalogus ondertekend. Het onderdeel beheerbaarheid van Windows Defender heeft echter een nieuw out-of-band-updatekanaal (OOB). Dit kanaal vervangt de oorspronkelijke bestanden door bijgewerkte versies die zijn ondertekend met behulp van een Microsoft-certificaat dat het Windows-besturingssysteem vertrouwt. Vanwege deze wijziging markeert SFC de bijgewerkte bestanden als 'Hashes voor bestandslid komen niet overeen'.

In toekomstige versies van Windows worden de bijgewerkte bestanden in de Windows-installatiekopieën gebruikt. Nadat deze wijziging is geïmplementeerd, markeert SFC de bestanden niet meer.

Oplossing

Dit probleem is opgelost in de update van versie 4.8.1908 van Windows Defender. Nadat deze update is toegepast, worden PowerShell-bestanden die deel uitmaken van de Windows-installatiekopieën niet meer gewijzigd en worden deze bestanden niet meer door het hulpprogramma SFC gevlagd. Computers met internetverbinding die zijn geabonneerd op het Windows Update-kanaal, downloaden en installeren deze update automatisch.

Als u de Windows-installatiekopieën wilt herstellen op computers die door dit probleem zijn getroffen, gebruikt u het hulpprogramma DISM. Open hiervoor een opdrachtpromptvenster op de betreffende computer en voer de volgende opdrachten uit:

dism /online /cleanup-image /restorehealth
sfc /scannow

Als deze opdrachten mislukken en een foutbericht genereren dat lijkt op 'Bestand niet gevonden', controleert u of het bestand Install.wim toegankelijk is en voert u de volgende opdrachten uit:

DISM /Online /Cleanup-Image /RestoreHealth /Source:WIM:c:\install.wim:1 /LimitAccess
sfc /scannow

Zie Een Windows-installatiekopieën herstellen voor meer informatie over herstelopdrachten.

Gegevensverzameling

Als u hulp nodig hebt van Microsoft-ondersteuning, raden we u aan de informatie te verzamelen door de stappen te volgen die worden vermeld in Informatie verzamelen met behulp van TSS voor implementatiegerelateerde problemen.