SIFT-totalen worden onjuist berekend wanneer u SIFT-records in Microsoft SQL Server Option voor Microsoft Dynamics NAV verwijderen


Microsoft Business Solutions-Navision 4.0 en Microsoft Navision 4.0 maken nu deel uit van Microsoft Dynamics NAV 4.0. Alle verwijzingen naar Microsoft Business Solutions-Navision of Microsoft Navision 4.0 hebben betrekking op Microsoft Dynamics NAV.
Dit artikel is van toepassing op Microsoft Dynamics NAV voor alle landen en alle taalinstellingen.

Symptomen


Som Index veld Technology (SIFT)-totalen in de FlowFields verkeerd berekend als u SIFT-records in Microsoft SQL Server Option voor Microsoft Dynamics NAV 4.0 verwijdert.
Opmerking Voorbeelden van FlowFields worden in het veld voorraad in het dialoogvenster Artikelkaart en het veld Mutatie in het dialoogvenster Rekeningschema .
Wanneer dit probleem optreedt, wordt in de FlowFields verkeerd bedragen weergegeven. Echter, als u op de knop Inzoomen in de velden, de juiste bedragen in de onderliggende posten weergegeven.

Oorzaak


Dit probleem kan optreden als u een lege SIFT-record verwijdert of als u meerdere lege SIFT-records verwijderen. Een lege SIFT-record is een record waarin alle bedragen gelijk zijn aan nul. Wanneer Microsoft Dynamics NAV later probeert voor het bijwerken van een SIFT-record die is verwijderd, wordt de update afgebroken. Daarom wordt de SIFT-totaal onjuist.

Oplossing


Informatie over de hotfix

Een ondersteunde hotfix is nu beschikbaar bij Microsoft. De hotfix verhelpt het probleem dat wordt beschreven in dit artikel. Toepassen van de hotfix alleen uit op systemen waarop dit specifieke probleem zich voordoet.

U lost dit probleem meteen contact opnemen met Technical Support voor Microsoft Dynamics en verwante producten om de hotfix te verkrijgen. Naar de Microsoft Dynamics-site en dien een nieuw ondersteuningsverzoek in. Hiertoe gaat u naar de volgende Microsoft-website:U kunt ook contact opnemen met Technical Support voor Microsoft Dynamics en verwante producten via de telefoon op (888) 477-7877.

Opmerking In speciale gevallen kunnen kosten die verbonden zijn aan ondersteuningsoproepen ondersteuning worden geannuleerd als een medewerker van Technical Support voor Microsoft Dynamics en verwante producten bepaalt dat een specifieke update de oplossing van uw probleem. De normale ondersteuningskosten van toepassing op alle extra ondersteuningsvragen die niet in aanmerking voor de specifieke update in kwestie komen.



Hoe kunt u de Microsoft Dynamics NAV-hotfix- of updatebestanden

Nadat u een Microsoft Dynamics NAV-hotfix of een updatebestand hebt aangevraagd bij Technical Support voor Microsoft Dynamics, wordt een hyperlink in een e-mailbericht naar u verzonden.


Het e-mailbericht bevat een hyperlink en een wachtwoord. De hyperlink kunt u de Microsoft Dynamics NAV-hotfix of de updatebestanden te downloaden. Wanneer u op de hyperlink klikt, wordt het dialoogvenster Bestand downloaden-Beveiligingswaarschuwing geopend. Vervolgens wordt u gevraagd uitvoeren, opslaan of het downloadproces.


Als u op uitvoerenklikt, worden de bestanden start het downloaden en het proces van extractie. U moet een map opgeven voor de nieuwe bestanden en vervolgens het wachtwoord opgeven.


Als u op Opslaanklikt, moet u een pad voor het opslaan van het gecomprimeerde bestand. Wanneer u het opgeslagen bestand opent, wordt u gevraagd een pad voor de bestanden op te geven. U moet vervolgens het wachtwoord in het e-mailbericht opgeven.


Als u op Annulerenklikt, wordt het downloadproces gestopt.

Het installeren van een Microsoft Dynamics NAV-hotfix of een updatebestand

De updates en hotfixes voor Microsoft Dynamics NAV worden beschikbaar gesteld als afzonderlijke bestanden. Gebruiken om een Microsoft Dynamics NAV-hotfix of de update installeert de hotfix of de updatebestanden vervangen de bestaande bestanden van Microsoft Dynamics NAV-installatie. Ga hiervoor als volgt te werk:
  1. Gebruik de hotfix of de updatebestanden te vervangen door de volgende bestanden in de installatie van Microsoft Dynamics NAV-client.
    BestandsnaamBestandsversieBestandsgrootteDatumTijdPlatform
    Dbm.dll4.0.3.24843345,55201-Jul-200721:32x86
    Fin.exe4.0.3.248438,119,76001-Jul-200721:32x86
    Fin.exe.manifestNiet van toepassing71101-Jul-200710:24Niet van toepassing
    Finhlink.exe4.0.3.24843120,27201-Jul-200721:32x86
    Finsql.exe4.0.3.248438,168,91201-Jul-200721:32x86
    Finsql.exe.manifestNiet van toepassing71414-Dec-200616:41Niet van toepassing
    Nc_netb.dll4.0.3.2484379,31201-Jul-200721:31x86
    Nc_tcp.dll4.0.3.2484383,40801-Jul-200721:31x86
    Nc_tcps.dll4.0.3.2484391,60001-Jul-200721:32x86
    Ndbcs.dll4.0.3.248431,086,92801-Jul-200721:32x86
    Slave.exe4.0.3.2484395,69601-Jul-200721:32x86
    Opmerking De Microsoft Dynamics NAV-client wordt meestal in de volgende map geïnstalleerd:
    C:\Program Files\Microsoft Business Solutions-Navision\Client\
    Ter vervanging van bestaande bestanden als volgt te werk:
    1. Sluit Microsoft Dynamics NAV.
    2. Ga naar de installatiemap van Microsoft Dynamics NAV-client.
    3. Kopieer de bestanden die u hebt gedownload.
    4. Plak de bestanden die u hebt gedownload in de installatiemap van Microsoft Dynamics NAV-client.
    5. Klik in het dialoogvenster Vervangen van bestand bevestigen op Ja om te overschrijven de bestanden in de installatiemap.
    6. Als de hotfix of de update bevat de vertaalde versies van het bestand Fin.stx of het bestand fin.etx, vervangt u het bestand Fin.stx of Fin.etx die is geïnstalleerd in de mappen voor specifieke taal van de installatiemap.

      Ga als volgt te werk om het bestand Fin.stx of het bestand fin.etx vervangen.
      Opmerking In het volgende voorbeeld wordt verwezen naar een Duitse installatie.
      1. Alle W1 bestand Fin.stx en fin.etx bestanden kopiëren naar de volgende map:
        C:\Program Files\Microsoft Business Solutions-Navision\Client\
      2. Kopieer alle bestand Fin.stx en fin.etx bestanden in de map NLD in de volgende map:
        C:\Program Files\Microsoft Business Solutions-Navision\Client\ENU\
      3. Alle bestand Fin.stx en fin.etx bestanden kopiëren vanuit de map DEU naar de volgende map:
        C:\Program Files\Microsoft Business Solutions-Navision\Client\DEU\
        De nieuwe client uitvoerbare bestanden converteren in sommige gevallen de database-indeling. Daarom moet u alle clients bijwerken. Voor de oorspronkelijke optie, moet u ook de installatie van de server bijwerken.
  2. Als u Microsoft Dynamics NAV Application Server is geïnstalleerd, vervangt de volgende bestanden in de installatie van Microsoft Dynamics NAV Application Server.
    BestandsnaamBestandsversieBestandsgrootteDatumTijdPlatform
    Dbm.dll4.0.3.24843345,55201-Jul-200721:32x86
    Nas.exe4.0.3.248431,422,80001-Jul-200721:32x86
    Nassql.exe4.0.3.248431,463,76001-Jul-200721:32x86
    Ndbcs.dll4.0.3.248431,086,92801-Jul-200721:32x86
    Slave.exe4.0.3.2484395,69601-Jul-200721:32x86
    Ter vervanging van bestaande bestanden als volgt te werk:
    1. Stop de Microsoft Dynamics NAV Application Server.
    2. Ga naar de installatiemap van Microsoft Dynamics NAV Application Server. Microsoft Dynamics NAV Application Server wordt meestal in de volgende map geïnstalleerd:
      C:\Program Files\Microsoft Business Solutions-Navision\Application Server\
    3. Kopieer de bestanden die u hebt gedownload.
    4. Plak de bestanden die u hebt gedownload in de installatiemap van Microsoft Dynamics NAV Application Server.
    5. Klik op Ja om te overschrijven de bestanden in de directory.
    6. Start Microsoft Dynamics NAV Application Server.
  3. Als u de Microsoft Dynamics NAV ODBC-stuurprogramma is geïnstalleerd, vervangt de volgende bestanden in de installatie van Microsoft Dynamics NAV ODBC-stuurprogramma.
    BestandsnaamBestandsversieBestandsgrootteDatumTijdPlatform
    Cfront.dll4.0.3.24843873,93601-Jul-200721:32x86
    Dbm.dll4.0.3.24843345,55201-Jul-200721:32x86
    Nc_netb.dll4.0.3.2484379,31201-Jul-200721:31x86
    Nc_tcp.dll4.0.3.2484383,40801-Jul-200721:31x86
    Nc_tcps.dll4.0.3.2484391,60001-Jul-200721:32x86
    Nodbc.dll4.0.3.248431,227,72801-Jul-200721:32x86
    Nodbccfg.cfg4.0.3.24843446,46401-Jul-200711:25Niet van toepassing
    Nodbccfg.hlpNiet van toepassing12,94014-Dec-200616:42Niet van toepassing
    Nodbccfg.xmlNiet van toepassing2,36014-Dec-200616:42Niet van toepassing
    Slave.exe4.0.3.2484395,69601-Jul-200721:32x86
    Ter vervanging van bestaande bestanden als volgt te werk:
    1. Ga naar de installatiemap van Microsoft Dynamics NAV ODBC-stuurprogramma. De Microsoft Dynamics NAV ODBC-stuurprogramma is meestal in de volgende map geïnstalleerd:
      C:\Program Files\Common Files\Navision\NODBC\
    2. Kopieer de bestanden die u hebt gedownload.
    3. Plak de bestanden die u hebt gedownload in de installatiemap van Microsoft Dynamics NAV ODBC-stuurprogramma.
    4. Klik op Ja om te overschrijven de bestanden in de directory.

Tijdelijke oplossing


Om dit probleem te omzeilen, door de eigenschap MaintainSIFTIndex op de sleutels van de desbetreffende tabel uit te schakelen. Schakel vervolgens de eigenschap MaintainSIFTIndex op die toetsen. Nu worden de SIFT-tabel hersteld met behulp van de juiste bedragen.

Status


Microsoft heeft bevestigd dat dit een fout in de Microsoft-producten die worden vermeld in de sectie 'Van toepassing op' is.

Meer informatie


Lege SIFT-records verwijderen, een van de volgende methoden te gebruiken.

Methode 1

  1. In Microsoft SQL Server Option voor Microsoft Dynamics NAV, wijs Database aan in het menu bestand en klik vervolgens op gegevens.
  2. Klik op tabellen. Klik vervolgens op optimaliseren.

Methode 2

Externe SQL-scripts gebruiken.

Referenties


Voor meer informatie klikt u op het volgende artikelnummer om het artikel in de Microsoft Knowledge Base weer te geven:

824684 beschrijving van de standaardterminologie die wordt gebruikt om software-updates voor Microsoft te beschrijven