U kan niet bepalen welke velden beschikbaar zijn en welke velden zijn niet beschikbaar wanneer u een dialoogvenster in Microsoft Dynamics NAV opent


Microsoft Business Solutions-Navision 4.0 en Microsoft Navision 4.0 maken nu deel uit van Microsoft Dynamics NAV 4.0. Alle verwijzingen naar Microsoft Business Solutions-Navision of Microsoft Navision 4.0 hebben betrekking op Microsoft Dynamics NAV.
Dit artikel is van toepassing op Microsoft Dynamics NAV 4.0 voor alle regio's.

Symptomen


Wanneer u een dialoogvenster in Microsoft Dynamics NAV opent, u kan niet bepalen welke velden beschikbaar zijn en welke velden zijn niet beschikbaar omdat de velden beschikbaar blijken te zijn. Dit probleem treedt op als aan de volgende voorwaarden voldaan wordt:
  • U gebruikt Microsoft Dynamics NAV op een computer met Windows Vista.
  • Het kleurenschema Windows Aero is ingeschakeld op de computer.
Dit probleem doet zich bijvoorbeeld voor wanneer u het dialoogvenster Klantenkaart in Microsoft Dynamics NAV. opent Wanneer u dit doet, worden de velden Saldo en de Kredietlimiet hebben dezelfde kleur. Het veld Saldo moet worden in grijs weergegeven omdat deze niet beschikbaar is.

Oorzaak


Dit probleem treedt op omdat Microsoft Dynamics NAV besturingselementen van Windows met een ander uiterlijk gebruikt wanneer de computer wordt Windows Vista uitgevoerd.

Oplossing


Informatie over de hotfix

Een ondersteunde hotfix is nu beschikbaar bij Microsoft. De hotfix verhelpt het probleem dat wordt beschreven in dit artikel. Toepassen van de hotfix alleen uit op systemen waarop dit specifieke probleem zich voordoet.

U lost dit probleem meteen contact opnemen met Technical Support voor Microsoft Dynamics en verwante producten om de hotfix te verkrijgen. Naar de Microsoft Dynamics-site en dien een nieuw ondersteuningsverzoek in. Hiertoe gaat u naar de volgende Microsoft-website:U kunt ook contact opnemen met Technical Support voor Microsoft Dynamics en verwante producten via de telefoon op (888) 477-7877.

Opmerking In speciale gevallen kunnen kosten die verbonden zijn aan ondersteuningsoproepen ondersteuning worden geannuleerd als een medewerker van Technical Support voor Microsoft Dynamics en verwante producten bepaalt dat een specifieke update de oplossing van uw probleem. De normale ondersteuningskosten van toepassing op alle extra ondersteuningsvragen die niet in aanmerking voor de specifieke update in kwestie komen.

Hoe kunt u de Microsoft Dynamics NAV-hotfix- of updatebestanden

Nadat u een Microsoft Dynamics NAV-hotfix of een updatebestand hebt aangevraagd bij Technical Support voor Microsoft Dynamics, wordt een hyperlink in een e-mailbericht naar u verzonden.


Het e-mailbericht bevat een hyperlink en een wachtwoord. De hyperlink kunt u de Microsoft Dynamics NAV-hotfix of de updatebestanden te downloaden. Wanneer u op de hyperlink klikt, wordt het dialoogvenster Bestand downloaden-Beveiligingswaarschuwing geopend. Vervolgens wordt u gevraagd uitvoeren, opslaan of het downloadproces.


Als u op uitvoerenklikt, worden de bestanden start het downloaden en het proces van extractie. U moet een map opgeven voor de nieuwe bestanden en vervolgens het wachtwoord opgeven.


Als u op Opslaanklikt, moet u een pad voor het opslaan van het gecomprimeerde bestand. Wanneer u het opgeslagen bestand opent, wordt u gevraagd een pad voor de bestanden op te geven. U moet vervolgens het wachtwoord in het e-mailbericht opgeven.


Als u op Annulerenklikt, wordt het downloadproces gestopt.

Een Microsoft Dynamics NAV-hotfix installeren of bijwerken van bestand

De Microsoft Dynamics NAV Platformhotfixes en updates worden beschikbaar gesteld als afzonderlijke bestanden. Als u een Microsoft Dynamics NAV-hotfix of update installeert, moet u de bestaande bestanden van Microsoft Dynamics NAV-installatie met de hotfix of de updatebestanden vervangen. Ga hiervoor als volgt te werk.

Microsoft Dynamics NAV 4.0 SP3

Stap 1: Het Microsoft Dynamics NAV Client-installatie-bestand vervangen

In de Microsoft Dynamics NAV client-installatie vervangt de volgende bestanden met de hotfix of update-bestand.
BestandsnaamBestandsversieBestandsgrootteDatumTijdPlatform
Dbm.dll4.0.3.25206345,20813-Sep-200720:18x86
Fin.exe4.0.3.252068,119,41613-Sep-200720:18x86
Fin.exe.manifestNiet van toepassing71111-Sep-200721:13Niet van toepassing
Finhlink.exe4.0.3.25206119,92813-Sep-200720:17x86
Finsql.exe4.0.3.252068,168,56813-Sep-200720:18x86
Finsql.exe.manifestNiet van toepassing71414-Dec-200616:41Niet van toepassing
Nc_netb.dll4.0.3.2520678,96813-Sep-200720:17x86
Nc_tcp.dll4.0.3.2520683,06413-Sep-200720:17x86
Nc_tcps.dll4.0.3.2520691,25613-Sep-200720:17x86

Ter vervanging van de bestaande bestanden van Microsoft Dynamics NAV als volgt te werk:
  1. Sluit de Microsoft Dynamics NAV-Client.
  2. Ga naar de installatiemap van Microsoft Dynamics NAV-Client.

    Opmerking De Microsoft Dynamics NAV-Client wordt gewoonlijk geïnstalleerd in de volgende map:
    C:\Program Files\Microsoft Business Solutions-Navision\Client\
  3. Kopieer de bestanden die u hebt gedownload.
  4. Plak de bestanden die u hebt gedownload in de installatiemap van Microsoft Dynamics NAV-Client.
  5. In het
    Vervangen van bestand bevestigen
    dialoogvenster op Ja om te overschrijven de bestanden in de installatiemap.

Microsoft Dynamics NAV 2009

Stap 1: De installatiebestanden voor de Client voor Microsoft Dynamics NAV Classic vervangen

In de installatie van Client voor Microsoft Dynamics NAV Classic, vervangt de volgende bestanden met de hotfix of update-bestand.
BestandsnaamBestandsversieBestandsgrootteDatumTijdPlatform
Dbm.dll6.0.29415.0444,2321-July-20099:19x86
Fin.exe6.0.29415.012,244,7921-July-20099:19x86
Finhlink.exe6.0.29415.0452,4321-July-20099:19x86
Finsql.exe6.0.29415.012,330,8321-July-20099:19x86
Nc_netb.dll6.0.29415.0108,3521-July-20099:19x86
Nc_tcp.dll6.0.29415.0108,3681-July-20099:19x86
Nc_tcps.dll6.0.29415.0153,4081-July-20099:19x86
Ndbcs.dll6.0.29415.01,333,0721-July-20099:19x86
Slave.exe6.0.29415.0161,6161-July-20099:19x86

Ter vervanging van de bestaande bestanden van Microsoft Dynamics NAV als volgt te werk:
  1. Sluit de Microsoft Dynamics NAV-Client.
  2. Ga naar de installatiemap voor de Client voor Microsoft Dynamics NAV Classic.

    Opmerking De klassieke Client voor Microsoft Dynamics NAV wordt gewoonlijk geïnstalleerd in de volgende map:
    C:\Program Files\Microsoft Dynamics NAV\60\CSIDE Client\
  3. Kopieer de bestanden die u hebt gedownload.
  4. Plak de bestanden die u hebt gedownload in de installatiemap voor de Client voor Microsoft Dynamics NAV Classic.
  5. In het
    Vervangen van bestand bevestigen
    dialoogvenster op Ja om te overschrijven de bestanden in de installatiemap.

Stap 2: De installatiebestanden van Microsoft Dynamics NAV rolgerichte Client vervangen

In de installatie van Microsoft Dynamics NAV rolgerichte Client, vervangt de volgende bestanden met de hotfix of update-bestand.
BestandsnaamBestandsversieBestandsgrootteDatumTijdPlatform
Dundaswinchart.dll5.0.0.16922,733,9041-Jul-20099:19x86
Microsoft.dynamics.framework.patterns.dll1.2.10579.17371,64830-Jun-20097:21x86
Microsoft.dynamics.framework.ui.dll1.2.10579.173654,28030-Jun-20097:21x86
Microsoft.dynamics.framework.ui.mapping.dll1.2.10579.173101,33630-Jun-20097:21x86
Microsoft.dynamics.framework.ui.navigation.dll1.2.10579.17322,49630-Jun-20097:21x86
Microsoft.dynamics.framework.ui.ux2006.dll1.2.10579.17393,0641-Jul-20099:08x86
Microsoft.dynamics.framework.ui.ux2006.winforms.dll1.2.10579.17339,8401-Jul-20099:08x86
Microsoft.dynamics.framework.ui.windows.dll1.2.10579.17384,95230-Jun-20097:21x86
Microsoft.dynamics.framework.ui.winforms.controls.dll1.2.10579.1732,067,44030-Jun-20097:21x86
Microsoft.dynamics.framework.ui.winforms.dll1.2.10579.173633,82430-Jun-20097:21x86
Microsoft.dynamics.nav.client.builder.dll1.2.10579.173166,7921-Jul-20099:08x86
Microsoft.dynamics.nav.client.exe6.0.29415.0142,2001-Jul-20099:08x86
Microsoft.dynamics.nav.client.interop.communicator.dll6.0.29415.076,7041-Jul-20099:08x86
Microsoft.dynamics.nav.client.serviceconnection.dll6.0.29415.076,7041-Jul-20099:08x86
Microsoft.dynamics.nav.client.ui.dll6.0.29415.0428,9201-Jul-20099:08x86
Microsoft.dynamics.nav.client.winforms.dll6.0.29415.0277,3841-Jul-20099:08x86
Microsoft.dynamics.nav.client.winforms.tlb6.0.29415.02,6521-Jul-20094:37Niet van toepassing
Microsoft.dynamics.nav.language.dllNiet van toepassing1,866,6161-Jul-20099:08x86
Microsoft.dynamics.nav.types.dll6.0.29415.0383,8561-Jul-20099:08x86
Microsoft.office.interop.outlook.dll10.0.4504.0396,1521-Jul-20099:08x86
Ter vervanging van bestaande bestanden als volgt te werk:
  1. Sluit de Microsoft Dynamics NAV rolgerichte Client.
  2. Ga naar de installatiemap van Microsoft Dynamics NAV rolgerichte Client. De rolgerichte Client voor Microsoft Dynamics NAV wordt gewoonlijk geïnstalleerd in de volgende map:
    C:\Program Files\Microsoft Dynamics NAV\60\RoleTailored Client
  3. Kopieer de bestanden die u hebt gedownload.
  4. Plak de bestanden die u hebt gedownload in de installatiemap van Microsoft Dynamics NAV rolgerichte Client.
  5. Klik desgevraagd op Ja om te overschrijven de bestanden in de installatiemap.

Stap 3: De installatiebestanden van Microsoft Dynamics NAV Server vervangen

In de installatie van Microsoft Dynamics NAV Server vervangt de volgende bestanden met de hotfix of update-bestand.
BestandsnaamBestandsversieBestandsgrootteDatumTijdPlatform
Httpcfg.exe5.2.3790.022,3521-Jul-20099:08x86
Microsoft.dynamics.nav.language.dll6.0.29415.01,865,6001-Jul-20099:08x86
Microsoft.dynamics.nav.ncl.dll6.0.29415.0489,3361-Jul-20099:08x86
Microsoft.dynamics.nav.server.exe6.0.29415.0137,0881-Jul-20099:08x86
Microsoft.dynamics.nav.server.exe.configNiet van toepassing21117-Jun-20093:29Niet van toepassing
Microsoft.dynamics.nav.service.dll6.0.29415.0120,7041-Jul-20099:08x86
Microsoft.dynamics.nav.service.runtime.dll6.0.29415.063,3761-Jul-20099:08x86
Microsoft.dynamics.nav.service.webservices.dll6.0.29415.0128,9201-Jul-20099:08x86
Microsoft.dynamics.nav.types.dll6.0.29415.0382.8401-Jul-20099:08x86
Microsoft.dynamics.nav.watson.dll6.0.29415.038,7841-Jul-20099:08x86
Nclcsrt.etxNiet van toepassing87,2791-Jul-200912:52Niet van toepassing
Nclcsrt.stxNiet van toepassing81,0831-Jul-200912:52Niet van toepassing
Nclcsrts.dllNiet van toepassing1,394,5121-Jul-20099:19x86
Ndbcs.dll6.0.29415.01,333,0721-Jul-20099:19x86
Ga als volgt te werk om de bestanden te vervangen:
  1. Stop de service Microsoft Dynamics NAV-server.
  2. Ga naar de installatiemap van Microsoft Dynamics NAV server-service.




    Opmerking De server-service van Microsoft Dynamics NAV wordt gewoonlijk geïnstalleerd in de volgende map:
    C:\Program files\Microsoft Dynamics NAV\60\Service
  3. Kopieer de bestanden die u hebt gedownload.
  4. Plak de bestanden die u hebt gedownload in de installatiemap van Microsoft Dynamics NAV server-service.
  5. Klik op Ja om te overschrijven de bestanden in de directory.
  6. Start de service Microsoft Dynamics NAV-server.

Stap 4: Vervang Common Files bestanden

Vervang de volgende bestanden in de map Common Files.
BestandsnaamBestandsversieBestandsgrootteDatumTijdPlatform
Customization.xmlNiet van toepassing1,11517-Jun-20093:24Niet van toepassing
Msoutl.olb11.0.5510.0200,24817-Jun-20093:24Niet van toepassing
Ter vervanging van bestaande bestanden als volgt te werk:
  1. Zoek de map Common Files:
    C:\Program Files\Common Files\Microsoft Dynamics NAV\OLSync
  2. Kopieer de bestanden die u hebt gedownload.
  3. Plak de bestanden die u hebt gedownload in de map Common Files.
  4. Klik desgevraagd op Ja om te overschrijven de bestanden in de installatiemap.

Stap 5: Vervangen Windows\System32 bestanden

Vervangt de volgende bestanden in de map Windows\System32.
BestandsnaamBestandsversieBestandsgrootteDatumTijdPlatform
Cdo.dll6.5.7940.0775,4801-Jul-20099:19x86
Gapi32.dll6.5.7940.071,4881-Jul-20099:19x86
Ter vervanging van bestaande bestanden als volgt te werk:
  1. Zoek de map Windows\System32:
    C:\Windows\System32
  2. Kopieer de bestanden die u hebt gedownload.
  3. Plak de bestanden die u hebt gedownload in de map Common Files.
  4. Klik desgevraagd op Ja om te overschrijven de bestanden in de installatiemap.

Vereisten

Hebt u een van de volgende producten geïnstalleerd om deze hotfix:
  • Microsoft Dynamics NAV 4.0 SP3 hotfix KB 940718
  • Microsoft Dynamics NAV 2009

Informatie over verwijderen

U kunt deze hotfix niet verwijderen.

Opnieuw opstarten


Als u wordt gevraagd de computer opnieuw wilt opstarten, moet u de computer opnieuw opstarten nadat u deze hotfix hebt toegepast.

Status


Microsoft heeft bevestigd dat dit probleem kan optreden in de Microsoft-producten die worden vermeld in de sectie 'Van toepassing op'.

Meer informatie


Voor meer informatie over terminologie voor software-updates klikt u op het volgende artikelnummer om het artikel in de Microsoft Knowledge Base weer te geven:
824684 beschrijving van de standaardterminologie die wordt gebruikt om software-updates voor Microsoft te beschrijven