Foutbericht wanneer u een rapport afdrukt in Microsoft Dynamics CRM 3.0: 'Unable to print-clientprotocol laden'


Symptomen


Wanneer u een rapport afdrukt in Microsoft Dynamics CRM 3.0, wordt het volgende foutbericht weergegeven:
Kan niet afdrukken-clientprotocol laden.

Oorzaak


Dit probleem kan optreden als de ActiveX-componenten niet zijn geïnstalleerd.

Oplossing


U lost dit probleem, kunnen de ActiveX-instellingen in Windows Internet Explorer. Voeg vervolgens de volgende URL's toe aan de zone Lokaal Intranet:
  • De URL voor de computer waarop de Microsoft Dynamics CRM-server
  • De URL voor de computer waarop Microsoft SQL Server Reporting Services
Ga hiervoor als volgt te werk:
  1. Start Windows Internet Explorer.
  2. Klik in het menu Extra op Internet-opties.
  3. Op het tabblad beveiliging , klik op Lokaal Intraneten klik op websites
  4. Klik op Geavanceerd.
  5. Typ de URL voor de computer waarop Microsoft Dynamics CRM-server in het vak deze website aan de zone toevoegen en klik vervolgens op toevoegen.
  6. Typ de URL voor de computer waarop Microsoft SQL Server Reporting Services wordt uitgevoerd in het vak deze website aan de zone toevoegen en klik vervolgens op toevoegen.
  7. Sluit het dialoogvenster Lokaal Intranet en klik vervolgens op OK.
  8. Klik op het tabblad beveiliging op Aangepast niveau.
  9. Klik op inschakelen voor elke component die wordt vermeld onder ActiveX-besturingselementen en -invoegtoepassingen.
  10. Klik op OK om het dialoogvenster Internet-opties te sluiten.
  11. Windows Internet Explorer af te sluiten en start Microsoft Dynamics CRM 3.0.
  12. Probeer het rapport afdrukt.

    Als u doorgaat met het probleem dat wordt beschreven in de sectie 'Symptomen', handmatig de ActiveX-componenten te installeren. Ga hiervoor als volgt te werk:
    1. Zoek de map rapport Server\bin.

      Opmerkingen
      • Als u Microsoft SQL Server 2000 Reporting Services wordt uitgevoerd, wordt de map bevindt zich op de volgende locatie:
        C:\Program Files\Microsoft SQL Server\MSSQL\Reporting Services\ReportServer\bin
      • Als u Microsoft SQL Server 2005 Reporting Services wordt uitgevoerd, wordt de map bevindt zich op de volgende locatie:
        C:\Program Files\Microsoft SQL Server\MSSQL.4\Reporting Services\ReportServer\bin
    2. Klik met de rechtermuisknop op het bestand RSClientPrint.cab en klik op uitpakken. Pak het bestand naar de map die u in stap 12 bis.
    3. Klik met de rechtermuisknop op het bestand RSClientPrint.inf dat u hebt uitgepakt in stap 12b en klik vervolgens op installeren.
    4. Probeer het rapport af te drukken.

Meer informatie


SQL Server Reporting Services maakt gebruik van het afdrukken van een ActiveX-besturingselement naar besturingselement afdrukfuncties in Windows Internet Explorer. Als de ActiveX-componenten niet zijn geïnstalleerd op de computer waarop Microsoft Dynamics CRM 3.0 wordt uitgevoerd, ontvangt u het foutbericht dat wordt vermeld in de sectie 'Symptomen'.