SharePoint 2013 of 2013 installatie van Project Server-fout als de 4.6 .NET Framework is geïnstalleerd.

BELANGRIJK: Dit artikel is vertaald door middel van automatische vertalingssoftware van Microsoft en is mogelijk nabewerkt door de Microsoft Community via CTF-technologie (Community Translation Framework) of door een menselijke vertaler. Microsoft biedt zowel automatisch vertaalde, door mensen vertaalde en door de community nabewerkte artikelen aan, zodat er in meerdere talen toegang is tot alle artikelen in onze Knowledge Base. Een vertaald of bewerkt artikel kan fouten bevatten in vocabulaire, syntaxis of grammatica.. Microsoft is niet verantwoordelijk voor eventuele onjuistheden, fouten of schade ten gevolge van een foute vertaling van de inhoud van een bericht of het gebruik van deze vertaalde berichten door onze klanten.

De Engelstalige versie van dit artikel is de volgende: 3087184
Symptomen
Wanneer u Microsoft SharePoint Foundation 2013 met Service Pack 1 Setup, SharePoint Server 2013 met Service Pack 1 Setup of Project Server 2013 met Service Pack 1 Setup op een computer met Microsoft .NET Framework 4.6, 4.6.1 en 4.6.2 is geïnstalleerd uitvoert, wordt het volgende foutbericht weergegeven:
Setup kan niet doorgaan vanwege de volgende fout(en):
Dit product is Microsoft .net Framework 4.5 vereist.
Oorzaak
Dit probleem treedt op omdat de installatie van SharePoint en Project Server Setup-programma's niet herkend door de .NET Framework 4.6, 4.6.1 en 4.6.2 als een ondersteunde versie van .NET Framework.
Oplossing
U kunt dit probleem oplossen door de volgende stappen uit te voeren:

  1. Pak de installatiemedia naar een beschrijfbare locatie.

    • Als het installatiemedium is een uitvoerbaar bestand (.exe), pak de bestanden en mappen uit het exe-bestand naar een beschrijfbare locatie door met de volgende opdracht bij een opdrachtprompt:

      <executable file name> /extract:<path to writable location>
      Bijvoorbeeld de volgende opdracht uitvoeren:

      sharepoint.exe /extract:C:\SharePointInstaller
    • Als het installatiemedium is een ISO of IMG schijfkopie (.iso of .img), koppel de installatiekopie van de cd en kopieer de bestanden en mappen van de schijfkopie op een beschrijfbare locatie.
  2. Download het gecomprimeerde (Zip) bestand met de correctie die overeenkomt met het product dat u installeert:

  3. Open het ZIP-bestand.
  4. Het volgende bestand, afhankelijk van de Setup-ondersteuning van het ZIP-bestand naar de map 'updates' op de beschrijfbare locatie kopiëren.

    • SharePoint Foundation 2013 met servicepack 1: wsssetup.dll
    • SharePoint Server 2013 met servicepack 1: svrsetup.dll
    • Project Server 2013 met servicepack 1: svrsetup.dll
  5. Voer Setup.exe vanaf de locatie beschrijfbare installatie van SharePoint of Project Server Setup te starten. Setup gebruikt het ondersteuningsbestand met de correctie die u hebt gekopieerd naar de map 'updates'.
Workaround
Als u de fix-methode die wordt geleverd in de sectie 'Oplossing' niet gebruiken, is een alternatieve methode beschikbaar.

Om dit probleem te omzeilen, moet het .NET Framework 4.6, 4.6.1 en 4.6.2 is niet geïnstalleerd tijdens het uitvoeren van de installatie van SharePoint.

Als Microsoft .NET Framework 4.6, 4.6.1 en 4.6.2 reeds is geïnstalleerd, gaat u als volgt te werk:
  1. Verwijder .NET Framework 4.6, 4.6.1 en 4.6.2. Hiertoe gaat u naar de locatie die specifiek is voor uw besturingssysteem, zoals vermeld in de volgende artikelen in de Microsoft Knowledge Base:
    3151800 De .NET Framework 4.6.2 offline installer voor Windows
    3102436 De .NET Framework 4.6.1 offline installer voor Windows
    3045557 Microsoft .NET Framework 4.6 (Offline Installer) voor Windows
    Opmerking In Windows Server 2012 R2 of Windows Server 2012, .NET Framework is een onderdeel van het besturingssysteem en kan niet afzonderlijk worden verwijderd. Updates voor .NET Framework worden weergegeven in de Geïnstalleerde Updates tabblad van het deelvenster Beheer Programma's en onderdelen App. Voor systemen waarop .NET Framework is niet vooraf geïnstalleerd, het .NET Framework wordt weergegeven in de Verwijderen of wijzigen van een programma tabblad (of de Programma's toevoegen of verwijderen tabblad) van de Programma's en onderdelen App in het Configuratiescherm. Zie Problemen met geblokkeerde .NET Framework-installaties en Uninstallations en de Microsoft Knowledge Base-artikelen die eerder zijn vermeld voor meer informatie.
  2. Start de computer opnieuw op.
  3. Installeer de Web-installer voor .NET Framework 4.5.2.
  4. Installatie van SharePoint om te installeren van SharePoint worden uitgevoerd.
Nadat SharePoint is geïnstalleerd, kunt u naar de .NET Framework 4.6, 4.6.1 en 4.6.2 van .NET Framework 4.5.2 bijwerken.
Meer informatie
Hoewel u het foutbericht weergegeven tijdens de installatie wordt, SharePoint Foundation 2013 en SharePoint Server 2013 worden nog steeds ondersteund nadat u een naar de .NET Framework 4.6, 4.6.1 voor .NET Framework of het .NET Framework 4.6.2 upgrade.

Opmerking Formele ondersteuning voor .NET Framework 4.5.1, 4.5 en 4.0 beëindigd in januari 2016.
Status
Microsoft heeft bevestigd dat dit probleem kan optreden in de Microsoft-producten die worden vermeld in de sectie 'Van toepassing op'.

Waarschuwing: dit artikel is automatisch vertaald

Eigenschappen

Artikel-id: 3087184 - Laatst bijgewerkt: 09/13/2016 22:39:00 - Revisie: 10.0

Microsoft SharePoint Server 2013, Microsoft SharePoint Foundation 2013

  • kbprb kbsurveynew kbmt KB3087184 KbMtnl
Feedback