De fout #WAARDE! corrigeren in de functies GEMIDDELDE of SOM

Als GEMIDDELDE of SOM verwijst naar cellen die #VALUE! fouten, resulteert de formules in een #VALUE! weergegeven.

Fout #WAARDE! in GEMIDDELDE

Om de foutwaarden te negeren, maken we een formule die de fouten in het bereik van de verwijzing negeert tijdens de berekening van het gemiddelde met de resterende 'normale' waarden.

Om dit scenario te omzeilen, gebruiken we een combinatie van GEMIDDELDE in combinatie met ALS en ISFOUT om te bepalen of het opgegeven bereik een fout bevat. Voor dit specifieke scenario is een matrixformule vereist:

=GEMIDDELDE(ALS(ISFOUT(B2:D2);"";B2:D2))

Dit is een matrixformule. U moet dus op Enter drukken (alleen als u Microsoft 365 ) of Ctrl+Shift+Enter in de formule.

Opmerking: Als u een huidige versie van Microsoft 365,kunt u de formule gewoon invoeren in de uitvoercel en vervolgens op Enter drukken om de formule te bevestigen als een dynamische matrixformule. Anders moet de formule worden ingevoerd als een oudere matrixformule door eerst de uitvoercel te selecteren, de formule in de uitvoercel in te voeren en vervolgens op Ctrl+Shift+Enter te drukken om deze te bevestigen. In Excel worden automatisch accolades aan het begin en einde van de formule geplaatst. Zie Richtlijnen en voorbeelden van matrixformules voor meer informatie over matrixformules.

Matrixfunctie in GEMIDDELDE om de #VALUE! corrigeren

Opmerking: De bovenstaande functie werkt niet alleen voor #WAARDE!, maar ook voor #N/B, #LEEG!, #DEEL/0! en meer.

U kunt SOM ook op dezelfde manier gebruiken:

=SOM(ALS(ISFOUT(B2:D2);"";B2:D2))

Hebt u een vraag over een bepaalde functie?

Stel een vraag op het forum van de Excel-community

Meer hulp nodig?

U kunt altijd uw vraag stellen aan een expert in de Excel Tech Community of ondersteuning vragen in de Answers-community.

Zie ook

De fout #WAARDE! corrigeren

GEMIDDELDE, functie

SOM, functie

Overzicht van formules in Excel

Fouten opsporen in formules

Alle Excel functies (alfabetisch)

Alle Excel-functies (per categorie)

Meer hulp nodig?

Uw Office-vaardigheden uitbreiden
Training verkennen
Als eerste nieuwe functies krijgen
Deelnemen aan Office Insiders

Was deze informatie nuttig?

Hartelijk dank voor uw feedback! Het lijkt ons een goed idee om u in contact te brengen met een van onze Office-ondersteuningsagenten.

×