Gebruik de functie EN, een van de logische functies, om te bepalen of alle voorwaarden in een test WAAR zijn.

Voorbeeld

Voorbeelden van de EN-functie

De functie EN resulteert in WAAR als het resultaat van alle argumenten WAAR is en resulteert in ONWAAR als het resultaat van een of meer argumenten ONWAAR is.

De functie EN wordt vaak gebruikt om andere functies die logische tests uitvoeren uit te breiden. Met de functie ALS wordt bijvoorbeeld een logische test uitgevoerd en een bepaalde waarde geretourneerd als het resultaat van de test WAAR is en een andere waarde als het resultaat van de test ONWAAR is. Als u de functie EN gebruikt als het argument logische-test van de functie ALS, kunt u in plaats van één voorwaarde verschillende voorwaarden testen.

Syntaxis

EN(logisch1; [logisch2]; ...)

De syntaxis van de functie EN heeft de volgende argumenten:

Argument

Beschrijving

logisch1

Vereist. De eerste voorwaarde die u wilt testen en waarvan het resultaat WAAR of ONWAAR kan zijn.

Logisch2, ...

Optioneel. Maximaal 255 extra voorwaarden die u wilt testen en waarvan het resultaat WAAR of ONWAAR kan zijn.

Opmerkingen

  • De argumenten moeten als resultaat logische waarden zoals WAAR of ONWAAR geven, of de argumenten moeten bestaan uit matrices of verwijzingen die logische waarden bevatten.

  • Als een matrix- of verwijzingsargument tekst of lege cellen bevat, worden deze waarden genegeerd.

  • Als het opgegeven bereik geen logische waarden bevat, geeft de functie EN de fout #WAARDE! als resultaat.

Voorbeelden

Hier volgen enkele algemene voorbeelden van het gebruik van EN op zichzelf en in combinatie met de functie ALS.

Voorbeelden van het gebruik van ALS-functies met EN

Formule

Beschrijving

= EN(A2>1;A2<100)

Resulteert in WAAR als A2 groter is dan 1 EN kleiner dan 100. Anders wordt ONWAAR weergegeven.

=ALS(EN(A2<A3;A2<100);A2; "De waarde ligt buiten het bereik.")

Geeft de waarde in cel A2 weer als deze kleiner is dan A3 EN kleiner is dan 100. Anders wordt het bericht 'De waarde ligt buiten het bereik.' weergegeven.

=ALS(EN(A3>1;A3<100);A3;"De waarde ligt buiten het bereik.")

Geeft de waarde in cel A3 weer als deze groter is dan 1 EN kleiner dan 100, anders wordt er een bericht weergegeven. U kunt elk bericht van uw keuze vervangen.

Bonusberekening

Hier volgt een veelvoorkomend scenario, waar we met ALS en EN moeten berekenen of verkopers in aanmerking komen voor een bonus.

Voorbeeld van een berekening van een verkoopbonus met de functies ALS en EN.  Formule in cel E14 is =ALS(EN(B14>=$B$7;C14>=$B$5);B14*$B$8;0)
  • =ALS(EN(B14>=$B$7;C14>=$B$5);B14*$B$8,0)ALS de totale verkoop groter is dan of gelijk is aan (> =) het verkoopdoel EN het aantal accounts is groter dan of gelijk aan (> =) het accountdoel, vermenigvuldig dan de totale verkoop met het bonuspercentage. Geef in andere gevallen het cijfer 0 als resultaat.

Meer hulp nodig?

U kunt altijd uw vraag stellen aan een expert in de Excel Tech Community of ondersteuning vragen in de Answers-community.

Verwante onderwerpen

Video: Geavanceerde ALS-functies
Meer informatie over het gebruik van geneste functies in een formule
ALS, functie
OF, functie
NOT, functie
Overzicht van formules in Excel
Gebroken formules voorkomen
Fouten in formules detecteren
Sneltoetsen in Excel
Logische functies (verwijzing)
Excel functies (alfabetisch)
Excel functies (per categorie)

Meer hulp nodig?

Uw vaardigheden uitbreiden
Training verkennen
Als eerste nieuwe functies krijgen
Deelnemen aan Microsoft insiders

Was deze informatie nuttig?

Hoe tevreden bent u met de vertaalkwaliteit?
Wat heeft uw ervaring beïnvloed?

Bedankt voor uw feedback.

×