FIELDVALUE, functie

U kunt de functie veld waarde gebruiken om veld gegevens op te halen uit gekoppelde gegevenstypen, zoals het gegevenstypeaandelen of geografie. U kunt eenvoudiger formules schrijven die naar gegevenstypen verwijzen, zodat de functie veld waarde hoofdzakelijk wordt gebruikt voor het maken van voorwaardelijke berekeningen op basis van gekoppelde gegevenstypen.

Opmerking: 28 maart 2019: gegevenstypen zijn vrijgegeven aan alle Windows Microsoft 365-abonnees. Zorg dat u de nieuwste versie van Officegebruikt als u eenMicrosoft 365-abonnee bent.

Technische informatie

Syntaxis

= FIELDVALUE(waarde; veldnaam)

De syntaxis van de functie FIELDVALUE heeft de volgende argumenten:

Argument

Beschrijving

waarde

Deze functie retourneert alle overeenkomstige velden van het gekoppelde gegevenstype dat is opgegeven in het argument 'waarde'.

veldnaam

De naam van het veld of de namen van de velden waarvan u de waarde uit het gekoppelde gegevenstype wilt ophalen.

Beschrijving

  • De functie FIELDVALUE retourneert alle overeenkomstige velden van het gekoppelde gegevenstype dat is opgegeven in het argument ‘waarde’.

  • De functie FIELDVALUE hoort in de categorie Zoeken en verwijzen van functies.

Voorbeelden

In het volgende eenvoudige voorbeeld haalt u met de formule =FIELDVALUE(A2;"Prijs") de waarde van het veld Prijs op met het gegevenstype Aandelen voor JM Smucker Co.

De aandelenkoers van een bedrijf ophalen met =FIELDVALUE(A2;"Prijs")

Het volgende voorbeeld is een meer typisch voorbeeld voor de functie FIELDVALUE. Hier gebruiken we de functie ALS.FOUT om te controleren op fouten. Als er geen bedrijfsnaam in cel A2 staat en de formule FIELDVALUE een fout oplevert, willen we dat er niets wordt weergegeven (""). Maar als er wel een bedrijfsnaam staat, willen we de prijs van het gegevenstype in A2 ophalen met =ALS.FOUT(FIELDVALUE($A2;B$1);"").

De aandelenkoers van een bedrijf ophalen en fouten negeren met =ALS.FOUT(FIELDVALUE($A2;B$1);"")

U kunt de functie FIELDVALUE gebruiken om via het argument ‘veldnaam’ te verwijzen naar werkbladcellen, wat betekent dat in de bovenstaande formule wordt verwezen naar cel B1 voor Prijs, in plaats van handmatig ‘Prijs’ in te voeren in de formule. 

Opmerkingen

Als u probeert gegevens op te halen uit een niet-bestaand gegevenstype veld, geeft de functie veld waarde de fout #FIELD! als resultaat.. U hebt bijvoorbeeld ' prijzen ' ingevuld, wanneer het werkelijke gegevenstype veld ' prijs ' wordt genoemd. Controleer de formule om er zeker van te zijn dat u een geldige veld naam gebruikt. Als u een lijst met veldnamen voor een record wilt weergeven, selecteert u de cel voor de record en drukt u op ALT + SHIFT + F10.

Meer hulp nodig?

U kunt altijd uw vraag stellen aan een expert in de Excel Tech Community, ondersteuning vragen in de Answer-community of een nieuwe functie of verbetering voorstellen in Excel User Voice.

Zie ook

Gekoppelde records in Excel

Formules schrijven die naar gegevenstypen verwijzen

De fout #VELD! corrigeren

Opmerking:  Deze pagina is automatisch vertaald en kan grammaticale fouten of onnauwkeurigheden bevatten. Wij hopen dat deze inhoud nuttig voor je is. Wil je ons laten weten of deze informatie nuttig is? Hier is het Engelstalige artikel ter referentie.

Uw Office-vaardigheden uitbreiden
Training verkennen
Als eerste nieuwe functies krijgen
Deelnemen aan Office Insiders

Was deze informatie nuttig?

Bedankt voor uw feedback.

Hartelijk dank voor uw feedback! Het lijkt ons een goed idee om u in contact te brengen met een van onze Office-ondersteuningsagenten.

×