Geneste functies gebruiken in een formule

Als u een functie gebruikt als een van de argumenten in een formule waarin een functie wordt gebruikt, wordt nesting genoemd. We verwijzen naar deze functie als geneste functie. Door bijvoorbeeld de functie GEMIDDELDE en SOM in de argumenten van de functie ALS te nesten, wordt met de volgende formule alleen een reeks getallen opgeteld (G2:G5) als het gemiddelde van een andere reeks getallen (F2:F5) groter is dan 50. Anders wordt 0 als resultaat gegeven.

geneste functies

De functies GEMIDDELDE en SOM zijn genest in de functie ALS.

U kunt maximaal 64 niveaus met functies in een formule nesten.

  1. Klik op de cel waarin u de formule wilt invoeren.

  2. Als u de formule met de functie wilt starten, klikt u op Functie invoegen Knopafbeelding op de formulebalk Knopafbeelding .

    Het gelijkteken (=) is al voor u ingevoegd.

  3. Selecteer in het vak Of selecteer een categorie de optie Alles.

    Als u de functiecategorieën kent, kunt u ook een categorie selecteren.

    Als u niet zeker weet welke functie u moet gebruiken, kunt u in het vak Zoek een functie een vraag typen waarmee u beschrijft wat u wilt doen ('getallen optellen' geeft bijvoorbeeld de functie SOM als resultaat).

  4. Als u een andere functie wilt opgeven als argument, geeft u de functie op in het gewenste argumentvak.

    De onderdelen van de formule in het dialoogvenster Functieargumenten komen overeen met de functie die u hebt geselecteerd in de vorige stap.

    Als u op ALS hebt geklikt,worden in het dialoogvenster Functieargumenten de argumenten voor de functie ALS weergegeven. Als u een andere functie wilt nesten, kunt u deze invoeren in het argumentvak. U kunt bijvoorbeeld SOM(G2:G5) invoeren in het Value_if_true van de functie ALS.

  5. Voer eventuele extra argumenten in die nodig zijn om de formule te voltooien.

    In plaats van een celverwijzing te typen kunt u ook de cellen selecteren waarnaar u wilt verwijzen. Klik Knopafbeelding het dialoogvenster te minimaliseren, selecteer de cellen waarnaar u wilt verwijzen en klik vervolgens op Knopafbeelding om het dialoogvenster opnieuw uit te vouwen.

    Tip: Klik op Help-informatie over deze functie voor meer informatie over de functie en zijn argumenten.

  6. Nadat u alle argumenten voor de functie hebt ingevoerd, klikt u op OK.

  1. Klik op de cel waarin u de formule wilt invoeren.

  2. Als u de formule met de functie wilt starten, klikt u op Functie invoegen Knopafbeelding op de formulebalk Knopafbeelding .

  3. Selecteer in het dialoogvenster Functie invoegen in het vak Een categorie kiezen de optie Alles.

    Als u de functiecategorieën kent, kunt u ook een categorie selecteren.

  4. Als u een andere functie als argument wilt invoeren, voert u de functie in het argumentvak in de opbouwfunctie voor formules of rechtstreeks in de cel in.

  5. Voer eventuele extra argumenten in die nodig zijn om de formule te voltooien.

  6. Nadat u de argumenten voor de formule hebt voltooid, drukt u op Enter.

Voorbeelden

Hieronder ziet u een voorbeeld van het gebruik van geneste ALS-functies om een lettercijfer toe te wijzen aan een numerieke testscore.

Kopieer de voorbeeldgegevens uit de volgende tabel en plak deze in cel A1 van een nieuw Excel-werkblad. Om resultaten van formules weer te geven, selecteert u deze, drukt u op F2 en drukt u vervolgens op Enter. Indien nodig kunt u de kolombreedten aanpassen als u alle gegevens wilt zien.

Score

45

90

78

Formule

Beschrijving

Resultaat

'=ALS(A2>89;"A",ALS(A2>79;"B", ALS(A2>69;"C",ALS(A2>59;"D","F"))))

Hiermee wordt geneste ALS-voorwaarden gebruikt om een lettercijfer toe te wijzen aan de score in cel A2.

=ALS(A2>89;"A",ALS(A2>79;"B",ALS(A2>69;"C",ALS(A2>59,"D","F")))))

'=ALS(A3>89;"A",ALS(A3>79;"B", ALS(A3>69;"C",ALS(A3>59;"D","F"))))

Hiermee worden geneste ALS-voorwaarden gebruikt om een lettercijfer toe te wijzen aan de score in cel A3.

=ALS(A3>89;"A",ALS(A3>79;"B",ALS(A3>69;"C";ALS(A3>59,"D","F")))))

'=ALS(A4>89;"A",ALS(A4>79;"B", ALS(A4>69;"C",ALS(A4>59;"D","F"))))

Hiermee wordt geneste ALS-voorwaarden gebruikt om een lettercijfer toe te wijzen aan de score in cel A4.

=ALS(A4>89,"A",ALS(A4>79;"B",ALS(A4>69;"C";ALS(A4>59,"D","F"))))

Tips: 

Meer hulp nodig?

U kunt altijd uw vraag stellen aan een expert in de Excel Tech Community of ondersteuning vragen in de Answers-community.

Zie ook

Video: Geneste ALS-functies

Meer hulp nodig?

Uw Office-vaardigheden uitbreiden
Training verkennen
Als eerste nieuwe functies krijgen
Deelnemen aan Office Insiders

Was deze informatie nuttig?

×