De functie SOMPRODUCT retourneert de som van de producten van overeenkomende bereik of matrices. De standaardbewerking is vermenigvuldiging, maar optellen, aftrekken en deling zijn ook mogelijk.

In dit voorbeeld gebruiken we SOMPRODUCT om de totale verkoop voor een bepaald item en de grootte te retourneren:

Voorbeeld van het gebruik van de functie SOMPRODUCT om de totale verkoop te retourneren wanneer de productnaam, de grootte en de afzonderlijke verkoopwaarden voor elk product worden opgegeven.

SOMPRODUCT komt overeen met alle exemplaren van item Y/grootte M en somt deze op, dus in dit voorbeeld is 21 plus 41 gelijk aan 62.

Syntaxis

De standaardbewerking (vermenigvuldiging) gebruiken:

=SOMPRODUCT(matrix1; [matrix2], [matrix3], ...)

De syntaxis van de functie SOMPRODUCT heeft de volgende argumenten:

Argument

Beschrijving

matrix1   

Vereist

Het eerste matrixargument waarvan u de elementen wilt vermenigvuldigen en vervolgens wilt optellen.

[matrix2], [matrix3],...    

Optioneel

Matrixargumenten 2 tot en met 255 waarvan u de elementen wilt vermenigvuldigen en vervolgens wilt optellen.

Andere rekenkundige bewerkingen uitvoeren

Gebruik SOMPRODUCT zoals gewoonlijk, maar vervang de komma's tussen de matrixargumenten door de rekenkundige operatoren die u wilt gebruiken (*, /, +, -). Nadat alle bewerkingen zijn uitgevoerd, worden de resultaten zoals gewoonlijk opgeteld.

Opmerking: Als u rekenkundige operatoren gebruikt, kunt u overwegen om de matrixargumenten tussen haakjes te plaatsen en haakjes te gebruiken om de matrixargumenten te groeperen om de volgorde van rekenkundige bewerkingen te bepalen.

Opmerkingen

  • De opgegeven matrices moeten dezelfde dimensie hebben. Als dat niet het geval is, geeft SOMPRODUCT de foutwaarde #WAARDE! als resultaat. =SOMPRODUCT(C2:C10;D2:D5) retourneert bijvoorbeeld een fout omdat de bereiks niet dezelfde grootte hebben.

  • SOMPRODUCT behandelt niet-numerieke matrixgegevens alsof het nullen zijn.

  • Voor de beste prestaties mag SOMPRODUCT niet worden gebruikt met volledige kolomverwijzingen. Houd rekening met =SOMPRODUCT(A:A;B:B), hier vermenigvuldigt de functie de 1.048.576 cellen in kolom A met de 1.048.576 cellen in kolom B voordat u deze toevoegt. 

Voorbeeld 1

Voorbeeld van de functie SOMPRODUCT die wordt gebruikt om de som van de verkochte items als opgegeven kosten per eenheid en hoeveelheid te retourneren.

Als u de formule wilt maken met behulp van de bovenstaande voorbeeldlijst, typt u =SOMPRODUCT(C2:C5;D2:D5) en drukt u op Enter. Elke cel in kolom C wordt vermenigvuldigd met de bijbehorende cel in dezelfde rij in kolom D en de resultaten worden opgeteld. Het totale bedrag voor de boodschappen is $ 78,97.

Als u een langere formule wilt schrijven die hetzelfde resultaat geeft, typt u =C2*D2+C3*D3+C4*D4+C5*D5 en drukt u op Enter. Nadat u op Enter drukt, is het resultaat hetzelfde: $ 78,97. Cel C2 wordt vermenigvuldigd met D2 en het resultaat wordt toegevoegd aan het resultaat van cel C3-tijdcel D3, en zo verder.

Voorbeeld 2

In het volgende voorbeeld wordt SOMPRODUCT gebruikt om de totale nettoverkoop per verkoopagent te retourneren, waarbij we zowel de totale verkoop als de uitgaven per agent hebben. In dit geval gebruiken we een Excel tabel,die gestructureerde verwijzingen gebruikt in plaats van standaardbereiken Excel gebruiken. Hier ziet u dat de verkoop-, onkosten- en agentbereiken op naam worden genoemd.

Voorbeeld van de functie SOMPRODUCT om de totale verkoop per verkoper te retourneren wanneer de verkoop en uitgaven voor elk product worden verstrekt.

De formule is: =SOMPRODUCT(((Tabel1[Verkoop])+(Tabel1[Onkosten]))*(Tabel1[Agent]=B8)) en retourneert de som van alle verkopen en uitgaven voor de agent in cel B8.

Voorbeeld 3

In dit voorbeeld willen we het totaal retourneren van een bepaald item dat door een bepaald gebied is verkocht. In dit geval hoeveel kersen heeft de regio Oost verkocht?

Examen van het gebruik van SOMPRODUCT om de som van items per regio te retourneren. In dit geval is het aantal kersen dat in de regio Oost wordt verkocht.

Hier is de formule: =SOMPRODUCT((B2:B9=B12)*(C2:C9=C12)*D2:D9). Het aantal exemplaren van Oost wordt eerst vermenigvuldigd met het aantal overeenkomende exemplaren van kersen. Ten slotte worden de waarden van de bijbehorende rijen in de kolom Verkoop opgeteld. Als u wilt zien hoe Excel dit berekent, selecteert u de formulecel en gaat u naar Formules > Formule evalueren > evalueren.

Meer hulp nodig?

U kunt altijd uw vraag stellen aan een expert in de Excel Tech Community of ondersteuning vragen in de Answers-community.

Zie ook

Voorwaardelijke berekeningen uitvoeren voor celbereiken

Som op basis van meerdere criteria met SOMMEN.ALS

Aantal op basis van meerdere criteria met AANTAL.ALS

Gemiddelde op basis van meerdere criteria met GEMIDDELDE.ALS

Meer hulp nodig?

Uw vaardigheden uitbreiden
Training verkennen
Als eerste nieuwe functies krijgen
Deelnemen aan Microsoft insiders

Was deze informatie nuttig?

Hoe tevreden bent u met de vertaalkwaliteit?
Wat heeft uw ervaring beïnvloed?

Bedankt voor uw feedback.

×