Symptomen
Wanneer u een verwerkingsbewerking uitvoert op een dimensie in SQL Server Analysis Services en de service onder geheugendruk staat, kan de dimensie niet worden verwerkt en kunnen de gegevens beschadigd raken.
Opmerking: dit probleem treedt op in een relatief zeldzame racevoorwaarde die niet alomtegenwoordig is. Wanneer dit probleem optreedt, kunnen onjuiste dimensierelaties of ProcessUpdate-fouten optreden.
Dit probleem is waargenomen onder de volgende omstandigheden:
Het geheugengebruik van Analysis Services overschrijdt de hoge geheugenlimiet die tijdens het verwerken voor de service is geconfigureerd, waardoor Analysis Services pagina's in het geheugen agressief opschoont.
Er wordt geen fout of bericht geregistreerd over het probleem tijdens de verwerking en de dimensieverwerking mislukt niet. In plaats daarvan wordt de verwerking voltooid en worden beschadigde gegevens weggeschreven naar het dimensiebestand.
Het probleem wordt hoogstwaarschijnlijk weergegeven als onjuiste dimensiekenmerkrelaties voor nieuw toegevoegde dimensieleden. Bijvoorbeeld: een lid in de productdimensie wordt weergegeven onder de verkeerde categorie of subcategorie.
Een andere manier waarop deze beschadiging zichzelf kan onthullen: als een volgende ProcessUpdate op een dimensie die rigide kenmerkrelaties bevat, mislukt de verwerking van dimensies met het volgende foutbericht:
Opmerking
Starre relaties tussen kenmerken kunnen niet worden gewijzigd tijdens incrementele verwerking van een dimensie.
Opmerking: Deze fout kan ook om legitieme redenen optreden, bijvoorbeeld voor wijzigingen in de onderliggende gegevensbron. Als de onderliggende gegevens in de tabel of weergave die dienen als bron voor de dimensie, echter niet zijn gewijzigd, kan dat de oorzaak van de fout zijn.
Het probleem treedt niet altijd op wanneer de server onder geheugendruk staat, maar soms treedt het op als de schonere thread een gegevenspagina voor nieuw toegevoegde dimensieleden verwijdert voordat de dimensieverwerking is voltooid. Dit is een relatief zeldzame racevoorwaarde tussen de dimensieverwerkingsthread en de geheugenopschoonthreads in de Analysis Services-service.
Nadat deze oplossing is geïnstalleerd, zal het probleem niet meer optreden, maar moeten de betreffende objecten opnieuw worden verwerkt om het probleem op te lossen.
- Een ProcessUpdate op een beïnvloede dimensie waarbij de server niet onder geheugendruk staat, corrigeert beschadigingen die door dit probleem zijn veroorzaakt voor alle flexibele relaties. Voor een beïnvloede dimensie die een of meer rigide kenmerkrelaties heeft, mislukt de verwerking met de hierboven vermelde fout.
- Als u het probleem wilt oplossen voor dimensies die starre relaties bevatten, wijzigt u de kenmerkrelaties voor de desbetreffende dimensie op de server en voert u een ProcessUpdate uit. De kenmerkrelatie kan vervolgens weer rigide worden en de indexen voor de maateenheidgroepen die de dimensie gebruiken, kunnen opnieuw worden opgebouwd.
Oplossing
Dit probleem is voor het eerst opgelost in de volgende cumulatieve updates voor SQL Server:
Cumulatieve update 14 voor SQL Server 2014
Cumulatieve update 4 voor SQL Server 2012 Service Pack 3
Cumulatieve update 13 voor SQL Server 2012 SP2
Cumulatieve update 7 voor SQL Server 2014 Service Pack 1
Informatie over cumulatieve updates voor SQL Server
Elke nieuwe cumulatieve update voor SQL Server bevat alle hotfixes en alle beveiligingspatches die deel uitmaakten van de vorige cumulatieve update. Bekijk de meest recente cumulatieve updates voor SQL Server:
Meest recente cumulatieve update voor SQL Server 2014
Meest recente cumulatieve update voor SQL Server 2012 SP3
Laatste cumulatieve update voor SQL Server 2012 SP2
Status
Microsoft heeft bevestigd dat dit een probleem is bij de Microsoft-producten die worden vermeld in de sectie Van toepassing op.
Meer informatie
Meer informatie over de terminologie die Microsoft gebruikt om software-updates te beschrijven.