Symptomen
Wanneer u probeert Microsoft Dynamics CRM configureren voor Microsoft Office Outlook, wordt het volgende foutbericht weergegeven:
"Er is een probleem opgetreden met de communicatie met de Microsoft Dynamics CRM-server. De server is mogelijk niet beschikbaar. Probeer het later opnieuw. Als het probleem zich blijft voordoen, neem dan contact op met uw systeembeheerder.
Error.AspNetInstallPath.Exception op Microsoft.Crm.Application.Outlook.Config.ConfigInfo.GetAspDotNetPath()
op Microsoft.Crm.Application.Outlook.Config.GlobalRepositoryConfigurator.SetLaptopClientRegistryValues()
op Microsoft.Crm.Application.Outlook.Config.GlobalRepositoryConfigurator.SetConfigurationRegistryValuesAction()
bij Microsoft.Crm.Application.Outlook.Config.GlobalRepositoryConfigurator.Configure (IProgressEventHandler progressEventHandler)
op Microsoft.Crm.Application.Outlook.Config.ConfigEngine.Configure (Object stateInfo)"
Oorzaak
Deze fout kan optreden als er een probleem met de installatie van Microsoft .NET Framework.
Oplossing
Optie 1
Downloaden en uitvoeren van het hulpprogramma Microsoft .NET Framework.
Optie 2 (Windows 8 of hoger)
Verwijderen en opnieuw installeren van .NET Framework.
Opmerking: CRM 2013 voor Outlook gebruikmaakt van .NET Framework 4 of hoger. 2015 CRM voor Outlook maakt gebruik van .NET Framework 4.5 of hoger. 2016 CRM voor Outlook maakt gebruik van .NET Framework 4.5.2 of hoger.
1. toegang tot het Configuratiescherm en open vervolgens een programma (programma's en onderdelen) verwijderen.
2. Klik op Windows-onderdelen in- of uitschakelen.
3. de selectie van het .NET Framework te verwijderen en klik vervolgens op OK.
4. Klik op sluiten.
5. Klik op Windows-onderdelen in- of uitschakelen.
6. het .NET Framework en ook de optie ASP.NET inschakelen.
7. Klik op OK.
Optie 3 (Windows 7)
Het .NET Framework in software programma's herstellen
1. toegang tot het Configuratiescherm en open vervolgens een programma (programma's en onderdelen) verwijderen.
2. Selecteer het Microsoft .NET Framework en klik vervolgens op Verwijderen/wijzigen.
3. Selecteer de optie herstellen en klik op volgende.