Http-server heeft 404 NotFound-uitzondering geretourneerd bij het gebruik van serversynchronisatie in Microsoft Dynamics 365

Dit artikel biedt een oplossing voor het oplossen van de foutberichten die kunnen optreden wanneer u probeert een postvak in Microsoft Dynamics 365 te testen en in te schakelen.

Van toepassing op: Microsoft Dynamics C5 2016
Origineel KB-nummer: 3214661

Symptomen

Wanneer u een postvak test en inschakelt in Microsoft Dynamics 365 (voorheen bekend als Microsoft Dynamics CRM Online), treedt een van de volgende fouten op in het gebied Waarschuwingen:

  • Postvak <postvaknaam> is niet gesynchroniseerd omdat er een fout is opgetreden tijdens het maken van verbinding met de e-mailserver. De eigenaar van het gekoppelde e-mailserverprofiel <Email Serverprofielnaam> is op de hoogte gesteld.
  • Postvak <PostvakNaam> synchroniseert geen afspraken, contactpersonen en taken omdat er een fout is opgetreden tijdens het maken van verbinding met de Microsoft Exchange-server. De eigenaar van het gekoppelde e-mailserverprofiel <Email Serverprofielnaam> is op de hoogte gesteld.
  • Het e-mailbericht Testbericht kan niet worden verzonden omdat er een fout is opgetreden tijdens het maken van verbinding met de e-mailserver. Postvak <postvaknaam> is niet gesynchroniseerd. De eigenaar van het gekoppelde e-mailserverprofiel <Email Serverprofielnaam> is op de hoogte gesteld.

Elk van de bovenstaande fouten bevat ook de volgende foutcode:

Email Server Foutcode: Http-server heeft 404 NotFound-uitzondering geretourneerd.

Oorzaak

Deze fout kan een van de volgende oorzaken hebben:

  1. Het postvak voor de gebruiker kan niet worden gevonden omdat het e-mailadres niet juist is of omdat het postvak momenteel niet beschikbaar is.
  2. De configuratie van het gekoppelde Email-serverprofiel is niet correct geconfigureerd om het postvak te kunnen vinden.

Oplossing

Gebruik de volgende stappen om dit probleem op te lossen:

  1. Controleer of het e-mailadres van de postvakrecord in Microsoft Dynamics 365 overeenkomt met het e-mailadres in Exchange. De fout bevat een koppeling naar de postvakrecord in Microsoft Dynamics 365. U kunt deze koppeling gebruiken om snel het veld Email Adres te controleren. Als het e-mailadres juist is, controleert u of het postvak beschikbaar is door het te openen met uw e-mailtoepassing, zoals Microsoft Outlook of Outlook Web Access.
  2. Controleer de configuratie van het gekoppelde Email-serverprofiel. Als u Microsoft Dynamics 365 (online) gebruikt met Exchange on-premises, controleert u of u een Exchange Server (hybride) e-mailserverprofiel gebruikt. Gebruik alleen een Exchange Online-profiel voor gebruikers met postvakken in Exchange Online.

Meer informatie

Wanneer u Details weergeven selecteert, ziet u foutdetails zoals de volgende:

ActivityId: <GUID>
Fout: System.Net.WebException: De aanvraag is mislukt met HTTP-status 404: Niet gevonden.
at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage-bericht, WebResponse-antwoord, Stream responseStream, Booleaanse asyncCall)
op System.Web.Services.Protocols.SoapHttpClientProtocol.EndInvoke(IAsyncResult asyncResult)
at Microsoft.Crm.Asynchronous.EmailConnector.ExchangeServiceBinding.EndFindItem(IAsyncResult asyncResult)
op Microsoft.Crm.Asynchronous.EmailConnector.FindItemsStep.EndCall()
op Microsoft.Crm.Asynchronous.EmailConnector.ExchangeIncomingEmailProviderStep.EndOperation()

ActivityId: <GUID>
Fout: System.Net.WebException: De aanvraag is mislukt met HTTP-status 404: Niet gevonden.
at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage-bericht, WebResponse-antwoord, Stream responseStream, Booleaanse asyncCall)
op System.Web.Services.Protocols.SoapHttpClientProtocol.EndInvoke(IAsyncResult asyncResult)
at Microsoft.Crm.Asynchronous.EmailConnector.ExchangeServiceBinding.EndCreateItem(IAsyncResult asyncResult)
op Microsoft.Crm.Asynchronous.EmailConnector.ExchangeOutgoingEmailProvider.EndCreateItem()

T:593
ActivityId: <GUID>
Uitzondering: niet-verwerkte uitzondering: Microsoft.Exchange.WebServices.Data.ServiceRequestException: De aanvraag is mislukt. De externe server heeft een fout geretourneerd: (404) Niet gevonden.
at Microsoft.Exchange.WebServices.Data.ServiceRequestBase.EndGetEwsHttpWebResponse(IEwsHttpWebRequest request, IAsyncResult asyncResult)
at Microsoft.Exchange.WebServices.Data.SimpleServiceRequestBase.EndInternalExecute(IAsyncResult asyncResult)
at Microsoft.Exchange.WebServices.Data.MultiResponseServiceRequest'1.EndExecute(IAsyncResult asyncResult)
at Microsoft.Exchange.WebServices.Data.ExchangeService.EndSyncFolderHierarchy(IAsyncResult asyncResult)
at Microsoft.Crm.Asynchronous.EmailConnector.MonitoredExchangeService.EndSyncFolderHierarchy(IAsyncResult asyncResult)
at Microsoft.Crm.Asynchronous.EmailConnector.ExchangeSyncSteps.ExchangeSyncAsyncRemoteStep'2.AfterCall()
at Microsoft.Crm.Asynchronous.EmailConnector.ExchangeSyncSteps.ExchangeSyncAsyncRemoteStep'2.E...