Kan geen verbinding maken met Microsoft Dynamics CRM serverfout treedt op wanneer u Microsoft Dynamics CRM 2013 voor Microsoft Office Outlook probeert te verbinden met CRM Online

Dit artikel biedt een oplossing voor een fout die optreedt wanneer u Microsoft Dynamics CRM 2013 voor Microsoft Office Outlook probeert te verbinden met CRM Online.

Van toepassing op: Microsoft Dynamics CRM Online
Origineel KB-nummer: 3089686

Symptomen

Wanneer u Microsoft Dynamics CRM 2013 voor Microsoft Office Outlook (Outlook-client) probeert te verbinden met een CRM Online-organisatie, wordt het volgende foutbericht weergegeven:

'Kan geen verbinding maken met Microsoft Dynamics CRM server omdat uw referenties niet kunnen worden geverifieerd. Controleer uw verbinding of neem contact op met de beheerder voor meer hulp.

Wanneer u Details selecteert, ziet u de volgende aanvullende details:

De waarde mag niet null zijn.
Parameternaam: pad1
op System.IO.Path.Combine(Tekenreekspad1, Tekenreekspad2)
op Microsoft.Crm.Passport.IdCrl.FederationLogOnManager.. ctor(tekenreeksomgeving)
op Microsoft.Crm.Outlook.ClientAuth.PassportAuthProvider'1.GetLogonManager()
op Microsoft.Crm.Outlook.ClientAuth.PassportAuthProvider'1.SignIn()
at Microsoft.Crm.Outlook.ClientAuth.ClientAuthProvidersFactory'1.SignIn(Uri endPoint, Credential credentials, AuthUIMode uiMode, IClientOrganizationContext context, Form parentWindow, Boolean retryOnError)
op Microsoft.Crm.Application.Outlook.Config. DeploymentsInfo.DeploymentInfo.LoadOrganizations(AuthUIMode uiMode, Form parentWindow, Credential credentials)
op Microsoft.Crm.Application.Outlook.Config. DeploymentsInfo.InternalLoadOrganizations(OrganizationDetailCollection orgs, AuthUIMode uiMode, Form parentWindow)

Oorzaak

De Microsoft Online Services-aanmeldingsassistent is niet geïnstalleerd of de juiste gebruikersnaam en het juiste wachtwoord zijn niet opgegeven. Als het probleem wordt veroorzaakt door een onjuiste gebruikersnaam of een onjuist wachtwoord, kunnen dit de referenties zijn die in de cache worden opgeslagen in Windows Credential Manager.

Oplossing

Als de Microsoft Online Services-aanmeldingsassistent niet is geïnstalleerd, installeert u deze met behulp van de juiste koppeling hieronder. Sluit na de installatie de wizard Microsoft Dynamics CRM voor Microsoft Office Outlook configuratie en open deze opnieuw.

Als de Microsoft Online Services-aanmeldingsassistent al is geïnstalleerd en u deze fout nog steeds ontvangt, selecteert u OK . U ziet een prompt voor uw gebruikersnaam en wachtwoord. Als de gebruikersnaam en het wachtwoord al zijn ingevuld, geeft dit aan dat de referenties in de cache zijn opgeslagen. Voer de juiste gebruikersnaam en het juiste wachtwoord opnieuw in om ervoor te zorgen dat er geen onjuiste referenties worden gebruikt.

Opmerking

Als u wilt weergeven of referenties zijn opgeslagen in Windows Credential Manager, selecteert u het menu Start in Windows en typt u Referentiebeheer. In het gebied Algemene referenties ziet u mogelijk referenties die beginnen met Microsoft_CRM. Als u uw wachtwoord hebt gewijzigd of een ander gebruikersaccount gebruikt, zijn deze opgeslagen referenties mogelijk niet juist. Deze referenties kunnen worden verwijderd, waardoor de Microsoft Dynamics CRM voor Microsoft Office Outlook ze niet kunnen gebruiken wanneer u verbinding probeert te maken.

Als uw CRM Online-organisatie al is bijgewerkt naar update 2015 (7.0 of hoger), kunt u Microsoft Dynamics CRM 2015 voor Microsoft Office Outlook gebruiken die niet afhankelijk is van de Microsoft Online Services-aanmeldingsassistent.

Meer informatie

Als de Microsoft Online Services-aanmeldingsassistent niet is geïnstalleerd, bevat het logboekbestand de volgende fout:

19:23:00| Fout | Fout bij het maken van verbinding met URL: https://disco.crm.dynamics.com/XRMServices/2011/Discovery.svc Uitzondering: System.DllNotFoundException: De Microsoft Online Services-aanmeldingsassistent is niet geïnstalleerd. 32-bits: https://g.microsoftonline.com/0BX00en/500 64-bits: https://g.microsoftonline.com/0BX00en/501