Er is een algemene fout opgetreden bij het ontvangen van een e-mailfout bij het testen en inschakelen van een postvak in Microsoft Dynamics 365

Dit artikel biedt een oplossing voor een fout die optreedt wanneer u probeert een postvak te testen en in te schakelen in Microsoft Dynamics 365.

Van toepassing op: Microsoft Dynamics 365
Origineel KB-nummer: 4092736

Symptomen

Wanneer u probeert een postvak te testen en in te schakelen in Microsoft Dynamics 365, wordt het volgende foutbericht weergegeven:

'Er is een algemene fout opgetreden bij het ontvangen van e-mail. Postvak <postvaknaam> is niet gesynchroniseerd. De eigenaar van het gekoppelde e-mailserverprofielProfielnaam <> is op de hoogte gesteld.
Email Server Foutcode: Socket heeft uitzondering timedout geretourneerd."

Als u de sectie Details selecteert, ziet u mogelijk ook meer details, zoals de volgende tekst:

'Fout: System.Net.Sockets.SocketException (0x80004005): een verbindingspoging is mislukt omdat de verbonden partij na een bepaalde periode niet goed heeft gereageerd of omdat de verbinding is mislukt omdat de verbonden host niet heeft gereageerd op <de IP-adrespoort><>
op System.Net.Sockets.TcpClient.Connect(Hostnaam tekenreeks, Int32-poort)
at Microsoft.Crm.Asynchronous.EmailConnector.Pop3Client.Connect()"

Oorzaak

Deze fout kan optreden als de poortwaarden in de sectie Geavanceerd van het e-mailserverprofiel niet juist zijn.

Oplossing

  1. Navigeer naar Instellingen, Email Configuratie en selecteer vervolgens Email Serverprofielen.

  2. Open het Email-serverprofiel dat wordt gebruikt door het postvak dat aan deze fout voldoet.

    Opmerking

    U kunt ook de naam van het Email Server-profiel selecteren in het foutbericht. Deze wordt weergegeven als een hyperlink waarmee de juiste record Email serverprofiel wordt geopend.

  3. Selecteer Geavanceerd.

  4. Controleer de waarden voor binnenkomende poort en uitgaande poorten selecteer opslaan.

    Opmerking

    Raadpleeg de documentatie van uw e-mailprovider voor de juiste poorten die u kunt gebruiken bij het maken van verbinding met de SMTP-service. Voor Gmail is de binnenkomende POP3-poort 995 en de uitgaande SMTP-poort 587.

  5. Selecteer Postvakken en selecteer vervolgens het postvak dat de fout heeft ontvangen.

  6. Selecteer de knop Test & Postvakken inschakelen .

  7. Nadat de tests zijn voltooid, opent u de postvakrecord en bekijkt u de sectie Waarschuwingen als de resultaten niet worden weergegeven als Geslaagd.

Disclaimerinformatie van derden

De producten van derden die in dit artikel worden vermeld, worden vervaardigd door bedrijven die onafhankelijk zijn van Microsoft. Microsoft verleent dan ook geen enkele garantie, impliciet noch anderszins, omtrent de prestaties of de betrouwbaarheid van deze producten.