Foutbericht wanneer u probeert te installeren, upgraden of een Microsoft Dynamics CRM-client voor Outlook-computer configureren

Symptomen

Wanneer u probeert te installeren of een upgrade van een Microsoft Dynamics CRM-client voor Microsoft Office Outlook-computer, wordt het volgende foutbericht weergegeven:

Actie Microsoft.Crm.Config.Client.InstallAbpAction is mislukt.

Toegang is geweigerd. (Uitzondering op HRESULT: 0x80070005 (E_ACCESSDENIED))

Bovendien wordt een van de volgende foutberichten weergegeven.

Foutbericht 1Wanneer u een Microsoft Dynamics CRM 4.0-client voor Outlook-computer installeert, wordt het volgende foutbericht in het configuratielogboek:

12:58:46 | Fout | Uitzondering van de configuratie. System.Exception: Actie Microsoft.Crm.Config.Client.InstallAbpAction is mislukt. --->
System.UnauthorizedAccessException: De toegang is geweigerd. (Uitzondering op HRESULT: 0x80070005 (E_ACCESSDENIED))

op System.Runtime.InteropServices.Marshal.ThrowExceptionForHRInternal (Int32 errorCode, IntPtr errorInfo)

bij Microsoft.Crm.Config.Client.InstallAbpAction.Do (IDictionary-parameters)

op Microsoft.Crm.Setup.Common.Action.ExecuteAction (actie actie parameters IDictionary, Boolean ongedaan maken)

---Einde van inner exception stacktrace---

op Microsoft.Crm.Setup.Common.Action.ExecuteAction (actie actie parameters IDictionary, Boolean ongedaan maken)

bij Microsoft.Crm.Setup.Common.Installer.Install (IDictionary stateSaver)

bij Microsoft.Crm.Setup.Common.ComposedInstaller.InternalInstall (IDictionary stateSaver)

bij Microsoft.Crm.Setup.Common.ComposedInstaller.Install (IDictionary stateSaver)

bij Microsoft.Crm.Config.Client.ClientConfig.Install (IDictionary-gegevens)

op Microsoft.Crm.Config.Client.ClientConfig.Run() 12:58:46 | Uitgebreide | Configuratie mislukt 12:58:46 | Info | Er zijn geen Microsoft Dynamics CRM voor Outlook geconfigureerd:



Actie Microsoft.Crm.Config.Client.InstallAbpAction is mislukt.

Toegang is geweigerd. (Uitzondering op HRESULT: 0x80070005 (E_ACCESSDENIED))

Foutbericht 2Wanneer u een Microsoft Dynamics CRM 3.0-client voor Outlook-computer een upgrade uitvoert, wordt het volgende foutbericht in het installatielogboek:

UpgradeDatabase.Action

UpgradeDatabase.Started

Databasebestanden zoeken

Databasebestanden verplaatsen

Voltooide databaseacties

Het toewijzen van machtigingen voor S-1-5-21-682003330-616249376-1801674531-1112

C:\Program Files\Microsoft CRM\sql\v3_msde_mscrm.mdf

op System.Security.AccessControl.NativeObjectSecurity.CreateInternal (ResourceType resourceType, Boolean isContainer, String name, ingang SafeHandle, AccessControlSections includeSections, Boolean createByName, ExceptionFromErrorCode exceptionFromErrorCode, exceptionContext Object)

op System.Security.AccessControl.FileSystemSecurity... ctor (Boolean isContainer, String name, AccessControlSections, includeSections, Boolean isDirectory)

op System.Security.AccessControl.FileSecurity... ctor (String fileName, AccessControlSections, includeSections)

op System.IO.FileInfo.GetAccessControl() op Microsoft.Crm.Setup.Client.DatabaseInstaller.Upgrade (sessie-sessie)

op Microsoft.Crm.Setup.Client.ClientSetup.UpgradeDatabase (sessie-sessie)

Actie 10:33:09 beëindigd: InstallFinalize. De waarde 3 als resultaat.

Wanneer u de off line Outlook-Client versie van Microsoft Dynamics CRM 4.0 configureren, wordt voortdurend de volgende fout in modaal venster Opnieuw of annuleren :

Actie Microsoft.Crm.Config.Client.InstallPstAction is mislukt. LaunchOutlookInstallerProcess is mislukt.

Oorzaak

Dit probleem kan optreden als het bestand met de Microsoft Dynamics CRM niet volledig is verwijderd en de Microsoft Dynamics CRM-adresboek provider (ABP) zijn niet volledig verwijderd.

Oplossing

Oplossing 1

Een van de volgende methoden gebruiken voor dit probleem en probeer te installeren of een upgrade van een Microsoft Dynamics CRM-client voor Outlook-computer.

Methode 1: Als Microsoft Office Outlook 2007 is geïnstalleerd

  1. Outlook 2007 start.

  2. Klik in het menu Extra op Accountinstellingen.

  3. Klik op het tabblad Gegevensbestanden .

  4. Klik op Microsoft CRMen klik vervolgens op verwijderen.

  5. Klik op het tabblad Adresboeken .

  6. Klik op de Microsoft CRM-adresboeken klik vervolgens op verwijderen.

  7. Afsluiten van Outlook 2007.

Methode 2: Als Microsoft Office Outlook 2003 is geïnstalleerd

  1. Sluit Outlook 2003 af.

  2. Klik op Start, klik op Configuratiescherm, klik op Gebruikersaccountsen klik vervolgens op E-mail.

  3. Klik in het dialoogvenster E-mailinstellingen op Gegevensbestanden.

  4. Klik op Microsoft CRM, klikt u op verwijderenen klik vervolgens op sluiten.

  5. Klik in het dialoogvenster E-mailinstellingen op E-mailaccounts.

  6. Klik op of wijziging bestaande adreslijsten of adresboeken weergevenen klik vervolgens op volgende.

  7. Klik op de Microsoft CRM-adresboeken klik vervolgens op verwijderen.

  8. Klik op sluiten om het dialoogvenster E-mailinstellingen te sluiten.

Oplossing 2

Ga als volgt te werk:

  1. Start Outlook.

  2. Klik op Opties in het menu Extra .

  3. Klik op het tabblad E-mailinstellingen op E-mailaccounts.

  4. Selecteer Microsoft CRM-niet beschikbaarop het tabblad Gegevensbestanden en klik vervolgens op verwijderen.

Meer hulp nodig?

Uw vaardigheden uitbreiden
Training verkennen
Als eerste nieuwe functies krijgen
Deelnemen aan Microsoft insiders

Was deze informatie nuttig?

Bedankt voor uw feedback.

Hartelijk dank voor uw feedback! Het lijkt ons een goed idee om u in contact te brengen met een van onze Office-ondersteuningsagenten.

×