Fouten oplossen in Business Portal voor Microsoft Dynamics SL

Dit artikel biedt een oplossing voor fouten die optreden wanneer u toegang probeert te krijgen tot De Bedrijfsportal voor Microsoft Dynamics SL of naar een van de webpagina's van de Bedrijfsportal gaat.

Van toepassing op: Microsoft Dynamics SL 2011
Origineel KB-nummer: 2788387

Symptomen

Wanneer u toegang probeert te krijgen tot De Bedrijfsportal voor Microsoft Dynamics SL of naar een van de webpagina's van de Bedrijfsportal gaat, kan er een foutbericht worden weergegeven dat lijkt op een van de volgende berichten:

Serverfout in toepassing '/'.
Runtimefout
Beschrijving: er is een toepassingsfout opgetreden op de server. De huidige aangepaste foutinstellingen voor deze toepassing voorkomen dat de details van de toepassingsfout op afstand worden weergegeven (om veiligheidsredenen). Het kan echter worden bekeken door browsers die worden uitgevoerd op de lokale servercomputer.

Er is een onverwachte fout opgetreden.
Problemen met correlatie-id van Microsoft Sharepoint Foundation oplossen: xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxx

Oorzaak

Er is een probleem met bedrijfsportal. In het ontvangen bericht wordt het probleem echter niet adequaat beschreven.

Oplossing

Als u een bericht wilt ontvangen dat beschrijvender is en dat kan helpen bij het oplossen van problemen, wijzigt u het web.config-bestand. Volg hiervoor de stappen:

  1. Blader op de server die als host fungeert voor de bedrijfsportalwebsite naar de map inetpub op de BP-server.

  2. Zoek het web.config bestand (meestal in de C:\inetpub\wwwroot\wss\VirtualDirectories\80 map).

  3. Maak een back-up van het web.config-bestand.

  4. Open het bestand web.config in Kladblok.

  5. Zoek de waarde Callstack="False" en wijzig deze in Callstack="True".

  6. Zoek de waarde CustomErrors mode= 'Aan' en wijzig deze in CustomErrors mode="Uit".

  7. Sla het Web.config-bestand op.

  8. Voer iisreset de opdracht uit om de wijzigingen in het Web.config-bestand in te schakelen. Volg deze stappen om dit te doen:

    1. Selecteer start op de server waarop de bedrijfsportal is geïnstalleerd en selecteer vervolgens Uitvoeren.

    2. Typ de volgende opdracht in het vak Openen en druk op Enter:

      iisreset
      
  9. Ga naar de bedrijfsportal of de webpagina en noteer het bericht dat wordt gegenereerd.