Met Systeembestandscontrole (SFC) worden de bestanden van Windows Defender PowerShell-module niet goed gemarkeerd.

Symptomen

Het hulpprogramma Systeembestandscontrole (SFC) bevat bestanden die zijn opgeslagen in de map%windir%\System32\WindowsPowerShell\v1.0\Modules\Defender als beschadigd of beschadigd. Als dit probleem zich voordoet, ziet u een foutmelding die er ongeveer als volgt uitziet: 

Hashes voor het bestands onderdeel komen niet overeen.

Oorzaak

Dit is een bekend probleem in Windows 10, versie 1607 en latere versies, en Windows Defender versie 4.18.1906.3 en nieuwere versies tot versie 4.8.1908.

De bestanden voor de Windows Defender PowerShell-module die zich bevinden in%windir%\System32\WindowsPowerShell\v1.0\Modules\Defender verzenden als onderdeel van de Windows-afbeelding. Deze bestanden zijn catalogus ondertekend. De onderdelen van de beheerbaarheid van Windows Defender hebben echter een nieuw (OOB) update kanaal. Dit kanaal vervangt de oorspronkelijke bestanden met bijgewerkte versies die zijn ondertekend met een Microsoft-certificaat dat het Windows-besturingssysteem vertrouwt. Door deze wijziging worden met SFC de bijgewerkte bestanden gemarkeerd alshashes voor het bestands onderdeel niet overeenkomen.

In toekomstige versies van Windows worden de bijgewerkte bestanden in de Windows-afbeelding gebruikt. Wanneer deze wijziging is doorgevoerd, worden de bestanden niet meer gemarkeerd met SFC.

Oplossing

Dit probleem is opgelost in de versie 4.8.1908 update voor Windows Defender. Nadat deze update is toegepast, worden PowerShell-bestanden die deel uitmaken van de Windows-afbeelding niet gewijzigd en worden deze bestanden niet meer gemarkeerd met het hulpprogramma SFC. Computers met Internet verbinding die zijn geabonneerd op Windows Update kanaal, automatisch de update downloaden en installeren.

Met het hulpprogramma DISM kunt u de Windows-afbeeldingsbestanden herstellen op computers waarop dit probleem optreedt. Open hiervoor een venster met een opdracht prompt op de desbetreffende computer en voer de volgende opdrachten uit:

   dism /online /cleanup-image /restorehealth
   sfc /scannow

Als deze opdrachten mislukt en een foutbericht worden weergegeven dat lijkt op ' bestand niet gevonden ', controleert u of het bestand install. Wim toegankelijk is en voert u de volgende opdrachten uit:

   DISM /Online /Cleanup-Image /RestoreHealth /Source:WIM:c:\install.wim:1 /LimitAccess
   sfc /scannow

Zie een Windows-afbeelding herstellenvoor meer informatie over herstel opdrachten.

Meer hulp nodig?

Uw vaardigheden uitbreiden
Training verkennen
Als eerste nieuwe functies krijgen
Deelnemen aan Microsoft insiders

Was deze informatie nuttig?

Bedankt voor uw feedback.

Hartelijk dank voor uw feedback! Het lijkt ons een goed idee om u in contact te brengen met een van onze Office-ondersteuningsagenten.

×