Microsoft Dynamics CRM voor telefoon en tablets kan geen verbinding maken met de Dynamics CRM-organisatie vanwege de lengte van tokenLifetime

Dit artikel biedt een oplossing voor het probleem dat Microsoft Dynamics CRM voor telefoon en tablets geen verbinding kan maken met de Dynamics CRM-organisatie vanwege de lengte van de TokenLifetime eigenschap.

Van toepassing op: Microsoft Dynamics CRM 2013, Microsoft Dynamics CRM 2013 Service Pack 1
Origineel KB-nummer: 3034570

Symptomen

Bij het instellen van een Microsoft Dynamics CRM organisatie in een van de Microsoft Dynamics CRM mobiele clienttoepassingen, komt verificatie in een oneindige lus terecht waarin de toepassing lijkt te proberen een bepaalde verificatie uit te voeren, maar niet wordt voltooid.

Oorzaak

Groter dan de standaardwaarden voor de TokenLifetime eigenschap in AD FS voor de Relying Party kan deze verificatielus veroorzaken.

Oplossing

De aanbevolen waarde van de TokenLifetime moet worden ingesteld op de standaardwaarde 0, wat 600 minuten of 10 uur betekent. Als u in plaats daarvan de optie SSOLifetime in de federation-service gebruikt, kunnen gebruikers hun referenties niet te vaak invoeren in deze Microsoft Dynamics CRM mobiele toepassingen. De standaardwaarde van SSOLifetime is 480 minuten of 8 uur.

Meer informatie

Zie Set-ADFSProperties voor informatie over het wijzigen van de eigenschap SSO Lifetime van de ADFS.

Zie Op claims gebaseerde verificatie en verloop van beveiligingstoken voor informatie over het wijzigen TokenLifetime van de eigenschap van de ADFS Relying Party via PowerShell.