Regels voor het automatisch maken van records mislukken wanneer de afzender van het e-mailbericht een contactpersoon en een gebruiker in Microsoft Dynamics CRM

Dit artikel biedt een oplossing voor de fout U moet een bovenliggende contactpersoon of account opgeven die optreedt wanneer regels voor het automatisch maken van records mislukken.

Van toepassing op: Microsoft Dynamics CRM 2015
Origineel KB-nummer: 3094208

Symptomen

Regels voor het automatisch maken van records mislukken wanneer de afzender van het e-mailbericht een contactpersoon en een gebruiker in Microsoft Dynamics CRM is. Wanneer u de systeemtaak Regelitem opent, ziet u of het mislukt met de volgende fout:

U moet een bovenliggende contactpersoon of account opgeven.

Oorzaak

Dit is een bekend probleem en is gepland om te worden opgelost in een update van Microsoft Dynamics CRM Online september.

Oplossing

Zodra deze oplossing is toegepast op de Microsoft Dynamics CRM Online organisatie, moet u de regel voor het automatisch maken van records uitschakelen, de stap case maken verwijderen in het regelitem en de stap voor het maken van case opnieuw maken. Dit moet worden gedaan, omdat de oplossing nieuwe dynamische waarde-slugs bevat die moeten worden gemaakt in de out-of-box velden Klant en Contactpersoon. Om dit te doen:

  1. Ga naar Instellingen>Servicebeheer>Regels voor automatisch maken en bijwerken van records.
  2. Selecteer het vinkje naast de regel en selecteer Deactiveren.
  3. Open vervolgens de regel voor automatisch maken van records.
  4. Selecteer om het opgegeven regelitem te openen.
  5. Selecteer onder Acties de stap Case maken en selecteer Deze stap verwijderen. Sla het formulier op.
  6. Voeg de actie opnieuw toe aan Case maken.
  7. Selecteer Eigenschappen instellen en voeg eventuele aangepaste toewijzingen opnieuw toe. De out-of-box velden Klant en Contactpersoon worden automatisch ingevuld op {null(Kanaaleigenschappen)}. Deze waarde moet behouden blijven om ervoor te zorgen dat de Email oplossing correct correleert met de contactpersoon of het account. Als deze waarde wordt gewijzigd, kan deze niet handmatig opnieuw worden ingesteld en moet de stap Case maken worden verwijderd en opnieuw worden gemaakt.
  8. Sla het formulier op,
  9. Schakel de regel voor automatisch maken van records opnieuw in.

Meer informatie

Met het huidige ontwerp van regels voor automatisch maken van records wordt de afzender van een Email niet omgezet als deze alleen bestaat als gebruiker in Microsoft Dynamics CRM. Het moet ook bestaan als een contactpersoon of account en kan automatisch als contactpersoon worden gemaakt wanneer deze wordt ontvangen. Als u de afzender van de Email automatisch als contactpersoon wilt maken, schakelt u het selectievakje Records maken voor e-mail van onbekende afzenders in de regel voor automatisch maken van records in. Als dit vak niet is gemarkeerd, wordt het e-mailadres niet opgelost en wordt de regel niet geactiveerd.