Werkstroom die een groot aantal systeemtaken en logboeken genereert

Dit artikel biedt een oplossing voor het probleem dat een asynchrone werkstroom een groot aantal systeemtaken en logboeken maakt.

Van toepassing op: Microsoft Dynamics 365
Origineel KB-nummer: 4562256

Symptomen

Een asynchrone werkstroom wordt snel aangeroepen gedurende een korte periode, waardoor een groot aantal systeemtaken wordt gegenereerd. Hierdoor wordt de asynchrone service belast, waardoor er een piek ontstaat in de achterstand die moet worden verwerkt, wat resulteert in prestatievermindering die uiteindelijk van invloed is op alle systeemtaken. Het veroorzaakt ook een toename van de databasegrootte vanwege het grote aantal asynchrone bewerkingen en bijbehorende werkstroomlogboeken.

Oorzaak

Wanneer een asynchrone werkstroom wordt geactiveerd en geactiveerd, worden nieuwe taken in de wachtrij geplaatst door Microsoft Dynamics 365 Asynchrone service en verwerkt op basis van beschikbare resources.

Onder bepaalde omstandigheden kan een asynchrone werkstroom uiteindelijk meerdere keren snel worden aangeroepen, waardoor in korte tijd een groot aantal systeemtaken wordt gemaakt. Dit gebeurt vanwege een bulkbewerking die de werkstroom agressief activeert of vanwege een onjuiste logica binnen een andere werkstroom en/of invoegtoepassing die deze met hoge frequentie aanroept.

De resources die beschikbaar zijn voor de asynchrone service zijn beperkt en als de achterstand wordt opgevuld door een dergelijke op hol geslagen werkstroom, is prestatievermindering die in grote lijnen van invloed is op alle systeemtaken gebruikelijk. Bovendien neemt de databasegrootte ook toe vanwege het grote aantal taken dat in een dergelijk scenario wordt gegenereerd.

Oplossing

In dergelijke gevallen kan de asynchrone werkstroominfrastructuur zichzelf tot op zekere hoogte herstellen zodra de geïdentificeerde werkstroom is gedeactiveerd. Hieronder vindt u de stappen om dit te bereiken:

  1. Navigeer naar Instellingen>processen en selecteer de relevante werkstroom. U kunt ook de werkstroom zoeken met behulp van Geavanceerd zoeken.
  2. Nadat deze optie is geselecteerd, selecteert u Deactiveren om de werkstroom uit te schakelen en in te stellen op Conceptstatus . Als u dat niet nodig hebt, kunt u de werkstroom op dit moment ook verwijderen.

Zodra de bovenstaande stappen zijn uitgevoerd, worden er geen nieuwe taken meer gemaakt. Bovendien worden alle taken die al zijn gemaakt en in de asynchrone wachtrij zijn geplaatst vóór deactivering, maar die nog niet zijn opgehaald voor verwerking , onmiddellijk geannuleerd wanneer ze worden opgehaald voor verwerking. Dit helpt om de asynchrone achterstand sneller te verwijderen.

De resterende taken die al worden uitgevoerd , blijven ongewijzigd en worden voltooid zoals verwacht. De achterstand zal in de loop van de tijd geleidelijk aflopen om te herstellen naar het nominale niveau.