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    Pomoc techniczna Microsoft

    Resolve problems with mouse button or scrolling settings

    Zawartość udostępniana przez firmę Microsoft

    Zawartość udostępniana przez firmę Microsoft

    Dotyczy: Microsoft Arc MouseMicrosoft Basic Optical MouseComfort Optical Mouse 1000Comfort Optical Mouse 3000Habu Laser Gaming MouseMicrosoft Explorer MouseMicrosoft Explorer Mini MouseMicrosoft Mobile Memory Mouse 8000Microsoft Natural Wireless Laser Mouse 6000Microsoft Notebook Optical MouseMicrosoft Notebook Optical Mouse 3000Microsoft SideWinder MouseMicrosoft Wireless Mobile Mouse 3000Microsoft Wireless Notebook Presenter Mouse 8000Microsoft Wireless Wheel Mouse Więcej


    Symptoms


    After you try to change the button or scrolling settings for any one of the Microsoft mouse devices that are listed in the "Applies to" section, you experience one of the following issues:
    • All the button assignments are reset to their default settings.
    • You cannot change the button assignments for your pointing device.
    • Button assignment commands in the IntelliPoint software are unavailable ("dimmed").
    • Scrolling is too slow or too fast in specific applications.
    • You receive the following error message:
      Some mouse settings might not work until you connect a Microsoft mouse to a USB port on your computer or set up a Microsoft mouse that uses Bluetooth technology

    Cause


    This can be because of any of the following reasons:
    • Incorrect mouse is selected in IntelliPoint software.
    • Conflict with other (non-Microsoft) mouse or pointer software,
    • Problem with the IntelliPoint software or drivers.
    • Application does not correctly recognize scrolling messages from the mouse.

    Resolution


    To resolve this issue, first visit the following Web site to download and install the latest IntelliPoint software:
    http://www.microsoft.com/hardware/download/download.aspx?category=MK

    If that does not resolve the problem, try the following methods.

    Method 1: Select the correct Microsoft mouse and connect to a USB port


    The IntelliPoint software tabs that are displayed depend on the mouse that is connected. For example, the Wireless tab is displayed only if you are using a wireless mouse.
    1. If an IntelliPoint software tab that is appropriate for your mouse is not displayed, make sure that you have the correct mouse selected on the Buttons tab.
    2. After you change the mouse selection, close the IntelliPoint control panel, and then open it again.
    3. Try to connect the USB wired mouse or the receiver to a different USB port, and then check the behavior. By trying the receiver on different ports, you can eliminate any issues with the port.
      Note Bypass any port replicators, USB hubs, KVM switches, and so on, and connect the receiver directly to the ports.
    4. Make sure that the name of the connected device is the same as the mouse that you are using.

    Method 2: Uninstall any conflicting mouse software

    If you have any other mouse software that is installed, such as Logitech or touchpad software, that software may conflict with your mouse. To uninstall software that may conflict, follow these steps:
    1. If you have a Windows Vista or Windows 7 computer, open the Programs and Features item in Control Panel. To do this, click Start
      windows icon
      , type appwiz.cpl in the Start Search box, and then press ENTER.

      If you have a Windows XP-based computer, open the Add or Remove Programs item in Control Panel. To do this, click Start, click Run, type appwiz.cpl, and then click OK.
    2. Follow the instructions to remove the software, and then restart the computer.
       
    Note If you are using a laptop, install the latest touchpad driver from the manufacturer's Web site. For help, contact the manufacturer. For manufacturer contact information, visit the following Microsoft Web site:
    http://support.microsoft.com/default.aspx?pr=oemphone
    If the issue continues to occur, go to the next method.

    Method 3: Perform a clean "boot," and then reinstall the IntelliPoint software

    Step 1: Restart the computer by using a clean startup

    When you start Microsoft Windows, other software may start together with the operating system. These programs may include antivirus and system programs that may interfere with your mouse. When you perform a clean startup before you start Setup, you prevent these programs from starting automatically.


    For more information about how to perform a clean startup, click one of the following article numbers, as appropriate for your version of Windows:

    310353 How to configure Windows XP to start in a "clean boot" state
     
    929135 How to troubleshoot a problem by performing a clean boot in Windows Vista or in Windows 7
     

    Step 2: Remove and reinstall the IntelliPoint software

    1. View the list of programs that are installed on the computer. To view the list of programs that are installed on a Windows Vista or Windows 7 computer, open the Programs and Features item in Control Panel. To do this, click Start
      windows icon
      , type appwiz.cpl in the Start Search box, and then press ENTER.

      To view the list of programs that are installed on a Windows XP-based computer, click Start, click Run, type appwiz.cpl, and then click OK.
    2. Remove Microsoft IntelliPoint. To do this in Windows Vista, click Microsoft IntelliPoint, and then click Uninstall/Change.

      Notice icon
       If you are prompted for an administrator password or for a confirmation, type the password, or click Continue. Click Yes to confirm that you want to remove the program.

      To remove IntelliPoint from a Windows XP-based computer, click Microsoft IntelliPoint, click
      Add/Remove, click Finish, and then click
      OK.
    3. Restart the computer.
    4. Reinstall the IntelliPoint software.
    If this method does not resolve the issue, follow these steps.

    Note Because there are several versions of Microsoft Windows, the following steps may be different on your computer. If they are, see your product documentation to complete these steps.

    Windows Vista or Windows 7

    1. Click Start
      windows icon
      , type devmgmt.msc in the Start Search box, and then press ENTER.

      Notice icon
       If you are prompted for an administrator password or for a confirmation, type the password, or click Continue.
    2. Double-click Mice and other pointing devices.
    3. Right-click your mouse, and then click Properties.
    4. On the Driver tab, click Update Driver.
    5. Follow the directions on the screen to complete the wizard.

    Windows XP

    1. Click Start, point to
      Settings, and then click Control Panel.
    2. Double-click System, click the
      Hardware tab, and then click Device Manager.
    3. Double-click the Mice and other pointing devices branch to expand it.
    4. Right-click you mouse, and then click Properties.
    5. On the Driver tab, click Update Driver.
    6. In the Upgrade Device Driver Wizard dialog box, click Next.
    7. Click Display a list of the known drivers, and then click Next.
    8. Select your mouse, and then click Next.
    9. Click Next to confirm that you have selected the correct driver.
    10. Click Finish to complete the installation of the new driver.
    To learn more about how to troubleshoot mouse devices in Windows Vista or Windows 7, follow the instructions in the "Troubleshoot USB device problems" topic in Windows Help and Support. To view the topic, follow these steps:
    1. Click Start
      windows icon
      , and then click Help and Support.
    2. In the Search Help box, type Troubleshoot USB device problems, and then click Search Help.
    3. Click the appropriate topic.
    If the issue continues to occur, visit the following Web site to download and install the latest IntelliPoint software:
    http://www.microsoft.com/hardware/download/download.aspx?category=MK

    Method 4: Start HID service

    To start the Human Interface Device (HID) service, follow these steps:
    1. Open Microsoft Management Console (MMC) snap-in for Services. To do this, follow the steps for your version of the operating system.
      • Windows Vista or Windows 7

        Click Start
        windows icon
        , type services.msc in the Start Search box, and then press ENTER.

        Notice icon
         If you are prompted for an administrator password or for confirmation, type the password, or click Continue.
      • Windows XP

        Click Start, click Run, type services.msc in the Open box, and then click OK.
    2. Open the HID service. To do this, follow the steps for your version of the operating system.
      • Windows Vista or Windows 7

        In the list of services in the details pane, double-click Human Interface Device Access.
      • Windows XP

        In the list of services in the details pane, double-click HID Input Service.
    3. Make sure that the Startup Type value is set to Automatic.
    If you receive an error when you start the HID service, click the following link to view the article in the Microsoft Knowledge Base:
    932875 Resolve Hotkeys or Volume control keys not working on Microsoft keyboards
     

    Method 5: Determine whether it is application specific


    With newer “high-resolution” mouse devices, some applications may not correctly interpret partial scrolling messages. When low resolution wheels scroll up and down, the mouse driver sends a scroll magnitude of 120 for each tick of the wheel up and 120 for each tick down. According to the official documentation, a scrolling value of 120 (or -120) indicates one line of scrolling. If the application receives less than a full line, it should either scroll part of a line (which is what Microsoft Word and some other applications do) or if that’s not possible, save up the value until a total of 120 is reached (which is what Notepad does). Most current Microsoft mouse devices are designed to give a smoother scroll experience, so the wheels are higher resolution and send four times as many scroll events, but at one-quarter of the magnitude. So instead of 120, they send 30 (or instead of -120 when scrolling back, they send -30). This should result in scrolling at the same speed, just more smoothly.

    Some applications may not handle this correctly.

    For example, they may ignore partial scroll events, or they may interpret a partial (30) event as a full line (120). There have been instances of some applications that actually combine both of these incorrect behaviors. For example, some applications may ignore the positive partial events and treat negative partial events as a full line, which would result in slow scrolling forward and fast scrolling backward.

    To test whether this is an application-specific problem, compare the behavior in that application to how scrolling works in Notepad or Microsoft Word.

     


    Ostatnia aktualizacja: 16.04.2018
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