Pojawi się komunikat o błędzie "Usługa niedostępna" podczas przeglądania strony sieci Web usług IIS w wersji 6.0 na kontrolerze domeny z systemem Windows Server 2003

Objawy

Podczas przeglądania strony sieci Web znajdującej się na kontrolerze domeny systemu Microsoft Windows Server 2003, może zostać wyświetlony następujący komunikat o błędzie Błąd Active Server Pages (ASP) 5:

Usługa jest niedostępna
Ponadto następujące zdarzenie ostrzegawcze może rejestrowane w dzienniku zdarzeń systemowych:

Ponadto następujące zdarzenie błędu może być rejestrowane w dzienniku zdarzeń aplikacji:







Gdy używasz Filemon monitorowania aktywności, pojawi się komunikat o błędzie podobny do następującego:

3521 C:\WINDOWS\system32\inetsrv\ASP Utwórz w3wp.exe:3168 czasu skompilowany Templates\PID3168. ODMOWA DOSTĘPU TMP NT AUTHORITY\NETWORK SERVICE

Przyczyna


Ten problem może wystąpić, jeśli serwera, na którym jest uruchomiony program Microsoft Internet Information Services (IIS) w wersji 6.0 jest także kontrolerem domeny. Problem występuje, ponieważ pula aplikacji jest za pomocą konta NT Authority\Network Service, a konto NT Authority\Network Service może nie mieć uprawnień dostępu wymagane foldery.

Rozwiązanie


Aby rozwiązać ten problem, należy ręcznie ustawić uprawnienia dotyczące folderów dla grupy IIS_WPG, a następnie ustawić uprawnienia dotyczące folderów dla konta NT Authority\Network Service.



Aby automatycznie rozwiązać ten problem, przejdź do sekcji "Rozwiązywanie problemu". Jeśli użytkownik woli samodzielnie rozwiązać ten problem, przejdź do sekcji "Samodzielne rozwiązywanie problemu".

Automatyczne rozwiązywanie problemu



Aby automatycznie rozwiązać ten problem, kliknij przycisk Naprawlub łącze. Kliknij przycisk Uruchomw oknie dialogowym Pobieranie pliku i wykonaj kroki rozwiązywania problemu kreatora.



Uwagi
  • Ten kreator może być tylko w języku angielskim. Jednak naprawa automatyczna działa również w innych wersjach językowych systemu Windows.
  • Jeśli nie jesteś na komputerze, na którym występuje problem, możesz zapisać to rozwiązanie naprawy na pamięci USB lub dysku CD i uruchomić je na odpowiednim komputerze.

Następnie przejdź do sekcji"Czy problem został rozwiązany?" .



Samodzielne rozwiązywanie problemu


Aby ustawić uprawnienia dotyczące folderów dla grupy IIS_WPG, wykonaj następujące kroki:
  1. Uruchom Eksploratora Windows, a następnie otwórz następujący folder:
    %systemroot%\Help\iisHelp
  2. W prawym okienku kliknij prawym przyciskiem myszy folder wspólnych , a następnie kliknij polecenie Udostępnianie i zabezpieczenia.
  3. Kliknij kartę Zabezpieczenia , kliknij przycisk Dodaj, wpisz IIS_WPG, a następnie kliknij przycisk OK.
  4. Z IIS_WPG zaznaczone kliknij, aby zaznaczyć pola wyboru w kolumnie Zezwalaj , a następnie kliknij przycisk OK:
    • Odczyt i wykonanie
    • Wyświetlanie zawartości folderu
    • Odczyt
  5. Otwórz następujący folder:
    %systemroot%\system32\inetsrv
  6. W prawym okienku kliknij prawym przyciskiem myszy folder ASP Compiled Templates , a następnie kliknij polecenie Udostępnianie i zabezpieczenia.
  7. Kliknij kartę Zabezpieczenia , kliknij opcję grupy IIS_WPG , a następnie kliknij, aby zaznaczyć pole wyboru Pełna kontrola w kolumnie Zezwalaj . Kliknij przycisk OK.
  8. Otwórz następujący folder:
    %systemroot%
  9. W okienku po prawej stronie kliknij prawym przyciskiem myszy folder Skompresowany tymczasowych usług IIS , a następnie kliknij polecenie Udostępnianie i zabezpieczenia.
  10. Kliknij kartę Zabezpieczenia , kliknij opcję grupy IIS_WPG , a następnie kliknij, aby zaznaczyć pole wyboru Pełna kontrola w kolumnie Zezwalaj . Kliknij przycisk OK.
Aby ustawić uprawnienia dotyczące folderów dla konta NT Authority\Network Service, wykonaj następujące kroki:
  1. Uruchom Eksploratora Windows, a następnie otwórz następujący folder:
    %systemroot%\Help\iisHelp
  2. W prawym okienku kliknij prawym przyciskiem myszy folder wspólnych , a następnie kliknij polecenie Udostępnianie i zabezpieczenia.
  3. Kliknij kartę Zabezpieczenia , kliknij przycisk Dodaj, wpisz Usługa sieciowa, a następnie kliknij przycisk OK.
  4. Wybrana Usługa sieciowa kliknij, aby zaznaczyć pola wyboru w kolumnie Zezwalaj , a następnie kliknij OK:
    • Odczyt i wykonanie
    • Wyświetlanie zawartości folderu
    • Odczyt
  5. Otwórz następujący folder:
    %systemroot%\system32\inetsrv
  6. W prawym okienku kliknij prawym przyciskiem myszy folder ASP Compiled Templates , a następnie kliknij polecenie Udostępnianie i zabezpieczenia.
  7. Kliknij kartę Zabezpieczenia , kliknij przycisk Dodaj, wpisz Usługa sieciowa, a następnie kliknij przycisk OK.
  8. Grupa Usługa sieciowa zaznaczona kliknij, aby zaznaczyć pole wyboru Pełna kontrola w kolumnie Zezwalaj , a następnie kliknij przycisk OK.
  9. Otwórz następujący folder:
    %systemroot%
  10. W okienku po prawej stronie kliknij prawym przyciskiem myszy folder Skompresowany tymczasowych usług IIS , a następnie kliknij polecenie Udostępnianie i zabezpieczenia.
  11. Kliknij kartę Zabezpieczenia , kliknij przycisk Dodaj, wpisz Usługa sieciowa, a następnie kliknij przycisk OK.
  12. Grupa Usługa sieciowa zaznaczona kliknij, aby zaznaczyć pole wyboru Pełna kontrola w kolumnie Zezwalaj , a następnie kliknij przycisk OK.
Po wykonaniu tych kroków ponownie uruchom Administratora usług IIS z przystawki usługi lub przystawki Zarządzanie komputerem.

Obejście problemu

Można tymczasowo obejść ten problem przez ponowne uruchamianie Administratora usług IIS z przystawki usługi lub przystawki Zarządzanie komputerem.

Stan

Firma Microsoft potwierdziła, że jest to problem występujący w produktach firmy Microsoft wymienionych w sekcji „Dotyczy”.

Więcej informacji

Aby uzyskać dodatkowe informacje o podobnym problemie z inną przyczynę kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:

332097 polecenie DCPROMO nie zachowuje uprawnień dla niektórych folderów usług IIS


Czy problem został rozwiązany?

  • Sprawdź, czy problem został rozwiązany. Jeśli problem nie został rozwiązany, to koniec pracy z tą sekcją. Jeśli problem nie został rozwiązany, można skontaktować się z obsługą.
  • Będziemy wdzięczni za opinie. Aby przekazać swoją opinię lub zgłosić jakiekolwiek problemy dotyczące tego rozwiązania, zostaw komentarz w blogu "Rozwiązywanie problemu" lub Wyślij do nas wiadomość e-mail.
Właściwości

Identyfikator artykułu: 842493 — ostatni przegląd: 16.02.2017 — zmiana: 2

Opinia