Komputer zawiesza się, a zdarzenia oznaczone identyfikatorami 1030 i 1058 są rejestrowane podczas wznawiania ze stanu wstrzymania w systemie Windows Server 2003

Objawy

Po wznowieniu pracy komputera z systemem Windows Server 2003 ze stanu wstrzymania komputer może przestać odpowiadać. Może również zobaczyć okno komunikatu "Stosowanie ustawień osobistych", aby uzyskać maksymalnie godzinę przed pojawieniem się pulpitu.

Zazwyczaj po wznowieniu pracy komputera z systemem Windows Server 2003 ze stanu wstrzymania, komputer jest zablokowany. W związku z tym należy zalogować się do komputera przed można uzyskać dostęp do pulpitu. Jednak w przypadku wystąpienia tego problemu komputer nie jest zablokowany, a ekran logowania systemu Windows Server 2003 nie jest wyświetlany.

Ponadto komunikaty dotyczące następujących zdarzeń mogą być rejestrowane w dzienniku zdarzeń aplikacji na kontrolerze domeny po ponownym uruchomieniu komputera z systemem Windows Server 2003:
Typ zdarzenia: błąd
Źródło zdarzenia: Userenv
Kategoria zdarzenia: Brak
Identyfikator zdarzenia: 1058
Opis: System Windows nie może uzyskać dostępu do pliku gpt.ini dla obiektu GPO CN = {31B2F340-016D-11D2-945F-00C04FB984F9}, CN = Policies, CN = System, DC =domena, DC =com. Plik musi znajdować się w lokalizacji < \\ \sysvol\domain\Policies\{31B2F340-016D-11D2-945F-00C04FB984F9}\gpt.inidomeny>. (Odmowa dostępu.). Przerwano przetwarzanie zasady grupy. Aby uzyskać więcej informacji zobacz Pomoc i obsługa techniczna pod adresem http://support.microsoft.com.
lub
Opis: System Windows nie może uzyskać dostępu do pliku gpt.ini dla obiektu GPO CN = {31B2F340-016D-11D2-945F-00C04FB984F9}, CN = Policies, CN = System, DC =domena, DC =com. Plik musi znajdować się w lokalizacji < \\ \sysvol\domain\Policies\{31B2F340-016D-11D2-945F-00C04FB984F9}\gpt.inidomeny>. (Ścieżka sieciowa nie znaleziono.).

Typ zdarzenia: błąd
Źródło zdarzenia: Userenv
Kategoria zdarzenia: Brak
Identyfikator zdarzenia: 1030
Opis: System Windows nie może zapytać o listę obiektów zasady grupy. Komunikat, który opisuje przyczynę, został wcześniej zarejestrowany przez ten aparat zasad. Aby uzyskać więcej informacji zobacz Pomoc i obsługa techniczna pod adresem http://support.microsoft.com.
Po włączeniu środowiska użytkownika (Userenv) rejestrowanie usługi rozproszonego systemu plików (DFS, Distributed File System) domeny mogą nie działać po wznowieniu pracy komputera ze stanu wstrzymania. Ponadto może zostać wyświetlony wiadomości, które komunikaty podobne do następujących w pliku %SystemRoot%\Debug\UserMode\Userenv.log.

Uwaga Aby uzyskać informacje dotyczące sposobu włączania rejestrowania Userenv zobacz artykuł bazy wiedzy Microsoft Knowledge Base, który odwołuje się do sekcji "Materiały referencyjne".
Userenv(1d8.a84) 21:52:58:718 EvaluateDeferredGPOs: wyszukiwanie obiektów GPO w cn = policies, cn = system, DC =domena, DC = local
Userenv(1d8.a84) 21:52:58:718 ProcessGPO: wyszukiwanie < CN = {31B2F340-016D-11D2-945F-00C04FB984F9}, CN = Policies, CN = System, DC =domena, DC = local >
Userenv(1d8.a84) 21:52:58:718 ProcessGPO: komputer ma dostęp do tego obiektu GPO.
Userenv(1d8.a84) 21:52:58:718 ProcessGPO: obiekt GPO przeszedł sprawdzanie filtrem.
Userenv(1d8.a84) 21:52:58:718 ProcessGPO: znaleziono wersję funkcjonalności: 2
Userenv(1d8.a84) 21:52:58:718 ProcessGPO: znaleziono ścieżką systemu plików: < \\domeny.local\sysvol\domeny.local\Policies\{31B2F340-016D-11D2-945F-00C04FB984F9} >
Userenv(1d8.a84) 21:52:58:734 ProcessGPO: nie można odnaleźć pliku szablonu zasad grupy < \\.local\Policies\{31B2F340-016D-11D2-945F-00C04FB984F9}\gpt.inidomeny.local\sysvol\domeny>, błąd = 0x5.

Przyczyna

Ten problem może wystąpić, jeżeli proces Winlogon usiłuje przetwarzać zasady grupy przed uruchomieniem innych składników. Dodatek service pack, który opisano w tym artykule dodaje logikę ulepszającą domyślne zachowanie procesu Winlogon i usług stacji roboczej.

Jednak istnieje kilka scenariuszy, które mogą powodować ten problem. Upewnij się, że następujące składniki są uruchomione i czy poprawnie skonfigurowane, przed zastosowaniem tego dodatku service pack:
  • Usługi Netlogon i DFS są uruchomione.
  • Kontrolery domeny przeczytano i zastosowanie prawa do zasad kontrolerów domeny.
  • Uprawnienia systemu plików NTFS i uprawnienia udziału są ustawione poprawnie w udziale Sysvol.
  • Wpisy DNS są poprawne dla kontrolerów domeny.

Rozwiązanie

Aby rozwiązać ten problem, zobacz poniższą sekcję "Informacje dotyczące Service pack". Aby tymczasowo obejść ten problem, zobacz sekcję "Obejście problemu" w dalszej części tej sekcji "Rozwiązanie".

Informacje dodatku Service pack

Aby rozwiązać ten problem, należy uzyskać najnowszy dodatek service pack dla systemu Windows Server 2003. Aby uzyskać więcej informacji, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
889100 jak uzyskać najnowszy dodatek service pack dla systemu Windows Server 2003
Uwaga Po zainstalowaniu tego dodatku service pack, wróć do tego artykułu, aby wykonać procedurę opisaną w sekcji "Informacje dotyczące rejestru", który następuje bezpośrednio.

Informacje dotyczące rejestru

Uwaga Wykonaj następujące kroki w systemie Windows Server 2003.

Ważne Niniejsza sekcja, metoda lub zadanie zawiera informacje dotyczące modyfikowania rejestru. Jednak niepoprawne zmodyfikowanie rejestru może spowodować poważne problemy. W związku z tym upewnij się, że wykonujesz następujące kroki ostrożnie. Aby zapewnić sobie dodatkową ochronę, wykonaj kopię zapasową rejestru przed przystąpieniem do modyfikacji. Wtedy będziesz mógł przywrócić rejestr w przypadku wystąpienia problemu. Aby uzyskać więcej informacji na temat wykonywania kopii zapasowej i przywracania rejestru, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
322756 jak wykonać kopię zapasową i przywrócić rejestr w systemie Windows
Aby zakończyć procedurę dla Ciebie, przejdź do sekcji "Rozwiązywanie problemu". Jeśli użytkownik woli samodzielnie rozwiązać ten problem, przejdź do sekcji "Samodzielne rozwiązywanie problemu".

Automatyczne rozwiązywanie problemu



Aby automatycznie rozwiązać ten problem, kliknij przycisk Napraw lub łącze. W oknie dialogowym Pobieranie pliku kliknij przycisk Uruchom , a następnie wykonaj kroki rozwiązywania problemu to kreatora.



Uwagi
  • Należy zainstalować dodatek service pack w sekcji "Informacje dotyczące Service pack" pierwszy przed uruchomieniem pakietu.
  • Ten kreator może być tylko w języku angielskim. Jednak naprawa automatyczna działa również w innych wersjach językowych systemu Windows.
  • Jeśli nie jesteś na komputerze, na którym występuje problem, możesz zapisać to rozwiązanie naprawy na pamięci USB lub dysku CD i uruchomić je na odpowiednim komputerze.

Następnie przejdź do sekcji"Czy problem został rozwiązany?" .



Samodzielne rozwiązywanie problemu

Po zastosowaniu tego dodatku service pack, wykonaj następujące kroki:
  1. Kliknij przycisk Start, kliknij polecenie Uruchom, wpisz polecenie regedit w polu Otwórz , a następnie kliknij przycisk OK.
  2. W Edytorze rejestru zlokalizuj następujący podklucz rejestru:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon
  3. Jeśli brakuje wpisu WaitForNetwork należy dodać wpis. Aby to zrobić, wykonaj następujące kroki:
    1. Kliknij prawym przyciskiem myszy podklucz usługi Winlogon , kliknij polecenie Nowy, a następnie kliknij Polecenie wartość Dword.
    2. W polu Nazwa wartości wpisz WaitForNetwork.
  4. Kliknij prawym przyciskiem myszy WaitForNetwork, a następnie kliknij polecenie Modyfikuj.
  5. W oknie dialogowym Edytowanie wartości DWORD w polu Dane wartości wpisz wartość 1, a następnie kliknij przycisk OK.
  6. Zamknij Edytor rejestru.

Czy problem został rozwiązany?

  • Sprawdź, czy problem został rozwiązany. Jeśli problem nie został rozwiązany, to koniec pracy z tą sekcją. Jeśli problem nie został rozwiązany, można skontaktować się z obsługą.
  • Będziemy wdzięczni za opinie. Aby przekazać swoją opinię lub zgłosić jakiekolwiek problemy dotyczące tego rozwiązania, zostaw komentarz w blogu "Rozwiązywanie problemu" lub Wyślij wiadomość e-mail .

Obejście problemu

Aby tymczasowo obejść ten problem, można uruchomić plik Dfsutil.exe uwzględniony w narzędziach obsługi systemu Windows Server 2003. Narzędzia obsługi systemu Windows Server 2003 można zainstalować na dwa sposoby. Można uruchomić plik \\Support\Tolls\Suptools.msi z dysku CD-ROM systemu Windows Server 2003. Lub można wyodrębnić narzędzia obsługi bezpośrednio z pliku \\Support\Tools\Support.cab. Aby uruchomić plik Dfsutil.exe, wykonaj następujące kroki:
  1. Kliknij przycisk Start, kliknij polecenie Uruchom, wpisz polecenie cmd, a następnie kliknij OK.
  2. W wierszu polecenia wpisz dfsutil/purgemupcache, a następnie naciśnij klawisz ENTER.

Stan

Firma Microsoft potwierdziła, że jest to problem występujący w produktach firmy Microsoft wymienionych w sekcji „Dotyczy”.
Ten problem został po raz pierwszy rozwiązany w dodatku Service Pack 1 dla systemu Windows Server 2003.

Powiązane artykuły

Aby uzyskać więcej informacji na temat włączania rejestrowania środowiska użytkownika kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
221833 włączania debugowania środowiska użytkownika rejestrowania w detalicznych kompilacjach systemu Windows
Właściwości

Identyfikator artykułu: 842804 — ostatni przegląd: 16.02.2017 — zmiana: 2

Microsoft Windows Server 2003, Enterprise Edition (32-bit x86), Microsoft Windows Server 2003, Standard Edition (32-bit x86)

Opinia